aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2011-06-06 13:53:51 +0800
committerbapt <bapt@FreeBSD.org>2011-06-06 13:53:51 +0800
commitc520595ae552774a8ea7a9ed5a1cadb3d3f94e8d (patch)
treedc3b0bd0ad87e384196ed1d4fdfcf182a8c90b44 /Mk/bsd.port.mk
parent26d6ccb72baf6cf7d724a601784d8e892c86db38 (diff)
downloadfreebsd-ports-c520595ae552774a8ea7a9ed5a1cadb3d3f94e8d.tar.gz
freebsd-ports-c520595ae552774a8ea7a9ed5a1cadb3d3f94e8d.tar.zst
freebsd-ports-c520595ae552774a8ea7a9ed5a1cadb3d3f94e8d.zip
- remove some old code (unsused on supported OS) [1]
- prevent some useless external program call (based on [2]) - simplify (in)valid category detection PR: ports/155629 [1], ports/65804 [2], ports/157273 [3] Submitted by: Eitan Adler <lists@eitanadler.com> [1], green@ [2], bapt@ (myself) [2] Exp-runs by: pav@
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk39
1 files changed, 12 insertions, 27 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index e0568cf4b2a2..53c274627267 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1173,7 +1173,7 @@ SRC_BASE?= /usr/src
.if !target(makepatch)
makepatch:
- @cd ${.CURDIR} && ${MKDIR} ${FILESDIR}
+ @${MKDIR} ${FILESDIR}
@(cd ${PATCH_WRKSRC}; \
for i in `find . -type f -name '*.orig'`; do \
ORG=$$i; \
@@ -1191,11 +1191,6 @@ makepatch:
# Start of options section
.if defined(INOPTIONSMK) || ( !defined(USEOPTIONSMK) && !defined(AFTERPORTMK) )
-.if defined(MAKE_VERSION)
-.if ${MAKE_VERSION} >= 5200408030 || ${MAKE_VERSION} >= 4200408030 && ${MAKE_VERSION} < 5000000000
-NOPRECIOUSSOFTMAKEVARS= yes
-.endif
-.endif
# Get the default maintainer
MAINTAINER?= ports@FreeBSD.org
@@ -2975,12 +2970,10 @@ VALID_CATEGORIES+= accessibility afterstep arabic archivers astro audio \
check-categories:
.for cat in ${CATEGORIES}
- @if ${ECHO_CMD} ${VALID_CATEGORIES} | ${GREP} -wq ${cat}; then \
- ${TRUE}; \
- else \
- ${ECHO_MSG} "${PKGNAME}: Makefile error: category ${cat} not in list of valid categories."; \
- ${FALSE}; \
- fi
+. if empty(VALID_CATEGORIES:M${cat})
+ @${ECHO_MSG} "${PKGNAME}: Makefile error: category ${cat} not in list of valid categories."; \
+ ${FALSE};
+. endif
.endfor
.endif
@@ -4849,7 +4842,7 @@ fetch-url-list-int:
for _file in ${DISTFILES}; do \
file=`${ECHO_CMD} $$_file | ${SED} -E -e 's/:[^:]+$$//'` ; \
select=`${ECHO_CMD} $${_file#$${file}} | ${SED} -e 's/^://' -e 's/,/ /g'` ; \
- if [ ! -z "${LISTALL}" -o ! -f $$file -a ! -f `${BASENAME} $$file` ]; then \
+ if [ ! -z "${LISTALL}" -o ! -f $$file -a ! -f $${file##*/} ]; then \
if [ ! -z "$$select" ] ; then \
__MASTER_SITES_TMP= ; \
for group in $$select; do \
@@ -4865,7 +4858,7 @@ fetch-url-list-int:
fi ; \
for site in `eval $$SORTED_MASTER_SITES_CMD_TMP ${_RANDOMIZE_SITES}`; do \
DIR=${DIST_SUBDIR}; \
- CKSIZE=`${GREP} "^SIZE ($${DIR:+$$DIR/}$$file)" ${DISTINFO_FILE} | ${AWK} '{print $$4}'`; \
+ CKSIZE=`${AWK} "/^SIZE \($${DIR:+$$DIR/}$$file\)"'{print $$4}' ${DISTINFO_FILE}`; \
case $${file} in \
*/*) args="-o $${file} $${site}$${file}";; \
*) args=$${site}$${file};; \
@@ -4880,7 +4873,7 @@ fetch-url-list-int:
for _file in ${PATCHFILES}; do \
file=`${ECHO_CMD} $$_file | ${SED} -E -e 's/:[^:]+$$//'` ; \
select=`${ECHO_CMD} $${_file#$${file}} | ${SED} -e 's/^://' -e 's/,/ /g'` ; \
- if [ ! -z "${LISTALL}" -o ! -f $$file -a ! -f `${BASENAME} $$file` ]; then \
+ if [ ! -z "${LISTALL}" -o ! -f $$file -a ! -f $${file##*/} ]; then \
if [ ! -z "$$select" ] ; then \
__PATCH_SITES_TMP= ; \
for group in $$select; do \
@@ -4896,7 +4889,7 @@ fetch-url-list-int:
fi ; \
for site in `eval $$SORTED_PATCH_SITES_CMD_TMP ${_RANDOMIZE_SITES}`; do \
DIR=${DIST_SUBDIR}; \
- CKSIZE=`${GREP} "^SIZE ($${DIR:+$$DIR/}$$file)" ${DISTINFO_FILE} | ${AWK} '{print $$4}'`; \
+ CKSIZE=`${AWK} "/^SIZE \($${DIR:+$$DIR/}$$file\)"'{print $$4}' ${DISTINFO_FILE}`; \
case $${file} in \
*/*) args="-o $${file} $${site}$${file}";; \
*) args=$${site}$${file};; \
@@ -5163,15 +5156,15 @@ ${deptype:L}-depends:
.if defined(${deptype}_DEPENDS)
.if !defined(NO_DEPENDS)
@for i in `${ECHO_CMD} "${${deptype}_DEPENDS}"`; do \
- prog=`${ECHO_CMD} $$i | ${SED} -e 's/:.*//'`; \
+ prog=$${i%%:*}; \
if [ -z "$$prog" ]; then \
${ECHO_MSG} "Error: there is an empty port dependency in ${deptype}_DEPENDS."; \
break; \
fi; \
dir=`${ECHO_CMD} $$i | ${SED} -e 's/[^:]*://'`; \
if ${EXPR} "$$dir" : '.*:' > /dev/null; then \
- target=`${ECHO_CMD} $$dir | ${SED} -e 's/.*://'`; \
- dir=`${ECHO_CMD} $$dir | ${SED} -e 's/:.*//'`; \
+ target=$${dir##*:}; \
+ dir=$${dir%%:*}; \
if [ X${DEPENDS_PRECLEAN} != "X" ]; then \
target="clean $$target"; \
depends_args="$$depends_args NOCLEANDEPENDS=yes"; \
@@ -6099,14 +6092,6 @@ depend:
tags:
.endif
-.if !defined(NOPRECIOUSSOFTMAKEVARS)
-.for softvar in CKSUMFILES _MLINKS
-.if defined(${softvar})
-__softMAKEFLAGS+= '${softvar}+=${${softvar}:S/'/'\''/g}'
-.endif
-.endfor
-.endif
-
.if !defined(NOPRECIOUSMAKEVARS)
# These won't change, so we can pass them through the environment
.MAKEFLAGS: \