aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2007-08-05 03:48:34 +0800
committerpav <pav@FreeBSD.org>2007-08-05 03:48:34 +0800
commitf15335d38111c05839569ab6d0349a3f41435643 (patch)
treee360dca7e3c5f5a7dfcc0a540eb86b1e20ad836c /Mk/bsd.port.mk
parent85488fc2d92837f6c8b5129b09a95496e1d77a24 (diff)
downloadfreebsd-ports-f15335d38111c05839569ab6d0349a3f41435643.tar.gz
freebsd-ports-f15335d38111c05839569ab6d0349a3f41435643.tar.zst
freebsd-ports-f15335d38111c05839569ab6d0349a3f41435643.zip
- Add --x-libraries=${X11BASE}/lib --x-includes=${X11BASE}/include to
CONFIGURE_ARGS for ports setting USE_XORG. This restores the old USE_XLIB behaviour. [1] - Whitespace fixes [2] PR: ports/115098 [1] Submitted by: mm [1], miwi [2]
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk11
1 files changed, 7 insertions, 4 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 89437be2e871..c484a5f68663 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -604,11 +604,11 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# "man/mann/bar.n", set "MAN1=foo.1" and "MANN=bar.n".
# The available sections chars are "123456789LN".
# MAN<sect>_<lang>
-# - If your port does not install all man pages for all
-# languages in MANLANG, language specific pages for
+# - If your port does not install all man pages for all
+# languages in MANLANG, language specific pages for
# a language can be specified with this. For example,
# if the port installs foo.1 in English, Japanese, and
-# German, bar.1 in English only, and baz.3 in German
+# German, bar.1 in English only, and baz.3 in German
# only, set
# MANLANG= "" de ja
# MAN1= foo.1
@@ -1069,7 +1069,7 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# CHECKSUM_ALGORITHMS
# - Different checksum algorithms to check for verifying the
# integrity of the distfiles. The absence of the algorithm
-# in distinfo doesn't make it fail.
+# in distinfo doesn't make it fail.
# Default: md5 sha256
# NO_CHECKSUM - Don't verify the checksum. Typically used when
# when you noticed the distfile you just fetched has
@@ -2051,6 +2051,9 @@ RUN_DEPENDS+= ${X11BASE}/libdata/xorg/libraries:${X_LIBRARIES_PORT}
LIB_DEPENDS+= X11.6:${X_LIBRARIES_PORT}
. endif
. endif
+.endif
+
+.if defined(USE_XLIB) || defined(USE_XORG)
# Add explicit X options to avoid problems with false positives in configure
.if defined(GNU_CONFIGURE)
CONFIGURE_ARGS+=--x-libraries=${X11BASE}/lib --x-includes=${X11BASE}/include