aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2005-02-02 17:34:05 +0800
committerAnton Berezin <tobez@FreeBSD.org>2005-02-02 17:34:05 +0800
commite2611e24e061b6fd7fdececed33cd8361b900f81 (patch)
tree4540b2498bf39c544d72184831ae0e04fdd6680d /Mk
parentbdc7d6ab9074f42ce535ec147aaa8658b65cad1d (diff)
downloadfreebsd-ports-e2611e24e061b6fd7fdececed33cd8361b900f81.tar.gz
freebsd-ports-e2611e24e061b6fd7fdececed33cd8361b900f81.tar.zst
freebsd-ports-e2611e24e061b6fd7fdececed33cd8361b900f81.zip
Update bsd.port.mk's notion of the perl version (to 5.8.6) [1].
Use more correct OSVERSION threshold to distinguish between base system perl and perl from ports - the right value is 500036 [1]. Also, simplify OSVERSION-related logic in lang/perl5 and lang/perl5.8. Now it goes as follows: - for lang/perl5.8, if there is perl in the base system, install use.perl script, use a helpful pkg-message, and do not automatically update symlinks; - for lang/perl5.8, if there is no perl in the base system, do not install use.perl script, and update symlinks automatically; - for lang/perl5, always install use.perl; - for lang/perl5, never update symlinks automatically; - for lang/perl5, vary produced pkg-message depending on the presence of the base system perl. Bump PORTREVISION for both lang/perl5 and lang/perl5.8. [1] Approved by: portmgr
Notes
Notes: svn path=/head/; revision=127896
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 4caa47277876..127d1bc16a7d 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1173,9 +1173,9 @@ BUILD_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE_PORT}
RUN_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE_PORT}
.endif
-.if ${OSVERSION} >= 502100
-PERL_VERSION?= 5.8.5
-PERL_VER?= 5.8.5
+.if ${OSVERSION} >= 500036
+PERL_VERSION?= 5.8.6
+PERL_VER?= 5.8.6
.else
.if ${OSVERSION} >= 500032
PERL_VERSION?= 5.6.1