aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1995-01-11 16:50:48 +0800
committerSatoshi Asami <asami@FreeBSD.org>1995-01-11 16:50:48 +0800
commitf0b0206d6386b105e146588ce041783b06ac4d6a (patch)
tree363c8252a90603a1d8a6c3f498ca62afcddb3cf7 /Mk
parent41a21872fa98fbf3cde09876b6865b66bf7ab714 (diff)
downloadfreebsd-ports-f0b0206d6386b105e146588ce041783b06ac4d6a.tar.gz
freebsd-ports-f0b0206d6386b105e146588ce041783b06ac4d6a.tar.zst
freebsd-ports-f0b0206d6386b105e146588ce041783b06ac4d6a.zip
Add missing ! in front of pipeline for extract commands---otherwise
it would exit on *successful* extraction.
Notes
Notes: svn path=/head/; revision=746
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index bee250383872..0a04806d1a4c 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3,7 +3,7 @@
# bsd.port.mk - 940820 Jordan K. Hubbard.
# This file is in the public domain.
#
-# $Id: bsd.port.mk,v 1.98 1995/01/06 22:14:12 ache Exp $
+# $Id: bsd.port.mk,v 1.99 1995/01/10 12:23:44 jkh Exp $
#
# Please view me with 4 column tabs!
@@ -549,13 +549,13 @@ ${EXTRACT_COOKIE}:
@mkdir -p ${WRKDIR}
.if defined(EXTRACT_ONLY)
@for file in ${EXTRACT_ONLY}; do \
- if ${EXTRACT_CMD} ${EXTRACT_ARGS} ${DISTDIR}/$$file; then \
+ ! if ${EXTRACT_CMD} ${EXTRACT_ARGS} ${DISTDIR}/$$file; then \
exit 1; \
fi \
done
.else
@for file in ${DISTFILES}; do \
- if ${EXTRACT_CMD} ${EXTRACT_ARGS} ${DISTDIR}/$$file; then \
+ ! if ${EXTRACT_CMD} ${EXTRACT_ARGS} ${DISTDIR}/$$file; then \
exit 1; \
fi \
done