aboutsummaryrefslogtreecommitdiffstats
path: root/audio/rebler/Makefile
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2003-06-05 06:43:38 +0800
committerkris <kris@FreeBSD.org>2003-06-05 06:43:38 +0800
commitf6ac0b4935ea004895ab5cc2800059b8d12c82ba (patch)
tree91894094142566c88cf43e76bf56bd120a3c8119 /audio/rebler/Makefile
parenta202830df7532e2bb404143c7bf5ee68b97df9bf (diff)
downloadfreebsd-ports-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.tar.gz
freebsd-ports-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.tar.zst
freebsd-ports-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.zip
Move inclusion of bsd.port.pre.mk later in the file for conditional BROKEN
tag. Early inclusion caused problems for some ports, so to be safe I'm updating all of them. Pointy hat to: kris
Diffstat (limited to 'audio/rebler/Makefile')
-rw-r--r--audio/rebler/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/audio/rebler/Makefile b/audio/rebler/Makefile
index f8fb6cd2541c..b1b8645dd30b 100644
--- a/audio/rebler/Makefile
+++ b/audio/rebler/Makefile
@@ -19,12 +19,6 @@ LIB_DEPENDS= mpeg2:${PORTSDIR}/multimedia/libmpeg2 \
aviplay.0:${PORTSDIR}/multimedia/avifile \
popt:${PORTSDIR}/devel/popt
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
USE_BZIP2= yes
AVIFILE_CONFIG?= ${LOCALBASE}/bin/avifile-config
CFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS} \
@@ -32,6 +26,12 @@ CFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS} \
LIBS+= -L${LOCALBASE}/lib -lm -lmpeg2 ${PTHREAD_LIBS} \
`${AVIFILE_CONFIG} --libs` -lpopt
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
do-build:
@(cd ${WRKSRC} ; \
${CXX} ${CXXFLAGS} rebler.cpp -o rebler ${LIBS})