aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-06-05 18:35:35 +0800
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-06-05 18:35:35 +0800
commit296338fdfb495fc82a877cd96f3a8f8d7b2e9f82 (patch)
tree662f1a6198a260265246e3f648474d1afd2e8bd1 /audio
parent1666f0cda21b0f2793faa499c15432dabdc27f35 (diff)
downloadfreebsd-ports-296338fdfb495fc82a877cd96f3a8f8d7b2e9f82.tar.gz
freebsd-ports-296338fdfb495fc82a877cd96f3a8f8d7b2e9f82.tar.zst
freebsd-ports-296338fdfb495fc82a877cd96f3a8f8d7b2e9f82.zip
- Mark restricted instead of NO_PACKAGE, since we're not allowed to distribute
the sources. - don't overwrite .conf file and install it as .saple also - fix pkg-deinstall - add CONLFICTS with upcomming linux binary port - bump PORTREVISION Submitted by: maintainer Approved by: lawrance (mentor, implicit)
Notes
Notes: svn path=/head/; revision=164417
Diffstat (limited to 'audio')
-rw-r--r--audio/shoutcast/Makefile15
-rw-r--r--audio/shoutcast/pkg-deinstall4
-rw-r--r--audio/shoutcast/pkg-install4
-rw-r--r--audio/shoutcast/pkg-plist4
4 files changed, 19 insertions, 8 deletions
diff --git a/audio/shoutcast/Makefile b/audio/shoutcast/Makefile
index 01bce6d890cf..75430f2983e7 100644
--- a/audio/shoutcast/Makefile
+++ b/audio/shoutcast/Makefile
@@ -6,7 +6,7 @@
PORTNAME= shoutcast
PORTVERSION= 1.9.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio net
MASTER_SITES= http://www.shoutcast.com/downloads/sc1-9-5/
@@ -15,15 +15,13 @@ COMMENT= Nullsoft's streaming audio server (binary port)
ONLY_FOR_ARCHS= i386 amd64 ia64
NO_BUILD= YES
-NO_PACKAGE= Redistribution of the software isn\'t allowed
+RESTRICTED= Redistribution of the software is not allowed
+
+CONFLICTS= linux-shoutcast-[0-9]*
USE_RC_SUBR= shoutcast.sh
-PLIST_FILES= sbin/sc_serv etc/shoutcast/sc_serv.conf.sample
-PLIST_DIRS= etc/shoutcast
PORTDOCS= README.TXT
-SUB_FILES= pkg-message
-
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500000
@@ -51,13 +49,14 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/sc_serv ${PREFIX}/sbin
${MKDIR} ${PREFIX}/etc/shoutcast
${INSTALL_DATA} ${WRKSRC}/sc_serv.conf ${PREFIX}/etc/shoutcast/sc_serv.conf.sample
+ @[ -f ${PREFIX}/etc/shoutcast/sc_serv.conf ] || \
+ ${INSTALL_DATA} ${WRKSRC}/sc_serv.conf ${PREFIX}/etc/shoutcast/sc_serv.conf
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.TXT ${DOCSDIR}
.endif
post-install:
- @${SH} ${PKGINSTALL} ${PKGNAME}
- @${CAT} ${PKGMESSAGE}
+ ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.include <bsd.port.post.mk>
diff --git a/audio/shoutcast/pkg-deinstall b/audio/shoutcast/pkg-deinstall
index 4dceb1880e13..21bac56cda91 100644
--- a/audio/shoutcast/pkg-deinstall
+++ b/audio/shoutcast/pkg-deinstall
@@ -1,5 +1,9 @@
#!/bin/sh
+if [ "$2" != "POST-DEINSTALL" ]; then
+ exit 0
+fi
+
SC_GROUP=shoutcast
SC_USER=shoutcast
SC_SHELL=/bin/sh
diff --git a/audio/shoutcast/pkg-install b/audio/shoutcast/pkg-install
index 29027c1cf880..bb97ac95dde2 100644
--- a/audio/shoutcast/pkg-install
+++ b/audio/shoutcast/pkg-install
@@ -1,5 +1,9 @@
#!/bin/sh
+if [ "$2" != "POST-INSTALL" ]; then
+ exit 0
+fi
+
SC_GROUP=shoutcast
SC_USER=shoutcast
SC_SHELL=/bin/sh
diff --git a/audio/shoutcast/pkg-plist b/audio/shoutcast/pkg-plist
new file mode 100644
index 000000000000..ae9ece2dc583
--- /dev/null
+++ b/audio/shoutcast/pkg-plist
@@ -0,0 +1,4 @@
+sbin/sc_serv
+@unexec if cmp -s %%PREFIX%%/etc/shoutcast/sc_serv.conf %%PREFIX%%/etc/shoutcast/sc_serv.conf.sample; then rm %%PREFIX%%/etc/shoutcast/sc_serv.conf; fi
+etc/shoutcast/sc_serv.conf.sample
+@dirrmtry etc/shoutcast