aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2002-01-21 04:30:58 +0800
committerTrevor Johnson <trevor@FreeBSD.org>2002-01-21 04:30:58 +0800
commit937eb4c851ea3c58739b6f8dddff592654cf4e82 (patch)
tree33074b1d8f93e04ce09cea5e6da94eec08348aff /audio
parent793cd4e837fbd54115f8e9b29e0ebaffefd3311e (diff)
downloadfreebsd-ports-937eb4c851ea3c58739b6f8dddff592654cf4e82.tar.gz
freebsd-ports-937eb4c851ea3c58739b6f8dddff592654cf4e82.tar.zst
freebsd-ports-937eb4c851ea3c58739b6f8dddff592654cf4e82.zip
Try to fix linking error introduced in last revision.
Notes
Notes: svn path=/head/; revision=53404
Diffstat (limited to 'audio')
-rw-r--r--audio/snd/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/audio/snd/Makefile b/audio/snd/Makefile
index 6f20eb23aaaa..a3c00c74d805 100644
--- a/audio/snd/Makefile
+++ b/audio/snd/Makefile
@@ -60,8 +60,10 @@ CONFIGURE_ARGS+= --with-gtk-extra
.if defined(WITHOUT_X11)
CONFIGURE_ARGS+= --with-no-gui
.endif
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
+
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
+ CFLAGS="${CFLAGS}"
+MAKE_ENV= LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}"
GNU_CONFIGURE= yes
@@ -77,7 +79,6 @@ WRKSRC= ${WRKDIR}/snd-5
post-configure:
@${PERL} -pi -e "s: -ldl::g" ${WRKSRC}/makefile
- @${PERL} -pi -e "s:-lm -lm:-lm:g" ${WRKSRC}/makefile
pre-install:
${ECHO} bin/snd > ${PLIST}