aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2008-04-06 16:58:21 +0800
committerstas <stas@FreeBSD.org>2008-04-06 16:58:21 +0800
commit6fbde8aaf51fc0bcaf991519b739b0592c98f740 (patch)
tree280ebf175af2693f172cb9dc5674fa73fb5992d3 /benchmarks
parentf29755f74021d623e3671b29c948ead5c3e33715 (diff)
downloadfreebsd-ports-6fbde8aaf51fc0bcaf991519b739b0592c98f740.tar.gz
freebsd-ports-6fbde8aaf51fc0bcaf991519b739b0592c98f740.tar.zst
freebsd-ports-6fbde8aaf51fc0bcaf991519b739b0592c98f740.zip
- Add ruby 1.9 support
- Implement new knobs for gems and rake (these are included in ruby 1.9 distribution already). Also move gem bits from ruby-gems/Makefile.common to bsd.ruby.mk[1]. Now to depend on gems or rake you should define USE_RUBYGEMS/USE_RAKE accordingly. Also RAKE_BIN variable is provided for pointing to the right rake executable. - Rewrite RUBY_SCHEBANG in awk to eliminate build dependency on ruby. Discussed with: Jonathan Weiss <jw@innerewut.de> [1] (gems maintainer) Tested by: ports@
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/rubygem-railsbench/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/benchmarks/rubygem-railsbench/Makefile b/benchmarks/rubygem-railsbench/Makefile
index 915680a9dbc2..f2afbafef1c3 100644
--- a/benchmarks/rubygem-railsbench/Makefile
+++ b/benchmarks/rubygem-railsbench/Makefile
@@ -16,6 +16,9 @@ COMMENT= Scripts designed for benchmarking of Rails applications
BUILD_DEPENDS= rubygem-hoe>=1.2.0:${PORTSDIR}/devel/rubygem-hoe
RUN_DEPENDS= ${BUILD_DEPENDS}
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
OPTIONS= GRUFF "Plotting of perf data support using gruff" off
OPTIONSFILE= ${PORT_DBDIR}/rubygem-${PORTNAME}/options
@@ -25,5 +28,4 @@ OPTIONSFILE= ${PORT_DBDIR}/rubygem-${PORTNAME}/options
RUN_DEPENDS+= rubygem-gruff>=0.2.8:${PORTSDIR}/graphics/rubygem-gruff
.endif
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
.include <bsd.port.post.mk>