aboutsummaryrefslogtreecommitdiffstats
path: root/biology
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-05-06 04:09:54 +0800
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-05-06 04:09:54 +0800
commitdfc2535ebee150f338339c3f68d4516433e0d7f4 (patch)
tree61ba02bd85972c4a2881095213fd963d8446be7b /biology
parent0c116f38a4028d402aec25e97086dbbe89d170c2 (diff)
downloadfreebsd-ports-dfc2535ebee150f338339c3f68d4516433e0d7f4.tar.gz
freebsd-ports-dfc2535ebee150f338339c3f68d4516433e0d7f4.tar.zst
freebsd-ports-dfc2535ebee150f338339c3f68d4516433e0d7f4.zip
Add protomol 2.0.3, OO, component based, framework for molecular
dynamics (MD) simulations. PR: 95123 Submitted by: Sangwoo Shim <sangwoos@gmail.com>
Notes
Notes: svn path=/head/; revision=161442
Diffstat (limited to 'biology')
-rw-r--r--biology/Makefile1
-rw-r--r--biology/protomol/Makefile54
-rw-r--r--biology/protomol/distinfo3
-rw-r--r--biology/protomol/pkg-descr15
-rw-r--r--biology/protomol/pkg-plist128
5 files changed, 201 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index 294332a06eef..4e3db307679d 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -57,6 +57,7 @@
SUBDIR += platon
SUBDIR += povchem
SUBDIR += primer3
+ SUBDIR += protomol
SUBDIR += psi88
SUBDIR += py-biopython
SUBDIR += pymol
diff --git a/biology/protomol/Makefile b/biology/protomol/Makefile
new file mode 100644
index 000000000000..39252c9bd9f7
--- /dev/null
+++ b/biology/protomol/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: protomol
+# Date created: 5 May 2006
+# Whom: Sangwoo Shim <sangwoos@gmail.com>
+#
+# $FreeBSD$
+
+PORTNAME= protomol
+PORTVERSION= 2.0.3
+CATEGORIES= biology
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION}-tar.gz
+EXTRACT_SUFX= # nada
+
+MAINTAINER= sangwoos@gmail.com
+COMMENT= OO, component based, framework for molecular dynamics (MD) simulations
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ tiff.4:${PORTSDIR}/graphics/tiff
+
+GNU_CONFIGURE= yes
+USE_XLIB= yes
+USE_GCC= 3.4+
+
+# Hack to cure a misbehavior of the configure script
+CONFIGURE_ARGS+= --without-irix_mipspro_mpi
+
+CPPFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include
+CXXFLAGS+= -L${LOCALBASE}/lib -L${X11BASE}/lib
+
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" CXXFLAGS="${CXXFLAGS}"
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+OPTIONS= GLUT "Use glut" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_GLUT)
+CONFIGURE_ARGS+= --with-glut=yes
+LIB_DEPENDS+= glut.4:${PORTSDIR}/graphics/libglut
+.else
+CONFIGURE_ARGS+= --with-glut=no
+.endif
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC}/examples && ${FIND} . | ${EGREP} -v '\.cvsignore' | \
+ ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/biology/protomol/distinfo b/biology/protomol/distinfo
new file mode 100644
index 000000000000..e38c28376e65
--- /dev/null
+++ b/biology/protomol/distinfo
@@ -0,0 +1,3 @@
+MD5 (protomol-2.0.3-tar.gz) = 0c0f1749c7dd88c280e9b2563e853a68
+SHA256 (protomol-2.0.3-tar.gz) = 52c5faf69c717516a2b071dabbaed089ae7e9944b706e391e74604946a69c183
+SIZE (protomol-2.0.3-tar.gz) = 2391568
diff --git a/biology/protomol/pkg-descr b/biology/protomol/pkg-descr
new file mode 100644
index 000000000000..8a0b7239b89d
--- /dev/null
+++ b/biology/protomol/pkg-descr
@@ -0,0 +1,15 @@
+ProtoMol is an object-oriented, component based, framework for molecular
+dynamics (MD) simulations. The framework supports the CHARMM 19 and 28a2 force
+fields and is able to process PDB, PSF, XYZ and DCD trajectory files. It is
+designed for high flexibility, easy extendibility and maintenance, and high
+performance demands, including parallelization. The technique of multiple
+time-stepping is used to improve long-term efficiency. The use of fast
+electrostatic force evaluation algorithms like Ewald, particle Mesh Ewald (PME),
+and Multigrid (MG) summation further enhances performance. Longer time steps
+are possible using MOLLY, Langevin Molly and Hybrid Monte Carlo, Nose-Hoover,
+and Langevin integrators. In addition, ProtoMol has been designed to interact
+with VMD, a visualization engine developed by the University of Illinois that is
+used for displaying large biomolecular systems in three dimensions. ProtoMol is
+freely distributed software, and the source code is available.
+
+WWW: http://protomol.sourceforge.net/
diff --git a/biology/protomol/pkg-plist b/biology/protomol/pkg-plist
new file mode 100644
index 000000000000..1823d8daeb80
--- /dev/null
+++ b/biology/protomol/pkg-plist
@@ -0,0 +1,128 @@
+bin/coords2coords
+bin/coulomb
+bin/dcd2dcd
+bin/iSGProtomol
+bin/protomol
+bin/xyzviz
+%%PORTDOCS%%%%EXAMPLESDIR%%/coulomb_309/309ca.config
+%%PORTDOCS%%%%EXAMPLESDIR%%/coulomb_309/309ca.par
+%%PORTDOCS%%%%EXAMPLESDIR%%/coulomb_309/309ca.pos.xyz
+%%PORTDOCS%%%%EXAMPLESDIR%%/coulomb_309/309ca.psf
+%%PORTDOCS%%%%EXAMPLESDIR%%/alanine_dipeptide_water_184x/alanine.equil.psf
+%%PORTDOCS%%%%EXAMPLESDIR%%/alanine_dipeptide_water_184x/alanine.7ns.namd
+%%PORTDOCS%%%%EXAMPLESDIR%%/alanine_dipeptide_water_184x/alanine.equil.pdb
+%%PORTDOCS%%%%EXAMPLESDIR%%/alanine_dipeptide_water_184x/ala607.pgn
+%%PORTDOCS%%%%EXAMPLESDIR%%/alanine_dipeptide_water_184x/alanine.namd
+%%PORTDOCS%%%%EXAMPLESDIR%%/alanine_dipeptide_water_184x/alanine.pdb
+%%PORTDOCS%%%%EXAMPLESDIR%%/alanine_dipeptide_water_184x/alanine.psf
+%%PORTDOCS%%%%EXAMPLESDIR%%/argon_400/argon.par
+%%PORTDOCS%%%%EXAMPLESDIR%%/argon_400/argon.lf.conf
+%%PORTDOCS%%%%EXAMPLESDIR%%/argon_400/argon.npt.conf
+%%PORTDOCS%%%%EXAMPLESDIR%%/argon_400/argon.pdb
+%%PORTDOCS%%%%EXAMPLESDIR%%/argon_400/argon.psf
+%%PORTDOCS%%%%EXAMPLESDIR%%/argon_400/argon.vel.pdb
+%%PORTDOCS%%%%EXAMPLESDIR%%/bpti_water_1101/bpti.par
+%%PORTDOCS%%%%EXAMPLESDIR%%/bpti_water_1101/bpti.hmc.conf
+%%PORTDOCS%%%%EXAMPLESDIR%%/bpti_water_1101/bpti.lf.conf
+%%PORTDOCS%%%%EXAMPLESDIR%%/bpti_water_1101/bpti.pdb
+%%PORTDOCS%%%%EXAMPLESDIR%%/bpti_water_1101/bpti.psf
+%%PORTDOCS%%%%EXAMPLESDIR%%/bpti_water_1101/bpti.shmc.conf
+%%PORTDOCS%%%%EXAMPLESDIR%%/bpti_water_14281/bpti.shake.conf
+%%PORTDOCS%%%%EXAMPLESDIR%%/bpti_water_14281/bpti.ewald.conf
+%%PORTDOCS%%%%EXAMPLESDIR%%/bpti_water_14281/bpti.mg.conf
+%%PORTDOCS%%%%EXAMPLESDIR%%/bpti_water_14281/bpti.namd
+%%PORTDOCS%%%%EXAMPLESDIR%%/bpti_water_14281/bpti.par
+%%PORTDOCS%%%%EXAMPLESDIR%%/bpti_water_14281/bpti.pbc.conf
+%%PORTDOCS%%%%EXAMPLESDIR%%/bpti_water_14281/bpti.pdb
+%%PORTDOCS%%%%EXAMPLESDIR%%/bpti_water_14281/bpti.psf
+%%PORTDOCS%%%%EXAMPLESDIR%%/butane_4/runButaneTests.sh
+%%PORTDOCS%%%%EXAMPLESDIR%%/butane_4/README
+%%PORTDOCS%%%%EXAMPLESDIR%%/butane_4/UA_butane.conf
+%%PORTDOCS%%%%EXAMPLESDIR%%/butane_4/UA_butane.dhmc.conf
+%%PORTDOCS%%%%EXAMPLESDIR%%/butane_4/UA_butane.hmc.conf
+%%PORTDOCS%%%%EXAMPLESDIR%%/butane_4/UA_butane.lf.conf
+%%PORTDOCS%%%%EXAMPLESDIR%%/butane_4/UA_butane.par
+%%PORTDOCS%%%%EXAMPLESDIR%%/butane_4/UA_butane.pdb
+%%PORTDOCS%%%%EXAMPLESDIR%%/butane_4/UA_butane.psf
+%%PORTDOCS%%%%EXAMPLESDIR%%/butane_4/angleSetDHMC
+%%PORTDOCS%%%%EXAMPLESDIR%%/butane_4/cleanOutput.bash
+%%PORTDOCS%%%%EXAMPLESDIR%%/butane_4/dihedralSetDHMC
+%%PORTDOCS%%%%EXAMPLESDIR%%/butane_4/procDihedralFile.awk
+%%PORTDOCS%%%%EXAMPLESDIR%%/butane_4/runButaneResults.sh
+%%PORTDOCS%%%%EXAMPLESDIR%%/alanine_dipeptide_23/ala_equil.pdb
+%%PORTDOCS%%%%EXAMPLESDIR%%/alanine_dipeptide_23/ala_equil.psf
+%%PORTDOCS%%%%EXAMPLESDIR%%/alanine_dipeptide_23/ala_equilibrated.pdb
+%%PORTDOCS%%%%EXAMPLESDIR%%/alanine_dipeptide_23/ala_equilibrated.pgn
+%%PORTDOCS%%%%EXAMPLESDIR%%/decalanine_66/dihedralIndexSet
+%%PORTDOCS%%%%EXAMPLESDIR%%/decalanine_66/alanine.BSplineMOLLY.conf
+%%PORTDOCS%%%%EXAMPLESDIR%%/decalanine_66/alanine.Equilibrium.conf
+%%PORTDOCS%%%%EXAMPLESDIR%%/decalanine_66/alanine.LF.conf
+%%PORTDOCS%%%%EXAMPLESDIR%%/decalanine_66/alanine.LFwDihedralOut.conf
+%%PORTDOCS%%%%EXAMPLESDIR%%/decalanine_66/alanine.PLF.conf
+%%PORTDOCS%%%%EXAMPLESDIR%%/decalanine_66/alanine.Shake.conf
+%%PORTDOCS%%%%EXAMPLESDIR%%/decalanine_66/alanine.par
+%%PORTDOCS%%%%EXAMPLESDIR%%/decalanine_66/alanine.pdb
+%%PORTDOCS%%%%EXAMPLESDIR%%/decalanine_66/alanine.psf
+%%PORTDOCS%%%%EXAMPLESDIR%%/decalanine_66/alanine.testSet
+%%PORTDOCS%%%%EXAMPLESDIR%%/decalanine_66/alanine.water.pdb
+%%PORTDOCS%%%%EXAMPLESDIR%%/decalanine_66/alanine.water.psf
+%%PORTDOCS%%%%EXAMPLESDIR%%/electrons_22/22el.conf
+%%PORTDOCS%%%%EXAMPLESDIR%%/electrons_22/22el.pos.xyz
+%%PORTDOCS%%%%EXAMPLESDIR%%/electrons_22/22el.psf
+%%PORTDOCS%%%%EXAMPLESDIR%%/electrons_22/22el.vel.xyz
+%%PORTDOCS%%%%EXAMPLESDIR%%/electrons_22/el.par
+%%PORTDOCS%%%%EXAMPLESDIR%%/methane_ethane_xxx/iSGMD_README
+%%PORTDOCS%%%%EXAMPLESDIR%%/methane_ethane_xxx/ethane_methane.par
+%%PORTDOCS%%%%EXAMPLESDIR%%/methane_ethane_xxx/ethane_methane.trans
+%%PORTDOCS%%%%EXAMPLESDIR%%/methane_ethane_xxx/ethane_methane_100.conf
+%%PORTDOCS%%%%EXAMPLESDIR%%/methane_ethane_xxx/ethane_methane_100_Pure_Trappe.coor.xyz
+%%PORTDOCS%%%%EXAMPLESDIR%%/methane_ethane_xxx/ethane_methane_100_Pure_Trappe.psf
+%%PORTDOCS%%%%EXAMPLESDIR%%/methane_ethane_xxx/ethane_methane_100_Pure_Trappe.vel.xyz
+%%PORTDOCS%%%%EXAMPLESDIR%%/methane_ethane_xxx/ethane_methane_100_Pure_Trappe.xsc
+%%PORTDOCS%%%%EXAMPLESDIR%%/methane_ethane_xxx/ethane_methane_300.conf
+%%PORTDOCS%%%%EXAMPLESDIR%%/methane_ethane_xxx/ethane_methane_300_Pure_Trappe.coor.xyz
+%%PORTDOCS%%%%EXAMPLESDIR%%/methane_ethane_xxx/ethane_methane_300_Pure_Trappe.psf
+%%PORTDOCS%%%%EXAMPLESDIR%%/methane_ethane_xxx/ethane_methane_300_Pure_Trappe.vel.xyz
+%%PORTDOCS%%%%EXAMPLESDIR%%/methane_ethane_xxx/ethane_methane_300_Pure_Trappe.xsc
+%%PORTDOCS%%%%EXAMPLESDIR%%/testset/test.tcsh
+%%PORTDOCS%%%%EXAMPLESDIR%%/testset/README
+%%PORTDOCS%%%%EXAMPLESDIR%%/testset/hmc.Bsp_PME.pb.conf
+%%PORTDOCS%%%%EXAMPLESDIR%%/testset/hmc.std.conf
+%%PORTDOCS%%%%EXAMPLESDIR%%/testset/lf.Ewald.pb.conf
+%%PORTDOCS%%%%EXAMPLESDIR%%/testset/lf.MG.conf
+%%PORTDOCS%%%%EXAMPLESDIR%%/testset/lf.PME.pb.conf
+%%PORTDOCS%%%%EXAMPLESDIR%%/testset/lf.std.conf
+%%PORTDOCS%%%%EXAMPLESDIR%%/testset/lf.std.pb.conf
+%%PORTDOCS%%%%EXAMPLESDIR%%/testset/shmc.Bsp_PME.pb.conf
+%%PORTDOCS%%%%EXAMPLESDIR%%/testset/shmc.std.pb.conf
+%%PORTDOCS%%%%EXAMPLESDIR%%/testset/slf.std.pb.conf
+%%PORTDOCS%%%%EXAMPLESDIR%%/water_216/water216.vel.pdb
+%%PORTDOCS%%%%EXAMPLESDIR%%/water_216/water216.conf
+%%PORTDOCS%%%%EXAMPLESDIR%%/water_216/water216.coor.pdb
+%%PORTDOCS%%%%EXAMPLESDIR%%/water_216/water216.new.pos.pdb
+%%PORTDOCS%%%%EXAMPLESDIR%%/water_216/water216.new.vel.pdb
+%%PORTDOCS%%%%EXAMPLESDIR%%/water_216/water216.par
+%%PORTDOCS%%%%EXAMPLESDIR%%/water_216/water216.psf
+%%PORTDOCS%%%%EXAMPLESDIR%%/water_648/water648.tip3.psf
+%%PORTDOCS%%%%EXAMPLESDIR%%/water_648/water648.fluid.conf
+%%PORTDOCS%%%%EXAMPLESDIR%%/water_648/water648.fluid.pos.xyz
+%%PORTDOCS%%%%EXAMPLESDIR%%/water_648/water648.ice.conf
+%%PORTDOCS%%%%EXAMPLESDIR%%/water_648/water648.ice.nvt.conf
+%%PORTDOCS%%%%EXAMPLESDIR%%/water_648/water648.ice.pos.xyz
+%%PORTDOCS%%%%EXAMPLESDIR%%/water_648/water648.spce.par
+%%PORTDOCS%%%%EXAMPLESDIR%%/water_648/water648.spce.psf
+%%PORTDOCS%%%%EXAMPLESDIR%%/water_648/water648.tip3.par
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/coulomb_309
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/alanine_dipeptide_water_184x
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/argon_400
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/bpti_water_1101
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/bpti_water_14281
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/butane_4
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/alanine_dipeptide_23
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/decalanine_66
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/electrons_22
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/methane_ethane_xxx
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/testset
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/water_216
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/water_648
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%