aboutsummaryrefslogtreecommitdiffstats
path: root/converters
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2006-11-01 02:05:32 +0800
committeralepulver <alepulver@FreeBSD.org>2006-11-01 02:05:32 +0800
commitb81a05dc7d0cf11f48d6ba314e649a2db88c7e63 (patch)
treefea34b57e60978d969eaae00d03a5451ff859cff /converters
parent479df853fa79fadd84b37b8e41452efa3d3f0e88 (diff)
downloadfreebsd-ports-b81a05dc7d0cf11f48d6ba314e649a2db88c7e63.tar.gz
freebsd-ports-b81a05dc7d0cf11f48d6ba314e649a2db88c7e63.tar.zst
freebsd-ports-b81a05dc7d0cf11f48d6ba314e649a2db88c7e63.zip
The ticonv library is a library to work with the various TI
calculator character sets. WWW: http://tilp.info/ - Tijl Coosemans tijl@ulyssis.org PR: ports/104407 Submitted by: Tijl Coosemans <tijl at ulyssis.org>
Diffstat (limited to 'converters')
-rw-r--r--converters/Makefile1
-rw-r--r--converters/libticonv/Makefile30
-rw-r--r--converters/libticonv/distinfo3
-rw-r--r--converters/libticonv/pkg-descr7
-rw-r--r--converters/libticonv/pkg-plist11
5 files changed, 52 insertions, 0 deletions
diff --git a/converters/Makefile b/converters/Makefile
index 37403f2f9db0..0346697082a6 100644
--- a/converters/Makefile
+++ b/converters/Makefile
@@ -28,6 +28,7 @@
SUBDIR += konwert
SUBDIR += ktextdecode
SUBDIR += libiconv
+ SUBDIR += libticonv
SUBDIR += libutf-8
SUBDIR += mimelib
SUBDIR += mmencode
diff --git a/converters/libticonv/Makefile b/converters/libticonv/Makefile
new file mode 100644
index 000000000000..42246b133157
--- /dev/null
+++ b/converters/libticonv/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: libticonv
+# Date created: 5 October 2006
+# Whom: Tijl Coosemans <tijl@ulyssis.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libticonv
+PORTVERSION= 1.0.0
+CATEGORIES= converters
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gtktiemu
+DISTNAME= ${PORTNAME}-20060925
+
+MAINTAINER= tijl@ulyssis.org
+COMMENT= TI calculator character set library
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_AUTOTOOLS= libtool:15
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOME= glib20 gnomehack pkgconfig
+USE_LDCONFIG= yes
+USE_ICONV= yes
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"\
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/converters/libticonv/distinfo b/converters/libticonv/distinfo
new file mode 100644
index 000000000000..ccdef38a4918
--- /dev/null
+++ b/converters/libticonv/distinfo
@@ -0,0 +1,3 @@
+MD5 (libticonv-20060925.tar.bz2) = ab19f2ba8eb82ad303c18867d84299a9
+SHA256 (libticonv-20060925.tar.bz2) = 571028e32397cea1c562ed0c03989d51a068c9496b5fca2ad9ff07fa1a622338
+SIZE (libticonv-20060925.tar.bz2) = 326675
diff --git a/converters/libticonv/pkg-descr b/converters/libticonv/pkg-descr
new file mode 100644
index 000000000000..b96d2439dba5
--- /dev/null
+++ b/converters/libticonv/pkg-descr
@@ -0,0 +1,7 @@
+The ticonv library is a library to work with the various TI
+calculator character sets.
+
+WWW: http://tilp.info/
+
+- Tijl Coosemans
+tijl@ulyssis.org
diff --git a/converters/libticonv/pkg-plist b/converters/libticonv/pkg-plist
new file mode 100644
index 000000000000..4c9676204dae
--- /dev/null
+++ b/converters/libticonv/pkg-plist
@@ -0,0 +1,11 @@
+include/tilp2/charset.h
+include/tilp2/export4.h
+include/tilp2/stdints4.h
+include/tilp2/ticonv.h
+include/tilp2/ticonv.h-e
+lib/libticonv.a
+lib/libticonv.la
+lib/libticonv.so
+lib/libticonv.so.2
+libdata/pkgconfig/ticonv.pc
+@dirrmtry include/tilp2