aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2000-04-24 00:24:06 +0800
committerVanilla I. Shu <vanilla@FreeBSD.org>2000-04-24 00:24:06 +0800
commit8ee05fcbde099f9935a2b74ccf706c65130a3b36 (patch)
tree77de641d37dce5cd2c0625858f984737228fce83 /databases
parentfee3f0b4b8d8be46cf8148bfa8b159ad688243a2 (diff)
downloadfreebsd-ports-8ee05fcbde099f9935a2b74ccf706c65130a3b36.tar.gz
freebsd-ports-8ee05fcbde099f9935a2b74ccf706c65130a3b36.tar.zst
freebsd-ports-8ee05fcbde099f9935a2b74ccf706c65130a3b36.zip
Cleanup of build process of the py-MySQL port. Previously port used
custom Makefile for this purpose, which led to resulting module being bloated (~600K) by linking all Python code from libpython1.5 into it. With this patch the module will use standard Python's way to build supplemental modules, which should generally be cleaner. Other good sideeffect is that after this patch resulting module is only 20K in size. PR: ports/17893 Submitted by: Maxim Sobolev <sobomax@altavista.net>
Notes
Notes: svn path=/head/; revision=27932
Diffstat (limited to 'databases')
-rw-r--r--databases/py-MySQL/Makefile17
-rw-r--r--databases/py-MySQL/files/Setup2
2 files changed, 11 insertions, 8 deletions
diff --git a/databases/py-MySQL/Makefile b/databases/py-MySQL/Makefile
index 14bff0feb40e..bbb83917508c 100644
--- a/databases/py-MySQL/Makefile
+++ b/databases/py-MySQL/Makefile
@@ -17,18 +17,19 @@ BUILD_DEPENDS= python:${PORTSDIR}/lang/python
LIB_DEPENDS= mysqlclient.6:${PORTSDIR}/databases/mysql322-client
RUN_DEPENDS= python:${PORTSDIR}/lang/python
-pre-build:
- ${CP} ${FILESDIR}/Makefile ${WRKSRC}/Makefile
+ALL_TARGET= MySQLmodule.so
+
+pre-configure:
+ ${CP} ${FILESDIR}/Setup ${WRKSRC}/Setup
+ ${LN} -s ${LOCALBASE}/lib/python1.5/config/Makefile.pre.in ${WRKSRC}/
+
+do-configure:
+ cd ${WRKSRC} && ${MAKE} -f Makefile.pre.in boot
-do-install:
- ${INSTALL_DATA} ${WRKSRC}/MySQLmodule.so ${PREFIX}/lib/python1.5/site-packages
.if !defined(NOPORTDOCS)
+post-install:
${MKDIR} ${PREFIX}/share/doc/py-MySQL
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/py-MySQL
-.endif
-
-post-install:
-.if !defined(NOPORTDOCS)
${ECHO} "share/doc/py-MySQL/README" >> ${TMPPLIST}
${ECHO} "@dirrm share/doc/py-MySQL" >> ${TMPPLIST}
.endif
diff --git a/databases/py-MySQL/files/Setup b/databases/py-MySQL/files/Setup
new file mode 100644
index 000000000000..bc8973ba58f9
--- /dev/null
+++ b/databases/py-MySQL/files/Setup
@@ -0,0 +1,2 @@
+*shared*
+MySQL MySQLmodule.c -I${LOCALBASE}/include/mysql -L${LOCALBASE}/lib/mysql -lmysqlclient