aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-05-29 01:15:38 +0800
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-05-29 01:15:38 +0800
commitae0f269fa0d93a69e6cf1ef54a3c241db33d995f (patch)
tree39a2421c649a1f394f9ae2af1d50ad73fd311567 /databases
parenta11dcc5cc3cb006237ecaeafd4c2e8f511c95313 (diff)
downloadfreebsd-ports-ae0f269fa0d93a69e6cf1ef54a3c241db33d995f.tar.gz
freebsd-ports-ae0f269fa0d93a69e6cf1ef54a3c241db33d995f.tar.zst
freebsd-ports-ae0f269fa0d93a69e6cf1ef54a3c241db33d995f.zip
add p5-DBIx-Password 1.8
Allows you to create a global password file for DB passwords PR: 36066 Submitted by: Autrijus Tang <autrijus@egb.elixus.org>
Notes
Notes: svn path=/head/; revision=60207
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-DBIx-Password/Makefile24
-rw-r--r--databases/p5-DBIx-Password/distinfo1
-rw-r--r--databases/p5-DBIx-Password/pkg-comment1
-rw-r--r--databases/p5-DBIx-Password/pkg-descr15
-rw-r--r--databases/p5-DBIx-Password/pkg-plist2
6 files changed, 44 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index dded8b958f32..c49a400cab48 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -78,6 +78,7 @@
SUBDIR += p5-DBIWrapper
SUBDIR += p5-DBIx-AnyDBD
SUBDIR += p5-DBIx-DataSource
+ SUBDIR += p5-DBIx-Password
SUBDIR += p5-DBIx-Recordset
SUBDIR += p5-DBIx-SearchBuilder
SUBDIR += p5-DBIx-XHTML_Table
diff --git a/databases/p5-DBIx-Password/Makefile b/databases/p5-DBIx-Password/Makefile
new file mode 100644
index 000000000000..76b83442795b
--- /dev/null
+++ b/databases/p5-DBIx-Password/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-DBIx-Password
+# Date created: March 17th 2002
+# Whom: Autrijus Tang <autrijus@autrijus.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBIx-Password
+PORTVERSION= 1.8
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DBIx
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= autrijus@autrijus.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+
+PERL_CONFIGURE= yes
+
+MAN3= DBIx::Password.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/databases/p5-DBIx-Password/distinfo b/databases/p5-DBIx-Password/distinfo
new file mode 100644
index 000000000000..c7e23e98cab5
--- /dev/null
+++ b/databases/p5-DBIx-Password/distinfo
@@ -0,0 +1 @@
+MD5 (DBIx-Password-1.8.tar.gz) = 5320613ea0dc98da52877d660c37aea0
diff --git a/databases/p5-DBIx-Password/pkg-comment b/databases/p5-DBIx-Password/pkg-comment
new file mode 100644
index 000000000000..b7b60153fb44
--- /dev/null
+++ b/databases/p5-DBIx-Password/pkg-comment
@@ -0,0 +1 @@
+Allows you to create a global password file for DB passwords
diff --git a/databases/p5-DBIx-Password/pkg-descr b/databases/p5-DBIx-Password/pkg-descr
new file mode 100644
index 000000000000..011d9ae64a61
--- /dev/null
+++ b/databases/p5-DBIx-Password/pkg-descr
@@ -0,0 +1,15 @@
+This module lets you stack handlers so that the next one will handle
+or "filter" the output of previous one.
+
+From README:
+
+ Don't you hate keeping track of database passwords and such
+ throughout your scripts? How about the problem of changing those
+ passwords on a mass scale? This module is one possible solution.
+ When you go to build this module it will ask you to create
+ virtual users. For each user you need to specify the database
+ module to use, the database connect string, the username and the
+ password. You will be prompted to give a name to this virtual
+ user. You can add as many as you like.
+
+-- Autrijus Tang <autrijus@autrijus.org>
diff --git a/databases/p5-DBIx-Password/pkg-plist b/databases/p5-DBIx-Password/pkg-plist
new file mode 100644
index 000000000000..ef1916b89913
--- /dev/null
+++ b/databases/p5-DBIx-Password/pkg-plist
@@ -0,0 +1,2 @@
+lib/perl5/site_perl/%%PERL_VER%%/DBIx/Password.pm
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/DBIx 2>/dev/null || true