aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-07-14 06:26:44 +0800
committerThierry Thomas <thierry@FreeBSD.org>2006-07-14 06:26:44 +0800
commitf8b42e1da314fa0898958ceb590c0359aadad6e5 (patch)
tree14e71fff0163176eb527552b070e9635d5664edd /databases
parent90ad186c409a80945035776fe7eab92398507d0b (diff)
downloadfreebsd-ports-f8b42e1da314fa0898958ceb590c0359aadad6e5.tar.gz
freebsd-ports-f8b42e1da314fa0898958ceb590c0359aadad6e5.tar.zst
freebsd-ports-f8b42e1da314fa0898958ceb590c0359aadad6e5.zip
- Upgrade to 1.1.16-1;
- Unbreak; - Add mirrors.
Notes
Notes: svn path=/head/; revision=167722
Diffstat (limited to 'databases')
-rw-r--r--databases/clip/Makefile19
-rw-r--r--databases/clip/distinfo6
-rw-r--r--databases/clip/files/patch-clip_Makefile.in15
-rw-r--r--databases/clip/files/patch-cliplibs::clip-gtkextra::configure16
-rw-r--r--databases/clip/files/patch-cliplibs_Makefile17
-rw-r--r--databases/clip/files/patch-cliplibs_clip-cti_Makefile17
-rw-r--r--databases/clip/pkg-plist24
7 files changed, 92 insertions, 22 deletions
diff --git a/databases/clip/Makefile b/databases/clip/Makefile
index 322fc9ccdfc0..a06828c8ede7 100644
--- a/databases/clip/Makefile
+++ b/databases/clip/Makefile
@@ -6,10 +6,14 @@
#
PORTNAME= clip
-DISTVERSION= 1.1.15-1
+DISTVERSION= 1.1.16-1
CATEGORIES= databases lang
MASTER_SITES= ftp://ftp.linux.ru.net/mirrors/clip/ \
- ftp://ftp.itk.ru/pub/clip/
+ ftp://www.cis.by/pub/clip/pub/clip/ \
+ http://clip.cis.by/mirror/pub/clip/ \
+ ftp://ftp.itk.ru/pub/clip/ \
+ ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= x-clip
DISTNAME= ${PORTNAME}-prg-${DISTVERSION}
EXTRACT_SUFX= .tgz
DIST_SUBDIR= clip
@@ -25,12 +29,12 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
freetype.9:${PORTSDIR}/print/freetype2 \
gtkextra.17:${PORTSDIR}/x11-toolkits/gtkextra \
gd.4:${PORTSDIR}/graphics/gd \
+ expat.6:${PORTSDIR}/textproc/expat2 \
+ glade-2.0:${PORTSDIR}/devel/libglade2 \
fcgi.0:${PORTSDIR}/www/fcgi
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
wget:${PORTSDIR}/ftp/wget
-BROKEN= Installs files prior to 'make install'
-
WRKSRC= ${WRKDIR}/${PORTNAME}-prg-${DISTVERSION}
USE_GETTEXT= yes
WANT_GNOME= yes
@@ -143,6 +147,11 @@ pre-configure:
-e "s|#!/bin/sh|#!${LOCALBASE}/bin/bash|" \
-e "s|/usr/local|${LOCALBASE}|g" \
-e "s|/usr/X11R6|${X11BASE}|g"
+ ${REINPLACE_CMD} "s|-I/usr/include|-I${LOCALBASE}/include -L${LOCALBASE}/lib|" \
+ ${WRKSRC}/cliplibs/clip-xml/configure
+ ${REINPLACE_CMD} -e "s|-I/usr/include|-I${LOCALBASE}/include|" \
+ -e "s|-lexpat|-L${LOCALBASE}/lib -lexpat|" \
+ ${WRKSRC}/cliplibs/clip-xml/Makefile.in
post-build: # don't include emppty directories
${RMDIR} ${DIR2PRUNE:S|^|${WRKDIR}/cliproot/|}
@@ -150,7 +159,7 @@ post-build: # don't include emppty directories
do-install:
@${MKDIR} ${PREFIX}/clip
@${CP} -R ${WRKDIR}/cliproot/* ${PREFIX}/clip
-.for FILE in ${BIN2STRIP}G
+.for FILE in ${BIN2STRIP}
@${STRIP_CMD} ${PREFIX}/clip/bin/${FILE}
.endfor
@for f in `${LS} ${PREFIX}/clip/lib/*.so` ; \
diff --git a/databases/clip/distinfo b/databases/clip/distinfo
index 96c494b60e6c..3063f766f047 100644
--- a/databases/clip/distinfo
+++ b/databases/clip/distinfo
@@ -1,3 +1,3 @@
-MD5 (clip/clip-prg-1.1.15-1.tgz) = 1bd2e6c30c6d95e8937e884c0441e527
-SHA256 (clip/clip-prg-1.1.15-1.tgz) = d611f0e0d700d428f0b49cfd6b3f5eb40b5327ebef3964a0135052ab8b856ff2
-SIZE (clip/clip-prg-1.1.15-1.tgz) = 4533670
+MD5 (clip/clip-prg-1.1.16-1.tgz) = bff7653e8dcb1e868ddb020339b06d96
+SHA256 (clip/clip-prg-1.1.16-1.tgz) = e2d4874ad35879d0c37902b0cf955a43bdc90462a977a7c54073e917a8861652
+SIZE (clip/clip-prg-1.1.16-1.tgz) = 4598486
diff --git a/databases/clip/files/patch-clip_Makefile.in b/databases/clip/files/patch-clip_Makefile.in
new file mode 100644
index 000000000000..34cd413402e2
--- /dev/null
+++ b/databases/clip/files/patch-clip_Makefile.in
@@ -0,0 +1,15 @@
+--- clip/Makefile.in.orig Tue Jan 3 14:33:54 2006
++++ clip/Makefile.in Thu Jul 13 23:57:42 2006
+@@ -381,9 +381,9 @@
+ inst_std_lib:
+ mkdir -p $(DESTDIR)$(STD_LIBDIR)
+ ls $(DESTDIR)$(CLIPROOT)/lib/*$(DLLSUFF)
+- for i in $(DESTDIR)$(CLIPROOT)/lib/*$(DLLSUFF); do ln -s $$i $(DESTDIR)$(STD_LIBDIR) 2>/dev/null || true; done
+- for i in $(DESTDIR)$(CLIPROOT)/lib/*$(DLLREALSUFF); do ln -s $$i $(DESTDIR)$(STD_LIBDIR) 2>/dev/null || true; done
+- for i in $(DESTDIR)$(CLIPROOT)/lib/*.a; do ln -s $$i $(DESTDIR)$(STD_LIBDIR) 2>/dev/null || true; done
++# for i in $(DESTDIR)$(CLIPROOT)/lib/*$(DLLSUFF); do ln -s $$i $(DESTDIR)$(STD_LIBDIR) 2>/dev/null || true; done
++# for i in $(DESTDIR)$(CLIPROOT)/lib/*$(DLLREALSUFF); do ln -s $$i $(DESTDIR)$(STD_LIBDIR) 2>/dev/null || true; done
++# for i in $(DESTDIR)$(CLIPROOT)/lib/*.a; do ln -s $$i $(DESTDIR)$(STD_LIBDIR) 2>/dev/null || true; done
+
+ inst_screen:
+ cd screen/install \
diff --git a/databases/clip/files/patch-cliplibs::clip-gtkextra::configure b/databases/clip/files/patch-cliplibs::clip-gtkextra::configure
index 02a562795007..74354c9f3d9c 100644
--- a/databases/clip/files/patch-cliplibs::clip-gtkextra::configure
+++ b/databases/clip/files/patch-cliplibs::clip-gtkextra::configure
@@ -1,5 +1,5 @@
---- cliplibs/clip-gtkextra/configure.orig Mon Oct 25 19:56:51 2004
-+++ cliplibs/clip-gtkextra/configure Fri Apr 15 21:24:57 2005
+--- cliplibs/clip-gtkextra/configure.orig Mon Dec 19 16:26:28 2005
++++ cliplibs/clip-gtkextra/configure Thu Jul 13 15:18:16 2006
@@ -3,6 +3,10 @@
uname=`uname -s`
uver=`uname -r`
@@ -61,12 +61,12 @@
echo "****************************************************************************"
USE_GTK_EXTRA=no
else
-- gtkextraincpath=`find $gtkextraprefix/include -name 'gtkextra.h' -printf '%h'`
-+ gtkextraincpath=`find $gtkprefix/include -name 'gtk.h' -exec dirname {} \;`
- cd $gtkextraincpath/..
- gtkextraincpath=`pwd`
- cd $oldpwd
-@@ -173,7 +182,7 @@
+- gtkextraincpath=`find $gtkextraprefix/include -name 'gtkextra.h' -printf ' %h'`
++ gtkextraincpath=`find $gtkextraprefix/include -name 'gtkextra.h' -exec dirname {} \;`
+ trt=$gtkextraincpath
+ gtkextraincpath=
+ for ii in $trt
+@@ -186,7 +195,7 @@
echo "COMPILER='$CC'" >&3
echo "DLLSUFF='$DLLSUFF'" >&3
echo "DLLREALSUFF='$DLLREALSUFF'" >&3
diff --git a/databases/clip/files/patch-cliplibs_Makefile b/databases/clip/files/patch-cliplibs_Makefile
index 2d26567de1af..cf0ac605f524 100644
--- a/databases/clip/files/patch-cliplibs_Makefile
+++ b/databases/clip/files/patch-cliplibs_Makefile
@@ -1,19 +1,21 @@
---- cliplibs/Makefile.orig Sat Jan 22 01:58:51 2005
-+++ cliplibs/Makefile Sun Apr 17 11:26:06 2005
-@@ -1,17 +1,27 @@
+--- cliplibs/Makefile.orig Tue Apr 11 06:54:48 2006
++++ cliplibs/Makefile Thu Jul 13 16:30:02 2006
+@@ -1,18 +1,29 @@
#
+# FreeBSD changes:
+# - remove some directories from being built automatically
+# - switch from shell for (which never fails) to phony targets (fail fast)
+# - build in any directories specified in OPT_CLIPLIBS
+# - execute install target to install libs into the temporary CLIPROOT
-+# under WRKSRC, so the rest of clip can find them.
++# under WRKSRC, so the rest of clip can find them
++# - clip-xml built before clip-ui.
dirs = clip-gzip clip-bzip2 clip-crypto clip-gd clip-fcgi \
clip-cti clip-gtk clip-gtkextra clip-gtk2 clip-fw \
- clip-mysql clip-postgres clip-oracle clip-interbase clip-odbc \
- clip-com clip-oasis clip-rtf clip-r2d2 clip-ui \
-
+- clip-com clip-oasis clip-rtf clip-r2d2 clip-ui \
+- clip-xml clip-glade2
+-
-all local user system install lib:
- for dir in $(dirs); \
- do \
@@ -21,6 +23,9 @@
- [ -x ./configure ] && ./configure ;\
- $(MAKE) $@ );\
- done
++ clip-com clip-oasis clip-rtf clip-r2d2 clip-xml clip-ui \
++ clip-glade2
++
+dirs += $(OPT_CLIPLIBS)
+
+.PHONY: subdirs $(dirs)
diff --git a/databases/clip/files/patch-cliplibs_clip-cti_Makefile b/databases/clip/files/patch-cliplibs_clip-cti_Makefile
new file mode 100644
index 000000000000..59cb31b0c42a
--- /dev/null
+++ b/databases/clip/files/patch-cliplibs_clip-cti_Makefile
@@ -0,0 +1,17 @@
+--- cliplibs/clip-cti/Makefile.orig Mon Mar 6 12:05:28 2006
++++ cliplibs/clip-cti/Makefile Thu Jul 13 15:58:51 2006
+@@ -74,11 +74,11 @@
+ -cp ./.calendar $(DESTDIR)$(CLIPROOT)/etc
+
+ rm_include:
+- rm -rf $(CLIPROOT)/include/cti
+- rm -f $(CLIPROOT)/cti.ch
++ #rm -rf $(CLIPROOT)/include/cti
++ #rm -f $(CLIPROOT)/cti.ch
+
+ links:
+- #[ -d include/cti ] || (cd include && ln -sf . cti)
++ [ -d include/cti ] || (cd include && ln -sf . cti)
+
+ $(LIB): $(OBJS)
+ rm -f $(LIB)
diff --git a/databases/clip/pkg-plist b/databases/clip/pkg-plist
index 4ff642945b2d..4f23e7895c47 100644
--- a/databases/clip/pkg-plist
+++ b/databases/clip/pkg-plist
@@ -430,6 +430,15 @@ clip/doc/example/clip-ui/icons/reference_partner.xpm
clip/doc/example/clip-ui/icons/tick.xpm
clip/doc/example/clip-ui/testWindow.xfl
clip/doc/example/clip-ui/test_ui.prg
+clip/doc/example/clip-xml/Makefile
+clip/doc/example/clip-xml/XPath_tests.tar.gz
+clip/doc/example/clip-xml/c.xml
+clip/doc/example/clip-xml/component.dtd
+clip/doc/example/clip-xml/component.xml
+clip/doc/example/clip-xml/currency.xml
+clip/doc/example/clip-xml/test-koi8-r.xml
+clip/doc/example/clip-xml/test.prg
+clip/doc/example/clip-xml/test_xml.prg
clip/doc/example/hello.prg
clip/doc/example/inkey.prg
clip/doc/example/mouse.prg
@@ -505,6 +514,8 @@ clip/include/box.ch
clip/include/browsys.ch
clip/include/btree.h
clip/include/button.ch
+clip/include/clip-expat.ch
+clip/include/clip-expat.h
clip/include/clip-gtk.ch
clip/include/clip-gtk.h
clip/include/clip-gtk2.ch
@@ -666,6 +677,7 @@ clip/include/reserved.ch
clip/include/richtext.ch
clip/include/rp_dot.ch
clip/include/rp_run.ch
+clip/include/screen/charset.h
clip/include/set.ch
clip/include/setcurs.ch
clip/include/setnames.ch
@@ -756,6 +768,10 @@ clip/lib/libclip-gd.a
clip/lib/libclip-gd.ex
clip/lib/libclip-gd.nm
clip/lib/libclip-gd.so
+clip/lib/libclip-glade2.a
+clip/lib/libclip-glade2.ex
+clip/lib/libclip-glade2.nm
+clip/lib/libclip-glade2.so
clip/lib/libclip-gtk.a
clip/lib/libclip-gtk.ex
clip/lib/libclip-gtk.nm
@@ -791,6 +807,10 @@ clip/lib/libclip-rtf.so
clip/lib/libclip-ui.ex
clip/lib/libclip-ui.nm
clip/lib/libclip-ui.so
+clip/lib/libclip-xml.a
+clip/lib/libclip-xml.ex
+clip/lib/libclip-xml.nm
+clip/lib/libclip-xml.so
clip/lib/libclip.a
clip/lib/libclip.ex
clip/lib/libclip.nm
@@ -930,6 +950,7 @@ clip/locale.pot/clip-r2d2/_.pot
clip/locale.pot/clip-r2d2/acc_log.pot
clip/locale.pot/clip-r2d2/balance.pot
clip/locale.pot/clip-r2d2/balance2.pot
+clip/locale.pot/clip-r2d2/cgi_funcs.pot
clip/locale.pot/cobra_clnt/_.pot
clip/locale.pot/cobra_clnt/objbrowse.pot
clip/locale.pot/cobra_serv/_.pot
@@ -976,6 +997,7 @@ clip/locale.pot/sys/foxsel.pot
clip/locale.pot/sys/ftools.pot
clip/locale.pot/sys/get_obj.pot
clip/locale.pot/sys/hbrowse.pot
+clip/locale.pot/sys/hparser.pot
clip/locale.pot/sys/http_service.pot
clip/locale.pot/sys/inifile.pot
clip/locale.pot/sys/memoedit.pot
@@ -1062,6 +1084,7 @@ clip/term/pcansi
@dirrm clip/kamache/mod-ini
@dirrm clip/kamache/mod-clip
@dirrm clip/kamache
+@dirrm clip/include/screen
@dirrm clip/include/netto
@dirrm clip/include/nanfor
@dirrm clip/include/fwin
@@ -1079,6 +1102,7 @@ clip/term/pcansi
@dirrm clip/etc/terminfo/a
@dirrm clip/etc/terminfo
@dirrm clip/etc
+@dirrm clip/doc/example/clip-xml
@dirrm clip/doc/example/clip-ui/icons
@dirrm clip/doc/example/clip-ui
@dirrm clip/doc/example/clip-rtf