aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorClive Lin <clive@FreeBSD.org>2000-12-07 00:39:24 +0800
committerClive Lin <clive@FreeBSD.org>2000-12-07 00:39:24 +0800
commita76b70a2051c055d28a02120dc36c7a0a7c5c4f9 (patch)
tree2328e32c54e2e36ecf9fcf02789688d858dbabab /devel
parent8db820f3342a065791c2218a456f18fb638da3d8 (diff)
downloadfreebsd-ports-a76b70a2051c055d28a02120dc36c7a0a7c5c4f9.tar.gz
freebsd-ports-a76b70a2051c055d28a02120dc36c7a0a7c5c4f9.tar.zst
freebsd-ports-a76b70a2051c055d28a02120dc36c7a0a7c5c4f9.zip
KeLP (Kernel Lattice Parallelism) is an infrastructure/interface to
FORTRAN 77 or C numeric kernels using FORTRAN array ordering. It is usually used for structured block-irregular grid computational applications. Submitted by: Michael Wu <keichii@iteration.net> Reviewed by: keith@FreeBSD.org Approved by: keith@FreeBSD.org
Notes
Notes: svn path=/head/; revision=35721
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/kelp/Makefile75
-rw-r--r--devel/kelp/distinfo1
-rw-r--r--devel/kelp/files/patch-config:x86-g++-linux52
-rw-r--r--devel/kelp/files/patch-configure25
-rw-r--r--devel/kelp/files/patch-mp++:config.h21
-rw-r--r--devel/kelp/pkg-comment1
-rw-r--r--devel/kelp/pkg-descr21
-rw-r--r--devel/kelp/pkg-message4
-rw-r--r--devel/kelp/pkg-plist723
10 files changed, 924 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 32ecaeccf1fa..217f88777c41 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -121,6 +121,7 @@
SUBDIR += kdbg
SUBDIR += kdelibdocs
SUBDIR += kdevelop
+ SUBDIR += kelp
SUBDIR += kpp
SUBDIR += ktranslator
SUBDIR += lclint
diff --git a/devel/kelp/Makefile b/devel/kelp/Makefile
new file mode 100644
index 000000000000..2ecea9ccc7cd
--- /dev/null
+++ b/devel/kelp/Makefile
@@ -0,0 +1,75 @@
+# New ports collection makefile for: KeLP
+# Date created: 5 May 2000
+# Whom: Michael Wu <keichii@iteration.net>
+# $FreeBSD$
+#
+
+PORTNAME= kelp
+PORTVERSION= 1.3
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.cs.ucsd.edu/pub/scg/KeLP/
+DISTNAME= KeLP1.3
+
+MAINTAINER= keichii@iteration.net
+
+BUILD_DEPENDS= ${LOCALBASE}/mpich/bin/mpirun:${PORTSDIR}/net/mpich
+
+MAN3= kelp.3
+MANCOMPRESSED= yes
+
+WRKSRC= ${WRKDIR}/${DISTNAME}_src
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+MAKE_ENV= KELP_HOME=${WRKSRC}
+
+#FIND= /usr/bin/find
+INST_DIST= bin dgrid doc dock examples include kelp lib mp++ tools
+INST_KELP_HOME= ${LOCALBASE}/kelp
+
+post-patch:
+ @${PERL} -pi -e 's,API2,./API2,' ${WRKSRC}/examples/API/makefile
+ @${PERL} -pi -e 's,API3,./API3,' ${WRKSRC}/examples/API/makefile
+ @${PERL} -pi -e 's,%LOCALBASE%,${LOCALBASE},' ${WRKSRC}/configure
+
+do-install:
+ @${MKDIR} ${INST_KELP_HOME}
+ @${ECHO} "Installing kelp into ${INST_KELP_HOME}"
+.for i in ${INST_DIST}
+ @${CP} -r ${WRKSRC}/${i} ${INST_KELP_HOME}
+.endfor
+ @${ECHO} "Deleting un-needed files."
+ @cd ${INST_KELP_HOME} ; \
+ find ./ \
+ \( \
+ -name "*.orig" -or -name "*.old" -or -name "*.log" -or -name "*.out" \
+ -or -name "*.o" -or -name "*.bck" -or -name "*.o2k" -or -name "*.ls" \
+ \) -delete
+
+ @cd ${INST_KELP_HOME} ; ${RM} lib/.empty_file_for_tar
+
+ @${ECHO} "Changing mode of files that shouldn't be executable."
+ @cd ${INST_KELP_HOME} ; \
+ find ./ \
+ \( \
+ -name "*.C" -or -name "*.h" -or -name "*.m4" -or -name README \
+ -or -name COPYING -or -name "*.c" -or -name "*.F" -or -name "*.f" \
+ \) -exec ${CHMOD} +r-x {} \;
+
+ @${ECHO} "Changing executable files mode to 555."
+ @cd ${INST_KELP_HOME} ; \
+ find ./ -type f \( -perm -+x -or -perm 750 \) \
+ -exec ${CHMOD} 555 {} \;
+
+ @${ECHO} "Changing normal files mode to 444."
+ @cd ${INST_KELP_HOME} ; \
+ find ./ -type f \( -perm 644 -or -perm 640 \) \
+ -exec ${CHMOD} 444 {} \;
+
+.if !defined(NOPORTDOCS)
+ @${GZIP_CMD} ${WRKSRC}/man/man3/kelp.3 -c > \
+ ${LOCALBASE}/man/man3/kelp.3.gz
+.endif
+ @${CAT} ${PKGMESSAGE}
+.include <bsd.port.mk>
diff --git a/devel/kelp/distinfo b/devel/kelp/distinfo
new file mode 100644
index 000000000000..3419538b8fcb
--- /dev/null
+++ b/devel/kelp/distinfo
@@ -0,0 +1 @@
+MD5 (KeLP1.3.tar.gz) = 61babeebe0785944f7ca8c55bb0dba33
diff --git a/devel/kelp/files/patch-config:x86-g++-linux b/devel/kelp/files/patch-config:x86-g++-linux
new file mode 100644
index 000000000000..1befd52022d6
--- /dev/null
+++ b/devel/kelp/files/patch-config:x86-g++-linux
@@ -0,0 +1,52 @@
+diff -crN config/x86-g++-linux.orig config/x86-g++-linux
+*** config/x86-g++-linux.orig Thu Oct 28 20:54:54 1999
+--- config/x86-g++-linux Sat May 6 21:25:19 2000
+***************
+*** 7,13 ****
+
+ ARCHITECTURE = x86-g++-linux
+
+! MPI_DIR = /net/boltzmann/disk3/mpich
+
+ RM = rm -f
+ LN = ln -s
+--- 7,13 ----
+
+ ARCHITECTURE = x86-g++-linux
+
+! MPI_DIR = /usr/local/mpich
+
+ RM = rm -f
+ LN = ln -s
+***************
+*** 15,29 ****
+
+ C++ = g++
+ CC = gcc
+! F77 = g77
+ C++LINK = g++
+ #C++LINK = g++ -static
+ AR = ar
+ RANLIB = ranlib
+
+ MPI_INCLUDE = $(MPI_DIR)/include
+! #MPI_LIB = $(MPI_DIR)/lib/LINUX/ch_p4
+! MPI_LIB = $(MPI_DIR)/build/LINUX/ch_p4/lib
+
+ INCLUDES = -I. -I$(KELP_HOME)/include -I$(MPI_INCLUDE) $(USR_INCLUDE)
+ ARCH_FLAGS = -DLINUX
+--- 15,28 ----
+
+ C++ = g++
+ CC = gcc
+! F77 = f77
+ C++LINK = g++
+ #C++LINK = g++ -static
+ AR = ar
+ RANLIB = ranlib
+
+ MPI_INCLUDE = $(MPI_DIR)/include
+! MPI_LIB = $(MPI_DIR)/lib
+
+ INCLUDES = -I. -I$(KELP_HOME)/include -I$(MPI_INCLUDE) $(USR_INCLUDE)
+ ARCH_FLAGS = -DLINUX
diff --git a/devel/kelp/files/patch-configure b/devel/kelp/files/patch-configure
new file mode 100644
index 000000000000..9250e1fad5b1
--- /dev/null
+++ b/devel/kelp/files/patch-configure
@@ -0,0 +1,25 @@
+--- configure.orig Sun Nov 26 18:36:01 2000
++++ configure Tue Dec 5 18:23:11 2000
+@@ -21,9 +21,9 @@
+ if [ -d /opt/SUNWhpc ] ; then
+ # user has hpc environment
+ MACHID="${MACHID}hpc" ;
+- elif [ -x `which mpirun` -a -x `which g++` ] ; then
++ elif [ -x `which %LOCALBASE%/mpich/bin/mpirun` -a -x `which g++` ] ; then
+ # user has g++ and mpich environment
+- MACHID="${MACHID}g++mpich" ;
++ MACHID="x86-g++-linux" ;
+ fi
+ fi
+
+@@ -33,8 +33,8 @@
+ ARCHITECTURE=""
+
+ if [ -n "$1" ] ; then
+- if [ -f config/${1} ] ; then
+- ARCHITECTURE=$1 ;
++ if [ -f config/x86-g++-linux ] ; then
++ ARCHITECTURE=x86-g++-linux ;
+ echo "found ${ARCHITECTURE}" ;
+ else
+ echo "ERROR. config/${1} not found" ;
diff --git a/devel/kelp/files/patch-mp++:config.h b/devel/kelp/files/patch-mp++:config.h
new file mode 100644
index 000000000000..3fdd277d2d0e
--- /dev/null
+++ b/devel/kelp/files/patch-mp++:config.h
@@ -0,0 +1,21 @@
+--- mp++/config.h.orig Tue Dec 5 17:55:10 2000
++++ mp++/config.h Tue Dec 5 17:56:20 2000
+@@ -3,6 +3,18 @@
+ #ifndef CONFIG_H_Included
+ #define CONFIG_H_Included
+
++#if (defined(__linux__) || defined(__sparc__) || defined(__FreeBSD__))
++# define PASTE_H "paste.h"
++#else
++# define PASTE_H <generic.h>
++#endif
++
++#endif // CONFIG_H_Included
++// This is a basic configuration header file to handle machine variations.
++
++#ifndef CONFIG_H_Included
++#define CONFIG_H_Included
++
+ #if (defined(__linux__) || defined(__sparc__)|| defined(_AIX))
+ # define PASTE_H "paste.h"
+ #else
diff --git a/devel/kelp/pkg-comment b/devel/kelp/pkg-comment
new file mode 100644
index 000000000000..5dec8022ae52
--- /dev/null
+++ b/devel/kelp/pkg-comment
@@ -0,0 +1 @@
+KeLP is a software infrastructure for parallel computing
diff --git a/devel/kelp/pkg-descr b/devel/kelp/pkg-descr
new file mode 100644
index 000000000000..2cb25ddf881e
--- /dev/null
+++ b/devel/kelp/pkg-descr
@@ -0,0 +1,21 @@
+KeLP is designed and maintained by a group at the University of California
+at San Diego. Associate Professor Scott B. Baden of Computer Science and
+Engineering is the director of the KeLP Project KeLP was part of the
+dissertation topic of Stephen J. Fink (Ph.D. 1998) and portions of a
+prototype of KeLP were developed by Scott R. Kohn (Ph.D. 1995). KeLP is
+supported by the NSF, the University of California, San Diego, and the
+National Partnership for Advanced Computational Infrastructure (NPACI).
+KeLP is part of NPACI's Kommon Adaptive Runtime Environment (KARTE) effort.
+
+KeLP (Kernel Lattice Parallelism) is an infrastructure/interface to
+FORTRAN 77 or C numeric kernels using FORTRAN array ordering. It is usually
+used for structured block-irregular grid computational applications.
+ KeLP uses coarse-grain data parallelism for its parallel model and should
+be run on message-passing parallel computers.
+KeLP is targeted towards adaptive mesh refinement applications and
+single-grid calculations requiring uniform or non-uniform decompositions
+across machine processors. Applications manipulate data decompositions as
+language objects through region calculus operations.
+
+WWW: http://www-cse.ucsd.edu/groups/hpcl/scg/kelp/index.html
+- Keichii <keichii@iteration.net>
diff --git a/devel/kelp/pkg-message b/devel/kelp/pkg-message
new file mode 100644
index 000000000000..9abad7dd5d40
--- /dev/null
+++ b/devel/kelp/pkg-message
@@ -0,0 +1,4 @@
+============================!! NOTICE !!================================
+The FreeBSD KeLP port is untested.
+Please do not assume it to behave the same as the KeLP on other platforms.
+========================================================================
diff --git a/devel/kelp/pkg-plist b/devel/kelp/pkg-plist
new file mode 100644
index 000000000000..a021dfb4b001
--- /dev/null
+++ b/devel/kelp/pkg-plist
@@ -0,0 +1,723 @@
+kelp/bin/Xto3
+kelp/bin/Xto1
+kelp/bin/Xto2
+kelp/bin/Compare
+kelp/bin/Xto4
+kelp/bin/machid
+kelp/bin/setfmods
+kelp/dgrid/replicatedGrid4.C
+kelp/dgrid/CollectiveGroup.h
+kelp/dgrid/dgTemplates1.C
+kelp/dgrid/collapse.C
+kelp/dgrid/collapse.h
+kelp/dgrid/dGrid.h
+kelp/dgrid/dGridX.C.m4
+kelp/dgrid/dGridX.h.m4
+kelp/dgrid/makefile
+kelp/dgrid/replicatedGridX.C.m4
+kelp/dgrid/replicatedGridX.h.m4
+kelp/dgrid/dgTemplates2.C
+kelp/dgrid/dgTemplates3.C
+kelp/dgrid/dgTemplates4.C
+kelp/dgrid/dGrid1.h
+kelp/dgrid/dGrid2.h
+kelp/dgrid/dGrid3.h
+kelp/dgrid/dGrid4.h
+kelp/dgrid/replicatedGrid1.h
+kelp/dgrid/dGrid1.C
+kelp/dgrid/replicatedGrid2.h
+kelp/dgrid/replicatedGrid3.h
+kelp/dgrid/replicatedGrid4.h
+kelp/dgrid/dGrid2.C
+kelp/dgrid/dGrid3.C
+kelp/dgrid/dGrid4.C
+kelp/dgrid/replicatedGrid1.C
+kelp/dgrid/replicatedGrid2.C
+kelp/dgrid/replicatedGrid3.C
+kelp/dgrid/CollectiveGroup.C
+kelp/doc/README
+kelp/dock/Decomposition4.C
+kelp/dock/DecompositionX.h.m4
+kelp/dock/GhostIteratorX.C.m4
+kelp/dock/GhostIteratorX.h.m4
+kelp/dock/GhostPlanX.C.m4
+kelp/dock/GhostPlanX.h.m4
+kelp/dock/ProcessorsX.C.m4
+kelp/dock/ProcessorsX.h.m4
+kelp/dock/dock.h
+kelp/dock/makefile
+kelp/dock/Processors1.h
+kelp/dock/Processors2.h
+kelp/dock/Processors3.h
+kelp/dock/Processors4.h
+kelp/dock/GhostPlan1.h
+kelp/dock/GhostPlan2.h
+kelp/dock/GhostPlan3.h
+kelp/dock/GhostPlan4.h
+kelp/dock/GhostIterator1.h
+kelp/dock/GhostIterator2.h
+kelp/dock/GhostIterator3.h
+kelp/dock/GhostIterator4.h
+kelp/dock/Decomposition1.h
+kelp/dock/Decomposition2.h
+kelp/dock/Decomposition3.h
+kelp/dock/Decomposition4.h
+kelp/dock/Processors1.C
+kelp/dock/Processors2.C
+kelp/dock/Processors3.C
+kelp/dock/Processors4.C
+kelp/dock/GhostPlan1.C
+kelp/dock/GhostPlan2.C
+kelp/dock/GhostPlan3.C
+kelp/dock/GhostPlan4.C
+kelp/dock/GhostIterator1.C
+kelp/dock/GhostIterator2.C
+kelp/dock/GhostIterator3.C
+kelp/dock/GhostIterator4.C
+kelp/dock/Decomposition1.C
+kelp/dock/Decomposition2.C
+kelp/dock/Decomposition3.C
+kelp/dock/DecompositionX.C.m4
+kelp/examples/rb3D/batch_scripts/p8.script
+kelp/examples/rb3D/batch_scripts/P16a
+kelp/examples/rb3D/batch_scripts/P32
+kelp/examples/rb3D/batch_scripts/P4
+kelp/examples/rb3D/batch_scripts/P4i
+kelp/examples/rb3D/batch_scripts/P64
+kelp/examples/rb3D/batch_scripts/P8
+kelp/examples/rb3D/batch_scripts/p16.script
+kelp/examples/rb3D/batch_scripts/p16a.script
+kelp/examples/rb3D/batch_scripts/p32.script
+kelp/examples/rb3D/batch_scripts/p4.script
+kelp/examples/rb3D/batch_scripts/p64.script
+kelp/examples/rb3D/batch_scripts/P16
+kelp/examples/rb3D/ComputeLocalPJ.C
+kelp/examples/rb3D/ComputeLocalRB.C
+kelp/examples/rb3D/ComputeNorm.C
+kelp/examples/rb3D/InitGrid.C
+kelp/examples/rb3D/Motion.C
+kelp/examples/rb3D/README
+kelp/examples/rb3D/ReportTimes.C
+kelp/examples/rb3D/cmdLine.C
+kelp/examples/rb3D/j3D.h
+kelp/examples/rb3D/makefile
+kelp/examples/rb3D/manhattan.C
+kelp/examples/rb3D/manhattan.h
+kelp/examples/rb3D/rb.F
+kelp/examples/rb3D/rb3D.C
+kelp/examples/rb3D/rbp.F
+kelp/examples/rb3D/timer.h
+kelp/examples/rb3D/rb3D
+kelp/examples/NAS-FT/OLDER/makefile
+kelp/examples/NAS-FT/OLDER/cmdLine.C
+kelp/examples/NAS-FT/OLDER/ft.C
+kelp/examples/NAS-FT/OLDER/ftTemplates.C
+kelp/examples/NAS-FT/OLDER/ftTemplates2.C
+kelp/examples/NAS-FT/OLDER/npbft.F
+kelp/examples/NAS-FT/OLDER/save.C
+kelp/examples/NAS-FT/OLDER/timer.h
+kelp/examples/NAS-FT/OLDER/cfft3.C
+kelp/examples/NAS-FT/batch_scripts/verify.sp2.p=8
+kelp/examples/NAS-FT/batch_scripts/P16
+kelp/examples/NAS-FT/batch_scripts/P2
+kelp/examples/NAS-FT/batch_scripts/P32
+kelp/examples/NAS-FT/batch_scripts/P4
+kelp/examples/NAS-FT/batch_scripts/P64
+kelp/examples/NAS-FT/batch_scripts/P8
+kelp/examples/NAS-FT/batch_scripts/p16.script
+kelp/examples/NAS-FT/batch_scripts/p32.script
+kelp/examples/NAS-FT/batch_scripts/p64.script
+kelp/examples/NAS-FT/batch_scripts/p8.script
+kelp/examples/NAS-FT/batch_scripts/P1
+kelp/examples/NAS-FT/cfft3.C
+kelp/examples/NAS-FT/cmdLine.C
+kelp/examples/NAS-FT/ft.C
+kelp/examples/NAS-FT/ftTemplates.C
+kelp/examples/NAS-FT/ftTemplates2.C
+kelp/examples/NAS-FT/makefile
+kelp/examples/NAS-FT/npbft.F
+kelp/examples/NAS-FT/save.C
+kelp/examples/NAS-FT/timer.h
+kelp/examples/NAS-FT/mp_complex.C
+kelp/examples/NAS-FT/ft
+kelp/examples/NAS-FT/README
+kelp/examples/NAS-MG/batch_scripts/p8nc
+kelp/examples/NAS-MG/batch_scripts/P32
+kelp/examples/NAS-MG/batch_scripts/P64
+kelp/examples/NAS-MG/batch_scripts/P8
+kelp/examples/NAS-MG/batch_scripts/p16nc
+kelp/examples/NAS-MG/batch_scripts/p32nc
+kelp/examples/NAS-MG/batch_scripts/p64nc
+kelp/examples/NAS-MG/batch_scripts/P16
+kelp/examples/NAS-MG/Interlevel.C
+kelp/examples/NAS-MG/Interlevel.h
+kelp/examples/NAS-MG/README
+kelp/examples/NAS-MG/Stencil.C
+kelp/examples/NAS-MG/Stencil.h
+kelp/examples/NAS-MG/cmdLine.C
+kelp/examples/NAS-MG/fdGrid.C
+kelp/examples/NAS-MG/fdGrid.h
+kelp/examples/NAS-MG/makefile
+kelp/examples/NAS-MG/mg.C
+kelp/examples/NAS-MG/mg.f
+kelp/examples/NAS-MG/mg.h
+kelp/examples/NAS-MG/mgHierarchy.C
+kelp/examples/NAS-MG/mgHierarchy.h
+kelp/examples/NAS-MG/mgLevel.C
+kelp/examples/NAS-MG/mgLevel.h
+kelp/examples/NAS-MG/npbmg.F
+kelp/examples/NAS-MG/sum.F
+kelp/examples/NAS-MG/timer.h
+kelp/examples/NAS-MG/mg
+kelp/examples/SUMMA/batch_scripts/verify.sp2.p=8
+kelp/examples/SUMMA/batch_scripts/P16NC
+kelp/examples/SUMMA/batch_scripts/P32
+kelp/examples/SUMMA/batch_scripts/P32NC
+kelp/examples/SUMMA/batch_scripts/P64
+kelp/examples/SUMMA/batch_scripts/P64NC
+kelp/examples/SUMMA/batch_scripts/P8
+kelp/examples/SUMMA/batch_scripts/P8NC
+kelp/examples/SUMMA/batch_scripts/P8c
+kelp/examples/SUMMA/batch_scripts/p16nc.scr
+kelp/examples/SUMMA/batch_scripts/p32nc.scr
+kelp/examples/SUMMA/batch_scripts/p64nc.scr
+kelp/examples/SUMMA/batch_scripts/p8nc.scr
+kelp/examples/SUMMA/batch_scripts/P16
+kelp/examples/SUMMA/README
+kelp/examples/SUMMA/cmdLine.C
+kelp/examples/SUMMA/g2dgemm.C
+kelp/examples/SUMMA/makefile
+kelp/examples/SUMMA/pdgemm.C
+kelp/examples/SUMMA/summa.C
+kelp/examples/SUMMA/summa.h
+kelp/examples/SUMMA/summaTemplates.C
+kelp/examples/SUMMA/summaTemplates2.C
+kelp/examples/SUMMA/timer.h
+kelp/examples/SUMMA/verify.C
+kelp/examples/SUMMA_MPI/sp2.scripts/P16
+kelp/examples/SUMMA_MPI/sp2.scripts/P32
+kelp/examples/SUMMA_MPI/sp2.scripts/P64
+kelp/examples/SUMMA_MPI/sp2.scripts/P8
+kelp/examples/SUMMA_MPI/README
+kelp/examples/SUMMA_MPI/check.c
+kelp/examples/SUMMA_MPI/cmdLine.c
+kelp/examples/SUMMA_MPI/driver2.c
+kelp/examples/SUMMA_MPI/genproblem.c
+kelp/examples/SUMMA_MPI/genproblem1.c
+kelp/examples/SUMMA_MPI/makefile
+kelp/examples/SUMMA_MPI/makefile.alpha
+kelp/examples/SUMMA_MPI/makefile.o2000
+kelp/examples/SUMMA_MPI/makefile.sp2
+kelp/examples/SUMMA_MPI/pdmmult.ab.c
+kelp/examples/SUMMA_MPI/printmatrix.c
+kelp/examples/SUMMA_MPI/rand.c
+kelp/examples/SUMMA_MPI/dlacpy.F
+kelp/examples/SUMMA_MPI/summa.h
+kelp/examples/jacobi2D_noAPI/jacobi2D
+kelp/examples/jacobi2D_noAPI/jacobi.F
+kelp/examples/jacobi2D_noAPI/jacobi2D.C
+kelp/examples/jacobi2D_noAPI/jacobi2D.h
+kelp/examples/jacobi2D_noAPI/makefile
+kelp/examples/jacobi2D_noAPI/README
+kelp/examples/jacobi2D_useAPI/jacobi2D
+kelp/examples/jacobi2D_useAPI/jacobi.F
+kelp/examples/jacobi2D_useAPI/jacobi2D.C
+kelp/examples/jacobi2D_useAPI/jacobi2D.h
+kelp/examples/jacobi2D_useAPI/jstub.C
+kelp/examples/jacobi2D_useAPI/jstub.h
+kelp/examples/jacobi2D_useAPI/makefile
+kelp/examples/jacobi2D_useAPI/timer.h
+kelp/examples/jacobi2D_useAPI/README
+kelp/examples/jacobi3D_basic/jacobi3D
+kelp/examples/jacobi3D_basic/cmdLine.C
+kelp/examples/jacobi3D_basic/jacobi.F
+kelp/examples/jacobi3D_basic/jacobi3D.C
+kelp/examples/jacobi3D_basic/jacobi3D.h
+kelp/examples/jacobi3D_basic/jstub.C
+kelp/examples/jacobi3D_basic/jstub.h
+kelp/examples/jacobi3D_basic/makefile
+kelp/examples/jacobi3D_basic/timer.h
+kelp/examples/jacobi3D_basic/README
+kelp/examples/jacobi3D_contig/jacobi3D
+kelp/examples/jacobi3D_contig/jacobi.F
+kelp/examples/jacobi3D_contig/jacobi3D.C
+kelp/examples/jacobi3D_contig/jacobi3D.h
+kelp/examples/jacobi3D_contig/jstub.C
+kelp/examples/jacobi3D_contig/jstub.h
+kelp/examples/jacobi3D_contig/makefile
+kelp/examples/jacobi3D_contig/manhattan.C
+kelp/examples/jacobi3D_contig/manhattan.h
+kelp/examples/jacobi3D_contig/timer.h
+kelp/examples/jacobi3D_contig/README
+kelp/examples/jacobi3D_manhattan/jacobi3D
+kelp/examples/jacobi3D_manhattan/jacobi.F
+kelp/examples/jacobi3D_manhattan/jacobi3D.C
+kelp/examples/jacobi3D_manhattan/jacobi3D.h
+kelp/examples/jacobi3D_manhattan/jstub.C
+kelp/examples/jacobi3D_manhattan/jstub.h
+kelp/examples/jacobi3D_manhattan/makefile
+kelp/examples/jacobi3D_manhattan/manhattan.C
+kelp/examples/jacobi3D_manhattan/manhattan.h
+kelp/examples/jacobi3D_manhattan/timer.h
+kelp/examples/jacobi3D_manhattan/README
+kelp/examples/API/libAPI.a
+kelp/examples/API/API3
+kelp/examples/API/APItemplates2.C
+kelp/examples/API/APItemplates3.C
+kelp/examples/API/Adder.F
+kelp/examples/API/Adder.h
+kelp/examples/API/AdderX.C
+kelp/examples/API/IO.C
+kelp/examples/API/IO.h
+kelp/examples/API/IrregularGrid.C
+kelp/examples/API/IrregularGrid.h
+kelp/examples/API/README
+kelp/examples/API/fkludge2.h
+kelp/examples/API/fkludge3.h
+kelp/examples/API/fmgrid.F
+kelp/examples/API/mGrid.C
+kelp/examples/API/mGrid.h
+kelp/examples/API/makefile
+kelp/examples/API/IO2.h
+kelp/examples/API/IrregularGrid2.h
+kelp/examples/API/mGrid2.h
+kelp/examples/API/Adder2.h
+kelp/examples/API/IO3.h
+kelp/examples/API/IrregularGrid3.h
+kelp/examples/API/mGrid3.h
+kelp/examples/API/Adder3.h
+kelp/examples/API/IO2.C
+kelp/examples/API/IrregularGrid2.C
+kelp/examples/API/mGrid2.C
+kelp/examples/API/Adder2.C
+kelp/examples/API/IO3.C
+kelp/examples/API/IrregularGrid3.C
+kelp/examples/API/mGrid3.C
+kelp/examples/API/Adder3.C
+kelp/examples/API/API2
+kelp/examples/rb3D_MPI/batch_scripts/runs.sunhpc
+kelp/examples/rb3D_MPI/batch_scripts/P32
+kelp/examples/rb3D_MPI/batch_scripts/P4
+kelp/examples/rb3D_MPI/batch_scripts/P64
+kelp/examples/rb3D_MPI/batch_scripts/P8
+kelp/examples/rb3D_MPI/batch_scripts/P=8
+kelp/examples/rb3D_MPI/batch_scripts/RUN.sunhpc
+kelp/examples/rb3D_MPI/batch_scripts/p16.script
+kelp/examples/rb3D_MPI/batch_scripts/p32.script
+kelp/examples/rb3D_MPI/batch_scripts/p64.script
+kelp/examples/rb3D_MPI/batch_scripts/p8.script
+kelp/examples/rb3D_MPI/batch_scripts/P16
+kelp/examples/rb3D_MPI/arch_archive/arch.sp2
+kelp/examples/rb3D_MPI/arch_archive/arch.sunhpc
+kelp/examples/rb3D_MPI/cmdLine.C
+kelp/examples/rb3D_MPI/getHost.C
+kelp/examples/rb3D_MPI/gethost.C
+kelp/examples/rb3D_MPI/makefile
+kelp/examples/rb3D_MPI/rb.C
+kelp/examples/rb3D_MPI/rb.h
+kelp/examples/rb3D_MPI/redblack.F
+kelp/examples/rb3D_MPI/redblack3D.C
+kelp/examples/rb3D_MPI/redblack3D.h
+kelp/examples/rb3D_MPI/timer.h
+kelp/examples/rb3D_MPI/redblack3D
+kelp/examples/rb3D_MPI/README
+kelp/examples/region3_init/README
+kelp/examples/region3_init/makefile
+kelp/examples/region3_init/region3_init.C
+kelp/examples/region3_init/region3_init
+kelp/examples/region3_xcut/README
+kelp/examples/region3_xcut/makefile
+kelp/examples/region3_xcut/region3_xcut.C
+kelp/examples/region3_xcut/region3_xcut
+kelp/examples/region3_move/region3_move_float.C
+kelp/examples/region3_move/makefile
+kelp/examples/region3_move/region3_move.C
+kelp/examples/region3_move/README
+kelp/examples/region3_move/region3_move
+kelp/examples/complex/complex_example
+kelp/examples/complex/ftTemplates.C
+kelp/examples/complex/makefile
+kelp/examples/complex/ftTemplates2.C
+kelp/examples/complex/npbft.F
+kelp/examples/complex/complex_math.F
+kelp/examples/complex/mp_complex.C
+kelp/examples/complex/cmdLine.C
+kelp/examples/complex/complex_example.C
+kelp/examples/README
+kelp/examples/makefile
+kelp/examples/stuff
+kelp/include/replicatedGrid4.C
+kelp/include/MPI.h
+kelp/include/arch.h
+kelp/include/config.h
+kelp/include/fastAlloc.h
+kelp/include/mp++.h
+kelp/include/mpError.h
+kelp/include/msg.h
+kelp/include/paste.h
+kelp/include/Abort.C
+kelp/include/fastAlloc.C
+kelp/include/mpTemplates.C
+kelp/include/random.C
+kelp/include/barrier.C
+kelp/include/init.C
+kelp/include/msg.C
+kelp/include/reduce.C
+kelp/include/broadcast.C
+kelp/include/message.C
+kelp/include/partition.C
+kelp/include/seconds.C
+kelp/include/Array.h
+kelp/include/BndError.h
+kelp/include/DimError.h
+kelp/include/Point1.h
+kelp/include/Point2.h
+kelp/include/Point3.h
+kelp/include/Point4.h
+kelp/include/Region1.h
+kelp/include/Region2.h
+kelp/include/Region3.h
+kelp/include/Region4.h
+kelp/include/BitArray1.h
+kelp/include/BitArray2.h
+kelp/include/BitArray3.h
+kelp/include/BitArray4.h
+kelp/include/IndexArray1.h
+kelp/include/IndexArray2.h
+kelp/include/IndexArray3.h
+kelp/include/IndexArray4.h
+kelp/include/Array1.h
+kelp/include/Array2.h
+kelp/include/Array3.h
+kelp/include/Array4.h
+kelp/include/Point1.C
+kelp/include/Point2.C
+kelp/include/Point3.C
+kelp/include/Point4.C
+kelp/include/Region1.C
+kelp/include/List.h
+kelp/include/Region2.C
+kelp/include/Region3.C
+kelp/include/Region4.C
+kelp/include/BitArray1.C
+kelp/include/BitArray2.C
+kelp/include/BitArray3.C
+kelp/include/IndexArray4.C
+kelp/include/IndexArray1.C
+kelp/include/IndexArray2.C
+kelp/include/IndexArray3.C
+kelp/include/Array1.C
+kelp/include/Array2.C
+kelp/include/Array3.C
+kelp/include/Array4.C
+kelp/include/Assert.h
+kelp/include/Boolean.h
+kelp/include/List.C
+kelp/include/RegError.h
+kelp/include/Statistics.h
+kelp/include/menagerie.h
+kelp/include/tools.h
+kelp/include/Assert.C
+kelp/include/Statistics.C
+kelp/include/Configuration.h
+kelp/include/KelpStats.h
+kelp/include/TagServer.h
+kelp/include/FortranRegion.h
+kelp/include/Map.h
+kelp/include/kelp.h
+kelp/include/Iterator.h
+kelp/include/NonLocError.h
+kelp/include/FloorPlan1.h
+kelp/include/FloorPlan2.h
+kelp/include/FloorPlan3.h
+kelp/include/FloorPlan4.h
+kelp/include/Grid1.h
+kelp/include/Grid2.h
+kelp/include/Grid3.h
+kelp/include/Grid4.h
+kelp/include/MotionPlan1.h
+kelp/include/MotionPlan2.h
+kelp/include/MotionPlan3.h
+kelp/include/MotionPlan4.h
+kelp/include/Mover1.h
+kelp/include/Mover2.h
+kelp/include/Mover3.h
+kelp/include/Mover4.h
+kelp/include/MsgRec1.h
+kelp/include/Grid1.C
+kelp/include/MsgRec2.h
+kelp/include/MsgRec3.h
+kelp/include/MsgRec4.h
+kelp/include/VectorMover1.h
+kelp/include/VectorMover2.h
+kelp/include/VectorMover3.h
+kelp/include/VectorMover4.h
+kelp/include/XArray1.h
+kelp/include/XArray2.h
+kelp/include/XArray3.h
+kelp/include/XArray4.h
+kelp/include/XObject1.h
+kelp/include/XObject2.h
+kelp/include/XObject3.h
+kelp/include/XObject4.h
+kelp/include/Configuration.C
+kelp/include/TagServer.C
+kelp/include/kelpTemplates3.C
+kelp/include/Iterator.C
+kelp/include/kelpTemplates1.C
+kelp/include/kelpTemplates4.C
+kelp/include/KelpStats.C
+kelp/include/kelpTemplates2.C
+kelp/include/Grid2.C
+kelp/include/FloorPlan1.C
+kelp/include/FloorPlan2.C
+kelp/include/FloorPlan3.C
+kelp/include/FloorPlan4.C
+kelp/include/Grid3.C
+kelp/include/Grid4.C
+kelp/include/MotionPlan1.C
+kelp/include/MotionPlan2.C
+kelp/include/MotionPlan3.C
+kelp/include/MotionPlan4.C
+kelp/include/Mover1.C
+kelp/include/Mover2.C
+kelp/include/Mover3.C
+kelp/include/Mover4.C
+kelp/include/VectorMover1.C
+kelp/include/VectorMover2.C
+kelp/include/VectorMover3.C
+kelp/include/VectorMover4.C
+kelp/include/XArray1.C
+kelp/include/XArray2.C
+kelp/include/XArray3.C
+kelp/include/XArray4.C
+kelp/include/dock.h
+kelp/include/dGrid.h
+kelp/include/Processors1.h
+kelp/include/Processors2.h
+kelp/include/Processors3.h
+kelp/include/Processors4.h
+kelp/include/GhostPlan1.h
+kelp/include/GhostPlan2.h
+kelp/include/GhostPlan3.h
+kelp/include/GhostPlan4.h
+kelp/include/GhostIterator1.h
+kelp/include/GhostIterator2.h
+kelp/include/GhostIterator3.h
+kelp/include/GhostIterator4.h
+kelp/include/Decomposition1.h
+kelp/include/Decomposition2.h
+kelp/include/Decomposition3.h
+kelp/include/Decomposition4.h
+kelp/include/Processors1.C
+kelp/include/Processors2.C
+kelp/include/Processors3.C
+kelp/include/Processors4.C
+kelp/include/GhostPlan1.C
+kelp/include/GhostPlan2.C
+kelp/include/GhostPlan3.C
+kelp/include/GhostPlan4.C
+kelp/include/GhostIterator1.C
+kelp/include/GhostIterator2.C
+kelp/include/GhostIterator3.C
+kelp/include/GhostIterator4.C
+kelp/include/Decomposition1.C
+kelp/include/Decomposition2.C
+kelp/include/Decomposition3.C
+kelp/include/Decomposition4.C
+kelp/include/CollectiveGroup.h
+kelp/include/collapse.h
+kelp/include/dGrid1.h
+kelp/include/dGrid2.h
+kelp/include/dGrid3.h
+kelp/include/dGrid4.h
+kelp/include/replicatedGrid1.h
+kelp/include/replicatedGrid2.h
+kelp/include/replicatedGrid3.h
+kelp/include/replicatedGrid4.h
+kelp/include/CollectiveGroup.C
+kelp/include/collapse.C
+kelp/include/dgTemplates1.C
+kelp/include/dgTemplates2.C
+kelp/include/dgTemplates3.C
+kelp/include/dgTemplates4.C
+kelp/include/dGrid1.C
+kelp/include/dGrid2.C
+kelp/include/dGrid3.C
+kelp/include/dGrid4.C
+kelp/include/replicatedGrid1.C
+kelp/include/replicatedGrid2.C
+kelp/include/replicatedGrid3.C
+kelp/include/Error.h
+kelp/kelp/XArray4.C
+kelp/kelp/Configuration.h
+kelp/kelp/FloorPlanX.C.m4
+kelp/kelp/FloorPlanX.h.m4
+kelp/kelp/FortranRegion.h
+kelp/kelp/GridX.C.m4
+kelp/kelp/GridX.h.m4
+kelp/kelp/Iterator.C
+kelp/kelp/Iterator.h
+kelp/kelp/KelpStats.C
+kelp/kelp/KelpStats.h
+kelp/kelp/Map.h
+kelp/kelp/MotionPlanX.C.m4
+kelp/kelp/MotionPlanX.h.m4
+kelp/kelp/MoverX.C.m4
+kelp/kelp/MoverX.h.m4
+kelp/kelp/MsgRecX.h.m4
+kelp/kelp/NonLocError.h
+kelp/kelp/TagServer.C
+kelp/kelp/TagServer.h
+kelp/kelp/VectorMoverX.C.m4
+kelp/kelp/kelp.h
+kelp/kelp/VectorMoverX.h.m4
+kelp/kelp/XArrayX.C.m4
+kelp/kelp/XArrayX.h.m4
+kelp/kelp/XObjectX.h.m4
+kelp/kelp/kelpTemplates1.C
+kelp/kelp/kelpTemplates2.C
+kelp/kelp/kelpTemplates3.C
+kelp/kelp/kelpTemplates4.C
+kelp/kelp/makefile
+kelp/kelp/XObject1.h
+kelp/kelp/FloorPlan1.h
+kelp/kelp/XObject2.h
+kelp/kelp/FloorPlan2.h
+kelp/kelp/XObject3.h
+kelp/kelp/FloorPlan3.h
+kelp/kelp/XObject4.h
+kelp/kelp/FloorPlan4.h
+kelp/kelp/Grid1.h
+kelp/kelp/Grid2.h
+kelp/kelp/Grid3.h
+kelp/kelp/Grid4.h
+kelp/kelp/MotionPlan1.h
+kelp/kelp/Grid1.C
+kelp/kelp/MotionPlan2.h
+kelp/kelp/MotionPlan3.h
+kelp/kelp/MotionPlan4.h
+kelp/kelp/Mover1.h
+kelp/kelp/Mover2.h
+kelp/kelp/Mover3.h
+kelp/kelp/Mover4.h
+kelp/kelp/MsgRec1.h
+kelp/kelp/MsgRec2.h
+kelp/kelp/MsgRec3.h
+kelp/kelp/MsgRec4.h
+kelp/kelp/VectorMover1.h
+kelp/kelp/VectorMover2.h
+kelp/kelp/VectorMover3.h
+kelp/kelp/VectorMover4.h
+kelp/kelp/XArray1.h
+kelp/kelp/XArray2.h
+kelp/kelp/XArray3.h
+kelp/kelp/XArray4.h
+kelp/kelp/FloorPlan1.C
+kelp/kelp/FloorPlan2.C
+kelp/kelp/FloorPlan3.C
+kelp/kelp/FloorPlan4.C
+kelp/kelp/Grid2.C
+kelp/kelp/Grid3.C
+kelp/kelp/Grid4.C
+kelp/kelp/MotionPlan1.C
+kelp/kelp/MotionPlan2.C
+kelp/kelp/MotionPlan3.C
+kelp/kelp/MotionPlan4.C
+kelp/kelp/Mover1.C
+kelp/kelp/Mover2.C
+kelp/kelp/Mover3.C
+kelp/kelp/Mover4.C
+kelp/kelp/VectorMover1.C
+kelp/kelp/VectorMover2.C
+kelp/kelp/VectorMover3.C
+kelp/kelp/VectorMover4.C
+kelp/kelp/XArray1.C
+kelp/kelp/XArray2.C
+kelp/kelp/XArray3.C
+kelp/kelp/Configuration.C
+kelp/lib/libtools.a
+kelp/lib/libmp++.a
+kelp/lib/libarray.a
+kelp/lib/libkelp.a
+kelp/lib/libdock.a
+kelp/lib/libdgrid.a
+kelp/mp++/std/cinst.h
+kelp/mp++/std/cmath.h
+kelp/mp++/std/complext.h
+kelp/mp++/std/dcomplex.h
+kelp/mp++/std/fcomplex.h
+kelp/mp++/std/ldcomplex.h
+kelp/mp++/Abort.C
+kelp/mp++/COPYING
+kelp/mp++/Error.h
+kelp/mp++/MPI.h
+kelp/mp++/README
+kelp/mp++/arch.h
+kelp/mp++/barrier.C
+kelp/mp++/broadcast.C
+kelp/mp++/config.h
+kelp/mp++/fastAlloc.C
+kelp/mp++/fastAlloc.h
+kelp/mp++/init.C
+kelp/mp++/makefile
+kelp/mp++/message.C
+kelp/mp++/mp++.h
+kelp/mp++/mpError.h
+kelp/mp++/mpTemplates.C
+kelp/mp++/msg.C
+kelp/mp++/msg.h
+kelp/mp++/partition.C
+kelp/mp++/paste.h
+kelp/mp++/random.C
+kelp/mp++/randomf.F
+kelp/mp++/reduce.C
+kelp/mp++/seconds.C
+kelp/tools/ReleaseNotes1.3
+kelp/tools/Assert.h
+kelp/tools/Boolean.h
+kelp/tools/List.C
+kelp/tools/List.h
+kelp/tools/RegError.h
+kelp/tools/Statistics.C
+kelp/tools/Statistics.h
+kelp/tools/makefile
+kelp/tools/menagerie.h
+kelp/tools/tools.h
+kelp/tools/Assert.C
+@dirrm kelp/tools
+@dirrm kelp/mp++/std
+@dirrm kelp/mp++
+@dirrm kelp/lib
+@dirrm kelp/kelp
+@dirrm kelp/include
+@dirrm kelp/examples/region3_xcut
+@dirrm kelp/examples/region3_move
+@dirrm kelp/examples/region3_init
+@dirrm kelp/examples/rb3D_MPI/batch_scripts
+@dirrm kelp/examples/rb3D_MPI/arch_archive
+@dirrm kelp/examples/rb3D_MPI
+@dirrm kelp/examples/rb3D/batch_scripts
+@dirrm kelp/examples/rb3D
+@dirrm kelp/examples/jacobi3D_manhattan
+@dirrm kelp/examples/jacobi3D_contig
+@dirrm kelp/examples/jacobi3D_basic
+@dirrm kelp/examples/jacobi2D_useAPI
+@dirrm kelp/examples/jacobi2D_noAPI
+@dirrm kelp/examples/complex
+@dirrm kelp/examples/SUMMA_MPI/sp2.scripts
+@dirrm kelp/examples/SUMMA_MPI
+@dirrm kelp/examples/SUMMA/batch_scripts
+@dirrm kelp/examples/SUMMA
+@dirrm kelp/examples/NAS-MG/batch_scripts
+@dirrm kelp/examples/NAS-MG
+@dirrm kelp/examples/NAS-FT/batch_scripts
+@dirrm kelp/examples/NAS-FT/OLDER
+@dirrm kelp/examples/NAS-FT
+@dirrm kelp/examples/API
+@dirrm kelp/examples
+@dirrm kelp/dock
+@dirrm kelp/doc
+@dirrm kelp/dgrid
+@dirrm kelp/bin
+@dirrm kelp