aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-09-02 14:20:22 +0800
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-09-02 14:20:22 +0800
commitc0aa94104ddef02707229c1111603ceae9e4b81a (patch)
tree6927652cb2f0c83a13687cb8684d383e412e85fa /devel
parentb667b34a87e675b02752ca5f2d7d9d76d6686e3f (diff)
downloadfreebsd-ports-c0aa94104ddef02707229c1111603ceae9e4b81a.tar.gz
freebsd-ports-c0aa94104ddef02707229c1111603ceae9e4b81a.tar.zst
freebsd-ports-c0aa94104ddef02707229c1111603ceae9e4b81a.zip
add xtl
A library for R/W structured data to/from an external representation
Notes
Notes: svn path=/head/; revision=47306
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/xtl/Makefile21
-rw-r--r--devel/xtl/distinfo1
-rw-r--r--devel/xtl/pkg-comment1
-rw-r--r--devel/xtl/pkg-descr20
-rw-r--r--devel/xtl/pkg-plist13
6 files changed, 57 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b7578f93ebbf..ad7190856043 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -571,6 +571,7 @@
SUBDIR += vtcl
SUBDIR += wedit
SUBDIR += xmake
+ SUBDIR += xtl
SUBDIR += xwpe
SUBDIR += xxgdb
SUBDIR += yacl
diff --git a/devel/xtl/Makefile b/devel/xtl/Makefile
new file mode 100644
index 000000000000..953b38fe047c
--- /dev/null
+++ b/devel/xtl/Makefile
@@ -0,0 +1,21 @@
+# ex:ts=8
+# New ports collection makefile for: xtl
+# Date created: Sep 1, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= xtl
+PORTVERSION= 1.4.1
+CATEGORIES= devel
+MASTER_SITES= http://xtl.sourceforge.net/
+
+MAINTAINER= ports@FreeBSD.org
+
+NO_BUILD= yes
+
+do-install:
+ ${CP} -R ${WRKSRC}/include/* ${PREFIX}/include
+
+.include <bsd.port.mk>
diff --git a/devel/xtl/distinfo b/devel/xtl/distinfo
new file mode 100644
index 000000000000..a5b104a733d7
--- /dev/null
+++ b/devel/xtl/distinfo
@@ -0,0 +1 @@
+MD5 (xtl-1.4.1.tar.gz) = d93ccaf18e490bc5dc5e9af53fd8cac2
diff --git a/devel/xtl/pkg-comment b/devel/xtl/pkg-comment
new file mode 100644
index 000000000000..ebaab696156b
--- /dev/null
+++ b/devel/xtl/pkg-comment
@@ -0,0 +1 @@
+A library for R/W structured data to/from an external representation
diff --git a/devel/xtl/pkg-descr b/devel/xtl/pkg-descr
new file mode 100644
index 000000000000..7dc599049893
--- /dev/null
+++ b/devel/xtl/pkg-descr
@@ -0,0 +1,20 @@
+XTL is a library of template classes and functions for reading/writing
+structured data to/from an external (platform independent) representation.
+This process is also usually known as marshalling, serialization or pickling,
+and is useful both for heterogeneous network programming and portable
+persistent storage.
+
+Currently, XTL supports XDR (Internet standard), GIOP CDR (CORBA standard)
+and readable ascii text (write-only) as data formats. Memory buffers and C++
+iostreams are usable as data sources/targets. Besides the usual C data types
+(basic, structs, pointers, unions), the XTL also supports C++ constructs,
+such as pointers to base classes and template types, namely, STL containers.
+
+XTL does not include any kind of IDL, and as such, the programmer is required
+to write a "filter" for each data type. The API is somewhat modeled on the
+original XDR library by Sun, in that the same filter is used for both reading
+and writing. However, heavy usage of templates makes the API simpler and type
+safe. Function inlining and careful avoidance of pointers or virtual
+functions, also make generated code faster.
+
+WWW: http://xtl.sourceforge.net/
diff --git a/devel/xtl/pkg-plist b/devel/xtl/pkg-plist
new file mode 100644
index 000000000000..657db9ea0dbf
--- /dev/null
+++ b/devel/xtl/pkg-plist
@@ -0,0 +1,13 @@
+include/xtl.h
+include/xtl/autobuf.h
+include/xtl/autoio.h
+include/xtl/config.h
+include/xtl/giop.h
+include/xtl/graphio.h
+include/xtl/iostrbuf.h
+include/xtl/macros.h
+include/xtl/objio.h
+include/xtl/text.h
+include/xtl/vobjio.h
+include/xtl/xdr.h
+@dirrm include/xtl