aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>2000-08-03 17:28:57 +0800
committerSatoshi Asami <asami@FreeBSD.org>2000-08-03 17:28:57 +0800
commitc6bcad2436d925c98052ed292bd0794ae0e34b45 (patch)
tree4752ebd6e8eb5959ebf00516e4ecf7156215bbce /devel
parentfbd121eee966abfc21d176cbede935ecd6bf1a34 (diff)
downloadfreebsd-ports-c6bcad2436d925c98052ed292bd0794ae0e34b45.tar.gz
freebsd-ports-c6bcad2436d925c98052ed292bd0794ae0e34b45.tar.zst
freebsd-ports-c6bcad2436d925c98052ed292bd0794ae0e34b45.zip
(1) Add new variable, XFREE86_VERSION, to specify which version of
XFree86 (3 or 4) to depend to when USE_XLIB is set. XFREE86_VERSION defaults to 3 for now, but adventurous users can override it in /etc/make.conf. When XFREE86_VERSION=3, USE_XLIB will add a dependency to x11/XFree86; when it is set to 4, the dependency will be to x11/XFree86-4-libraries. When XFREE86_VERSION=4, the PKG_IGNORE_DEPENDS and ALWAYS_BUILD_DEPENDS hacks to avoid messing with XFree86 are turned off. Since XFree86 version 4 includes some software that used to be separate ports, when XFREE86_VERSION=3 the following variables are provided: USE_DGS LIB_DEPENDS on x11/dgs USE_FREETYPE LIB_DEPENDS on print/freetype USE_MESA LIB_DEPENDS on graphics/Mesa3 USE_XPM LIB_DEPENDS on graphics/xpm When XFREE86_VERSION=4, these variables have no effect. The LIB_DEPENDS in the tree for the above four ports have all been converted to the USE_* counterparts. For your information, this is the count of the number of ports: USE_DGS 0 USE_FREETYPE 16 USE_MESA 36 USE_XPM 236 There is a new variable, XAWVER, which is set to 6 when XFREE86_VERSION=3 and 7 when XFREE86_VERSION=4. This is also passed to PLIST_SUB so ports that build Xaw based shared libraries can use this variable to substitute the shlib version number. There is also a provision of using a separate mtree file for XFREE86_VERSION=4, but that part is not enabled yet. Reviewed by: the ports list Tested by: make index (XFREE86_VERSION=3 only) (2) Add hebrew to list of valid categories. Submitted by: nbm
Notes
Notes: svn path=/head/; revision=31272
Diffstat (limited to 'devel')
-rw-r--r--devel/ddd/Makefile3
-rw-r--r--devel/sdl-devel/Makefile6
-rw-r--r--devel/sdl12/Makefile6
-rw-r--r--devel/swarm/Makefile2
4 files changed, 6 insertions, 11 deletions
diff --git a/devel/ddd/Makefile b/devel/ddd/Makefile
index 46591c0157e8..e500c3b9bb05 100644
--- a/devel/ddd/Makefile
+++ b/devel/ddd/Makefile
@@ -14,13 +14,12 @@ MASTER_SITE_SUBDIR= ddd
MAINTAINER= obrien@FreeBSD.org
-LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm
-
GNU_CONFIGURE= yes
CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-motif-libraries="${LIBXMDIR}" \
--with-readline-libraries=/usr/lib
USE_GMAKE= yes
+USE_XPM= yes
REQUIRES_MOTIF= yes
MAN1= ddd.1
diff --git a/devel/sdl-devel/Makefile b/devel/sdl-devel/Makefile
index 1005819d5cae..b063dbdff9b3 100644
--- a/devel/sdl-devel/Makefile
+++ b/devel/sdl-devel/Makefile
@@ -15,8 +15,7 @@ DISTNAME= SDL-${PORTVERSION}
MAINTAINER= sobomax@FreeBSD.org
LIB_DEPENDS= esd.2:${PORTSDIR}/audio/esound \
- aa.1:${PORTSDIR}/graphics/aalib \
- ${GL_DEPENDS}
+ aa.1:${PORTSDIR}/graphics/aalib
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
USE_GMAKE= yes
@@ -31,10 +30,9 @@ CONFIGURE_ARGS= --enable-video-aalib
CFLAGS+= -D_THREAD_SAFE
.if defined(WITHOUT_GL)
-GL_DEPENDS=
CONFIGURE_ARGS+= --disable-video-opengl
.else
-GL_DEPENDS= GL.14:${PORTSDIR}/graphics/Mesa3
+USE_MESA= yes
CONFIGURE_ARGS+= --enable-video-opengl
.endif
diff --git a/devel/sdl12/Makefile b/devel/sdl12/Makefile
index 1005819d5cae..b063dbdff9b3 100644
--- a/devel/sdl12/Makefile
+++ b/devel/sdl12/Makefile
@@ -15,8 +15,7 @@ DISTNAME= SDL-${PORTVERSION}
MAINTAINER= sobomax@FreeBSD.org
LIB_DEPENDS= esd.2:${PORTSDIR}/audio/esound \
- aa.1:${PORTSDIR}/graphics/aalib \
- ${GL_DEPENDS}
+ aa.1:${PORTSDIR}/graphics/aalib
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
USE_GMAKE= yes
@@ -31,10 +30,9 @@ CONFIGURE_ARGS= --enable-video-aalib
CFLAGS+= -D_THREAD_SAFE
.if defined(WITHOUT_GL)
-GL_DEPENDS=
CONFIGURE_ARGS+= --disable-video-opengl
.else
-GL_DEPENDS= GL.14:${PORTSDIR}/graphics/Mesa3
+USE_MESA= yes
CONFIGURE_ARGS+= --enable-video-opengl
.endif
diff --git a/devel/swarm/Makefile b/devel/swarm/Makefile
index b24291ddcd15..9c2376af2e1d 100644
--- a/devel/swarm/Makefile
+++ b/devel/swarm/Makefile
@@ -14,10 +14,10 @@ MAINTAINER= horance@freedom.ie.cycu.edu.tw
LIB_DEPENDS= ffi.2:${PORTSDIR}/devel/libffi \
png.4:${PORTSDIR}/graphics/png \
- Xpm.4:${PORTSDIR}/graphics/xpm \
BLT24.2:${PORTSDIR}/x11-toolkits/blt
USE_GMAKE= yes
+USE_XPM= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --with-defaultdir=${PREFIX} \