aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2009-02-16 07:27:36 +0800
committerbeech <beech@FreeBSD.org>2009-02-16 07:27:36 +0800
commit5ea28978d56f93996c463b033d4446109600192f (patch)
tree8fa8cff9845c186fef3199aa850e9967ec1c901b /dns
parent9e38c9599eb64bd7662f82de9da2b7bc3bbf6abd (diff)
downloadfreebsd-ports-5ea28978d56f93996c463b033d4446109600192f.tar.gz
freebsd-ports-5ea28978d56f93996c463b033d4446109600192f.tar.zst
freebsd-ports-5ea28978d56f93996c463b033d4446109600192f.zip
- Update to 2.1.2
- Add selection for mysql or pgsql backend - Pass maintainership to submitter PR: ports/131035 Submitted by: Edmondas Girkantas <eg@fbsd.lt> Approved by: maintainer timeout (no activity since 2005)
Diffstat (limited to 'dns')
-rw-r--r--dns/poweradmin/Makefile45
-rw-r--r--dns/poweradmin/distinfo6
-rw-r--r--dns/poweradmin/files/pkg-message.in2
-rw-r--r--dns/poweradmin/pkg-descr4
-rw-r--r--dns/poweradmin/pkg-plist43
5 files changed, 67 insertions, 33 deletions
diff --git a/dns/poweradmin/Makefile b/dns/poweradmin/Makefile
index 9ed9ac811d77..70dbc57bddbc 100644
--- a/dns/poweradmin/Makefile
+++ b/dns/poweradmin/Makefile
@@ -1,33 +1,46 @@
# New ports collection makefile for: poweradmin
-# Date created: 19 January 2005
+# Date created: 19 January 2005
# Whom: geo
#
# $FreeBSD$
#
-PORTNAME= poweradmin
-PORTVERSION= 1.2.7
-CATEGORIES= dns www
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= poweradmin
+PORTNAME= poweradmin
+PORTVERSION= 2.1.2
+CATEGORIES= dns www
+MASTER_SITES= https://www.poweradmin.org/download/
+EXTRACT_SUFX= .tgz
-MAINTAINER= grivat@sicfa.net
-COMMENT= A set of PHP-scripts to manage PowerDNS over the web
+MAINTAINER= eg@fbsd.lt
+COMMENT= A set of PHP-scripts to manage PowerDNS over the web
-RUN_DEPENDS= ${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB
-
-USE_PHP= mysql
+USE_PHP= gettext
WANT_PHP_WEB= yes
NO_BUILD= yes
+PEARDIR= ${PREFIX}/share/pear
+
+OPTIONS= POSTGRESQL "Use PostgreSQL database instead of MySQL" off
+
SUB_FILES= pkg-message
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_POSTGRESQL)
+USE_PHP+= pgsql
+RUN_DEPENDS+= ${PEARDIR}/MDB2/Driver/pgsql.php:${PORTSDIR}/databases/pear-MDB2_Driver_pgsql
+.else
+USE_PHP+= mysql
+RUN_DEPENDS+= ${PEARDIR}/MDB2/Driver/mysql.php:${PORTSDIR}/databases/pear-MDB2_Driver_mysql
+.endif
+
+post-extract:
+ @cd ${WRKSRC} && ${RM} -rf "install"
+
do-install:
- ${MKDIR} ${WWWDIR}
- cd ${WRKSRC}; ${FIND} . \
- | ${CPIO} -pdm -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
- ${MV} ${WWWDIR}/inc/config-block.inc.php ${WWWDIR}/inc/config.inc.php.sample
+ @${CP} -r ${WRKSRC} ${PREFIX}/www/${PORTNAME}
+ ${CP} ${WWWDIR}/inc/config-me.inc.php ${WWWDIR}/inc/config.inc.php
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/dns/poweradmin/distinfo b/dns/poweradmin/distinfo
index af83937d39ed..2d7dfd83371c 100644
--- a/dns/poweradmin/distinfo
+++ b/dns/poweradmin/distinfo
@@ -1,3 +1,3 @@
-MD5 (poweradmin-1.2.7.tar.gz) = 0e639b7a245b7ccda0af4b50221d2cea
-SHA256 (poweradmin-1.2.7.tar.gz) = a7869b187155a5b07d3ca656a52e17eca300b6fa607aaadd74617e7a4b14adfd
-SIZE (poweradmin-1.2.7.tar.gz) = 61531
+MD5 (poweradmin-2.1.2.tgz) = cf83b89c6931160684de52a0b3ea3678
+SHA256 (poweradmin-2.1.2.tgz) = 2e90c05247d416fce704016126abce37f10a6817723008b220ac9c003d194cb8
+SIZE (poweradmin-2.1.2.tgz) = 94314
diff --git a/dns/poweradmin/files/pkg-message.in b/dns/poweradmin/files/pkg-message.in
index 6136b8b3d63e..d08b5796c970 100644
--- a/dns/poweradmin/files/pkg-message.in
+++ b/dns/poweradmin/files/pkg-message.in
@@ -1,5 +1,5 @@
*******************************************************************************
-A sample config file is located in %%WWWDIR%%/inc/config.inc.php.sample
+A sample config file is located in %%WWWDIR%%/inc/config.inc.php
You now need to add an alias to apache's httpd.conf pointing to
%%WWWDIR%% in order to access PowerAdmin from your web brower,
or create a VirtualHost with DocumentRoot set to that directory.
diff --git a/dns/poweradmin/pkg-descr b/dns/poweradmin/pkg-descr
index 41822d32b593..5c61925f0214 100644
--- a/dns/poweradmin/pkg-descr
+++ b/dns/poweradmin/pkg-descr
@@ -2,5 +2,5 @@ This project is a web-based front-end for the PowerDNS DNS server.
WWW: http://www.poweradmin.org/
-- Geoffroy RIVAT
-grivat@sicfa.net
+- Edmondas Girkantas
+eg@fbsd.lt
diff --git a/dns/poweradmin/pkg-plist b/dns/poweradmin/pkg-plist
index 99f25d0a3878..ca3e151d0b5a 100644
--- a/dns/poweradmin/pkg-plist
+++ b/dns/poweradmin/pkg-plist
@@ -1,38 +1,59 @@
+www/poweradmin/add_perm_templ.php
www/poweradmin/add_record.php
+www/poweradmin/add_supermaster.php
+www/poweradmin/add_user.php
+www/poweradmin/add_zone_master.php
+www/poweradmin/add_zone_slave.php
+www/poweradmin/change_password.php
www/poweradmin/delete_domain.php
+www/poweradmin/delete_perm_templ.php
www/poweradmin/delete_record.php
+www/poweradmin/delete_supermaster.php
www/poweradmin/delete_user.php
-www/poweradmin/docs/ChangeLog
+www/poweradmin/docs/CHANGELOG
+www/poweradmin/docs/LICENSE
www/poweradmin/docs/README
-www/poweradmin/docs/README-Sequence
-www/poweradmin/docs/REDHAT-README
-www/poweradmin/docs/TODO
+www/poweradmin/docs/i18n-template-db.pot
+www/poweradmin/docs/i18n-template-php.pot
+www/poweradmin/docs/poweradmin-mysql-db-structure.sql
+www/poweradmin/docs/poweradmin-pgsql-db-structure.sql
www/poweradmin/edit.php
+www/poweradmin/edit_perm_templ.php
www/poweradmin/edit_record.php
www/poweradmin/edit_user.php
+www/poweradmin/images/arrow.png
www/poweradmin/images/background.jpg
www/poweradmin/images/delete.gif
www/poweradmin/images/edit.gif
www/poweradmin/inc/auth.inc.php
-www/poweradmin/inc/config.inc.php.sample
-www/poweradmin/inc/dal.inc.php
+www/poweradmin/inc/config.inc.php
+www/poweradmin/inc/config-me.inc.php
www/poweradmin/inc/database.inc.php
www/poweradmin/inc/dns.inc.php
www/poweradmin/inc/error.inc.php
www/poweradmin/inc/footer.inc.php
www/poweradmin/inc/header.inc.php
+www/poweradmin/inc/i18n.inc.php
www/poweradmin/inc/record.inc.php
www/poweradmin/inc/toolkit.inc.php
www/poweradmin/inc/users.inc.php
www/poweradmin/index.php
-www/poweradmin/install.php
-www/poweradmin/migrator.php-pa
+www/poweradmin/list_perm_templ.php
+www/poweradmin/list_supermasters.php
+www/poweradmin/list_zones.php
+www/poweradmin/locale/en_EN/LC_MESSAGES/en.po
+www/poweradmin/locale/nl_NL/LC_MESSAGES/messages.mo
+www/poweradmin/locale/nl_NL/LC_MESSAGES/nl.po
+www/poweradmin/robots.txt
www/poweradmin/search.php
-www/poweradmin/seq_update.php
-www/poweradmin/style/style.css.php
-www/poweradmin/test_setup.php
+www/poweradmin/style/example.inc.php
www/poweradmin/users.php
@dirrm www/poweradmin/style
+@dirrm www/poweradmin/locale/nl_NL/LC_MESSAGES
+@dirrm www/poweradmin/locale/nl_NL
+@dirrm www/poweradmin/locale/en_EN/LC_MESSAGES
+@dirrm www/poweradmin/locale/en_EN
+@dirrm www/poweradmin/locale
@dirrm www/poweradmin/inc
@dirrm www/poweradmin/images
@dirrm www/poweradmin/docs