aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2006-07-14 15:00:44 +0800
committerroam <roam@FreeBSD.org>2006-07-14 15:00:44 +0800
commit80ffa45db0ad45b8e9c7d747bf3ab99681ab2abf (patch)
treeaaf7a36be237b7f2ef29508e0ecb19e63e71ae5a /dns
parent29a566da76d89ebeabb1fe6e4af8fd5e77ced707 (diff)
downloadfreebsd-ports-80ffa45db0ad45b8e9c7d747bf3ab99681ab2abf.tar.gz
freebsd-ports-80ffa45db0ad45b8e9c7d747bf3ab99681ab2abf.tar.zst
freebsd-ports-80ffa45db0ad45b8e9c7d747bf3ab99681ab2abf.zip
Add c-ares 1.3.1, Daniel Stenberg's adopted version of the ares library
for asynchronous DNS resolving. It was repo-copied from the dns/ares port. WWW: http://daniel.haxx.se/projects/c-ares/ Author: Daniel Stenberg <daniel@haxx.se>
Diffstat (limited to 'dns')
-rw-r--r--dns/c-ares/Makefile31
-rw-r--r--dns/c-ares/distinfo6
-rw-r--r--dns/c-ares/pkg-descr6
-rw-r--r--dns/c-ares/pkg-plist4
4 files changed, 30 insertions, 17 deletions
diff --git a/dns/c-ares/Makefile b/dns/c-ares/Makefile
index a315d64c9890..7cb87883f1ed 100644
--- a/dns/c-ares/Makefile
+++ b/dns/c-ares/Makefile
@@ -5,22 +5,33 @@
# $FreeBSD$
#
-PORTNAME= ares
-PORTVERSION= 1.1.1
+PORTNAME= c-ares
+PORTVERSION= 1.3.1
CATEGORIES= dns
-MASTER_SITES= http://curl.haxx.se/dev/ \
- ftp://athena-dist.mit.edu/pub/ATHENA/ares/
+MASTER_SITES= http://daniel.haxx.se/projects/c-ares/
MAINTAINER= roam@FreeBSD.org
COMMENT= An asynchronous DNS resolver library
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --mandir=${PREFIX}/man
-MAN3= ares_destroy.3 ares_expand_name.3 ares_fds.3 \
- ares_free_errmem.3 ares_free_hostent.3 ares_free_string.3 \
- ares_gethostbyaddr.3 ares_gethostbyname.3 ares_init.3 \
- ares_init_options.3 ares_mkquery.3 ares_parse_a_reply.3 \
- ares_parse_ptr_reply.3 ares_process.3 ares_query.3 \
- ares_search.3 ares_send.3 ares_strerror.3 ares_timeout.3
+MAN3= ares_cancel.3 \
+ ares_destroy.3 \
+ ares_expand_name.3 ares_expand_string.3 \
+ ares_fds.3 \
+ ares_free_hostent.3 ares_free_string.3 \
+ ares_gethostbyaddr.3 ares_gethostbyname.3 ares_getnameinfo.3 \
+ ares_init.3 ares_init_options.3 \
+ ares_mkquery.3 \
+ ares_parse_a_reply.3 ares_parse_aaaa_reply.3 ares_parse_ptr_reply.3 \
+ ares_process.3 \
+ ares_query.3 \
+ ares_search.3 \
+ ares_send.3 \
+ ares_strerror.3 \
+ ares_timeout.3 \
+ ares_version.3
.include <bsd.port.mk>
diff --git a/dns/c-ares/distinfo b/dns/c-ares/distinfo
index 57a89c207ce5..cb15c118c7ed 100644
--- a/dns/c-ares/distinfo
+++ b/dns/c-ares/distinfo
@@ -1,3 +1,3 @@
-MD5 (ares-1.1.1.tar.gz) = 4554140cd940da01f25c4b3b20f7955c
-SHA256 (ares-1.1.1.tar.gz) = 90f86b3984e5252b263645a43b01d9a440c15cc7f6d23d3d11426b76a172a75e
-SIZE (ares-1.1.1.tar.gz) = 65463
+MD5 (c-ares-1.3.1.tar.gz) = e79413ca62df8f124bb0dbf32119310d
+SHA256 (c-ares-1.3.1.tar.gz) = e5ac3b76534a6e0302ce9a883ee5021d84394d3e037bcef307301c85621b8580
+SIZE (c-ares-1.3.1.tar.gz) = 318859
diff --git a/dns/c-ares/pkg-descr b/dns/c-ares/pkg-descr
index 0673fa9bcb35..3c3ec44522bc 100644
--- a/dns/c-ares/pkg-descr
+++ b/dns/c-ares/pkg-descr
@@ -1,8 +1,8 @@
-This is ares, an asynchronous resolver library. It is intended for
+This is c-ares, an asynchronous resolver library. It is intended for
applications which need to perform DNS queries without blocking, or
need to perform multiple DNS queries in parallel. The primary
examples of such applications are servers which communicate with
multiple clients and programs with graphical user interfaces.
-FTP: ftp://athena-dist.mit.edu/pub/ATHENA/ares/
-Author: Greg Hudson <ghudson@mit.edu>
+WWW: http://daniel.haxx.se/projects/c-ares/
+Author: Daniel Stenberg <daniel@haxx.se>, Greg Hudson <ghudson@mit.edu>
diff --git a/dns/c-ares/pkg-plist b/dns/c-ares/pkg-plist
index 24ee8158de71..4f37c6b212a1 100644
--- a/dns/c-ares/pkg-plist
+++ b/dns/c-ares/pkg-plist
@@ -1,2 +1,4 @@
include/ares.h
-lib/libares.a
+include/ares_version.h
+lib/libcares.a
+lib/libcares.la