aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/xmame
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2001-04-14 20:16:58 +0800
committerJimmy Olgeni <olgeni@FreeBSD.org>2001-04-14 20:16:58 +0800
commitdb9ca188e201493bab4b36d6c8f7b676f05fb042 (patch)
tree0fa0b097d1ee225fce3a73551e58f4785d9e40c3 /emulators/xmame
parent141470537e26c2135689f2b19d363d214e1e918c (diff)
downloadfreebsd-ports-db9ca188e201493bab4b36d6c8f7b676f05fb042.tar.gz
freebsd-ports-db9ca188e201493bab4b36d6c8f7b676f05fb042.tar.zst
freebsd-ports-db9ca188e201493bab4b36d6c8f7b676f05fb042.zip
Update xmame, xmess and xpinmame to 0.37b13.2
From the PR: - Remove temporary GL patch (xmame/files/patch-ae) - Remove glue for xmess-0.37b12.1 from xmame makefile - Move patches to post-patch target And some more patches (also from maintainer): - Fixed distfile information (tarball changed) - Removed a file from pkg-plist. Notable updates in xmame-0.37b13.2: - Fixed an unmatched parenthesis error in src/drawgfx.c that was affecting non-Intel platforms. - Fixed a bug in mess/cpu/apexc/apexcdsm.c that was causing xmess linking to fail. - Updated GLMame to v0.85. (Sven Goethel) - Vector games now work with the SDL target. PR: 26474 Submitted by: Stijn Hoop <stijn@win.tue.nl>
Notes
Notes: svn path=/head/; revision=41372
Diffstat (limited to 'emulators/xmame')
-rw-r--r--emulators/xmame/Makefile43
-rw-r--r--emulators/xmame/distinfo7
-rw-r--r--emulators/xmame/files/patch-ac14
-rw-r--r--emulators/xmame/files/patch-ae138
-rw-r--r--emulators/xmame/pkg-plist42
5 files changed, 72 insertions, 172 deletions
diff --git a/emulators/xmame/Makefile b/emulators/xmame/Makefile
index 743a3c24df80..bd6d6e58070a 100644
--- a/emulators/xmame/Makefile
+++ b/emulators/xmame/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME?= xmame
-PORTVERSION?= 0.37b13.1
+PORTVERSION?= 0.37b13.2
CATEGORIES= emulators
MASTER_SITES= http://x.mame.net/download/ \
ftp://ftp.kaupp.cx/pub/xmame/ \
@@ -17,19 +17,13 @@ MASTER_SITES= http://x.mame.net/download/ \
DISTNAME= xmame-${XMAMEVERSION:S/p/pre/}
DIST_SUBDIR= xmame
XMAMEVERSION?= ${PORTVERSION}
-.if ${XMAMEVERSION} == "0.37b12.1"
-EXTRACT_SUFX= .tgz
-.else
USE_BZIP2= yes
-EXTRACT_SUFX= .tar.bz2
-.endif
MAINTAINER?= stijn@win.tue.nl
USE_XPM= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-MAKEFILE= makefile.unix
MAN6= x${MAMEMESS}.6
@@ -57,6 +51,7 @@ SPOOLGAMES?= /var/games
# Docs list
GENERALDOCS= changes.unix \
liesmich.unix \
+ credits.txt \
multiplayer-readme.txt \
xmame-doc-1.html \
xmame-doc-2.html \
@@ -71,11 +66,9 @@ GENERALDOCS= changes.unix \
xmame-doc.sgml \
xmame-doc.txt
XMAMEDOCS= changes.mame \
- changes.opengl \
gamelist.mame \
readme.mame
XMESSDOCS= changes.mess \
- credits.txt \
gamelist.mess \
readme.mess \
messold.txt \
@@ -86,6 +79,7 @@ PINMAMEDOCS= pinmame/simulation.txt \
pinmame/gamelist.txt \
pinmame/keys.txt \
pinmame/sounds.dat
+GLDOCS= changes.opengl
.if ${MAMEMESS} == "mame"
ALLDOCS= ${GENERALDOCS} ${XMAMEDOCS}
.else
@@ -99,7 +93,7 @@ ALLDOCS= ${GENERALDOCS} ${PINMAMEDOCS}
# CPS-2 patches - this enables extra games in MAME.
.if ${MAMEMESS} == "mame"
.if defined(WITH_CPS2) && ${WITH_CPS2} == "yes"
-CPS2VERSION= 20010330
+CPS2VERSION= 20010409
PATCH_SITES+= http://www.win.tue.nl/~stijn/xmame/
PATCHFILES+= ${DISTNAME}-cps2-${CPS2VERSION}.patch.gz
@@ -169,6 +163,7 @@ CFLAGS+= ${PTHREAD_CFLAGS}
USE_MESA= yes
DISPLAY_METHOD= xgl
PLIST_SUB+= OPENGL=""
+ALL_DOCS+= ${GLDOCS}
.else
PLIST_SUB+= OPENGL="@comment "
.if !defined(WITH_SDL) || ${WITH_SDL} != "no"
@@ -188,15 +183,23 @@ DISPLAY_METHOD= x11
.endif
.endif
+# Some simple patches that don't warrant a separate patch
+post-patch:
+ ${PERL} -pi -e 's@SDL/@SDL11/@' ${WRKSRC}/src/unix/video-drivers/SDL.c
+ ${PERL} -pi -e 's@png.h@../../png.h@' \
+ ${WRKSRC}/src/unix/video-drivers/glexport.c
+ ${PERL} -pi -e 's@malloc.h@stdlib.h@' \
+ ${WRKSRC}/src/unix/video-drivers/gljpg.c
+
# The large number of sed regexes here is intended to make this port a whole
# lot easier to maintain - please don't convert them into a patch.
do-configure:
- @${CP} ${WRKSRC}/makefile.unix ${WRKSRC}/makefile.unix.sed
${SED} -e "s@= gcc@?= ${CC}@g" \
-e "s@= -O2 -Wall@?= ${CFLAGS}@g" \
-e "s@= cp@?= ${INSTALL} ${COPY}@g" \
-e "s@lib/x\$$(TARGET)@share/x\$$(TARGET)@g" \
-e "s@/usr/X11R6@${X11BASE}@g" \
+ -e "s@-g bin@-g wheel@g" \
-e "s@ARCH = linux@ARCH = freebsd@g" \
-e "s@# X11_DGA@X11_DGA@g" \
-e "s@# JOY_USB@JOY_USB@g" \
@@ -204,20 +207,13 @@ do-configure:
-e "s@= mame@= ${MAMEMESS}@g" \
-e "s@# X86_ASM@${ASM_COMMENT}X86_ASM@g" \
-e "s@GLLIBS=.-ldl@GLLIBS= ${PTHREAD_LIBS}@g" \
- ${WRKSRC}/makefile.unix.sed > ${WRKSRC}/makefile.unix
- ${PERL} -pi -e 's@SDL/@SDL11/@' ${WRKSRC}/src/unix/video-drivers/SDL.c
-.if ${XMAMEVERSION} != "0.37b12.1"
- ${PERL} -pi -e 's@png.h@../../png.h@' \
- ${WRKSRC}/src/unix/video-drivers/glexport.c
- ${PERL} -pi -e 's@malloc.h@stdlib.h@' \
- ${WRKSRC}/src/unix/video-drivers/gljpg.c
-.endif
+ ${WRKSRC}/makefile.unix > ${WRKSRC}/Makefile
post-build:
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} SDL_VIDEODRIVER=aalib \
- ${GMAKE} -f ${MAKEFILE} doc/x${MAMEMESS}.6
+ ${GMAKE} doc/x${MAMEMESS}.6
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} SDL_VIDEODRIVER=aalib \
- ${GMAKE} -f ${MAKEFILE} doc/x${MAMEMESS}rc.dist
+ ${GMAKE} doc/x${MAMEMESS}rc.dist
@${CP} ${WRKSRC}/doc/x${MAMEMESS}rc.dist \
${WRKSRC}/doc/x${MAMEMESS}rc.dist.sed
${SED} -e "s@^spooldir.*\$$@spooldir ${SPOOLGAMES}/x${MAMEMESS}@" \
@@ -242,6 +238,11 @@ post-install:
.for file in ${ALLDOCS}
${INSTALL_DATA} ${WRKSRC}/doc/${file} ${PREFIX}/share/doc/x${MAMEMESS}
.endfor
+.if ${MAMEMESS} == "mess"
+ ${MKDIR} ${PREFIX}/share/doc/x${MAMEMESS}/sysinfo
+ ${INSTALL_DATA} ${WRKSRC}/doc/sysinfo/* \
+ ${PREFIX}/share/doc/x${MAMEMESS}/sysinfo
+.endif
.endif
.if ${MAMEMESS} == "mame" && defined(WITH_DATFILES) && ${WITH_DATFILES} == "yes"
${INSTALL_DATA} ${WRKDIR}/hiscore.dat ${PREFIX}/share/xmame
diff --git a/emulators/xmame/distinfo b/emulators/xmame/distinfo
index 00b6786339ce..f3a35f6bede5 100644
--- a/emulators/xmame/distinfo
+++ b/emulators/xmame/distinfo
@@ -1,7 +1,6 @@
-MD5 (xmame/xmame-0.37b12.1.tgz) = 8f08ef945ec49872397862d99676690f
-MD5 (xmame/xmame-0.37b13.1.tar.bz2) = ab81777720d7b1e724ff8d1d432325b1
+MD5 (xmame/xmame-0.37b13.2.tar.bz2) = 70ec7ae3fba3110a6d85a7f5bfdb84f1
MD5 (xmame/cheat.zip) = dc380436c04780950cee07d3e31bfb0b
MD5 (xmame/history.zip) = 69da5c33e6a78092c6cd75cbeb737c6a
MD5 (xmame/hsdat7.zip) = 9e4a7e36448895f13128a675327e34e4
-MD5 (xmame/xmame-0.37b13.1-cps2-20010330.patch.gz) = bf1d53ea84a4905d8377a187d3478883
-MD5 (xmame/xmame-0.37b13.1-pinmame-0.99b1.patch.gz) = 06526474f4bd5afa0874237ffe653d34
+MD5 (xmame/xmame-0.37b13.2-cps2-20010409.patch.gz) = a6c5d66076d2fa54a3628624ff3ad5ad
+MD5 (xmame/xmame-0.37b13.2-pinmame-0.99b1.patch.gz) = 06526474f4bd5afa0874237ffe653d34
diff --git a/emulators/xmame/files/patch-ac b/emulators/xmame/files/patch-ac
index d8f0f0590141..47ee03e48f7f 100644
--- a/emulators/xmame/files/patch-ac
+++ b/emulators/xmame/files/patch-ac
@@ -1,11 +1,11 @@
---- src/unix/unix.mak.orig Sat Mar 24 02:33:38 2001
-+++ src/unix/unix.mak Mon Apr 2 12:32:36 2001
+--- src/unix/unix.mak.orig Mon Apr 9 03:54:42 2001
++++ src/unix/unix.mak Tue Apr 10 10:52:06 2001
@@ -46,18 +46,18 @@
LIBS.x11 = $(X11LIB) $(JOY_X11_LIBS) -lX11 -lXext
LIBS.svgalib = $(X11LIB) -lvga -lvgagl
LIBS.ggi = $(X11LIB) -lggi
-LIBS.xgl = $(X11LIB) $(JOY_X11_LIBS) -lX11 -lXext $(GLLIBS) -ljpeg
-+LIBS.xgl = $(X11LIB) $(JOY_X11_LIBS) -lX11 -lXext $(GLLIBS) -L/usr/local/lib -ljpeg $(PTHREAD_LIBS)
++LIBS.xgl = $(X11LIB) $(JOY_X11_LIBS) -lX11 -lXext $(GLLIBS) -L/usr/local/lib -ljpeg
LIBS.xfx = $(X11LIB) $(JOY_X11_LIBS) -lX11 -lXext -lglide2x
LIBS.svgafx = $(X11LIB) -lvga -lvgagl -lglide2x
LIBS.openstep = -framework AppKit
@@ -14,8 +14,8 @@
LIBS.photon2 = -L/usr/lib -lph -lphrender
CFLAGS.x11 = $(X11INC) $(JOY_X11_CFLAGS)
--CFLAGS.xgl = $(X11INC) $(JOY_X11_CFLAGS)
-+CFLAGS.xgl = $(X11INC) $(JOY_X11_CFLAGS) -I/usr/local/include $(PTHREAD_CFLAGS)
+-CFLAGS.xgl = $(X11INC) $(JOY_X11_CFLAGS) $(GLCFLAGS)
++CFLAGS.xgl = -DGLU_VERSION_1_2 $(X11INC) $(JOY_X11_CFLAGS) $(GLCFLAGS) -I/usr/local/include $(PTHREAD_CFLAGS)
CFLAGS.xfx = $(X11INC) $(JOY_X11_CFLAGS) -I/usr/include/glide
CFLAGS.svgafx = -I/usr/include/glide
-CFLAGS.SDL = -D_REENTRANT
@@ -23,7 +23,7 @@
CFLAGS.photon2 =
INST.x11 = doinstall
-@@ -317,7 +317,7 @@
+@@ -322,7 +322,7 @@
doc/x$(TARGET)rc.dist: all src/unix/xmamerc-keybinding-notes.txt
./x$(TARGET).$(DISPLAY_METHOD) -noloadconfig -showconfig | \
@@ -32,7 +32,7 @@
cat src/unix/xmamerc-keybinding-notes.txt >> doc/x$(TARGET)rc.dist
doc/gamelist.$(TARGET): all
-@@ -326,7 +326,8 @@
+@@ -331,7 +331,8 @@
doc/x$(TARGET).6: all src/unix/xmame.6-1 src/unix/xmame.6-3
cat src/unix/xmame.6-1 > doc/x$(TARGET).6
diff --git a/emulators/xmame/files/patch-ae b/emulators/xmame/files/patch-ae
deleted file mode 100644
index c030ba962efb..000000000000
--- a/emulators/xmame/files/patch-ae
+++ /dev/null
@@ -1,138 +0,0 @@
---- src/unix/video-drivers/glxtool.h.orig Sat Mar 24 02:33:38 2001
-+++ src/unix/video-drivers/glxtool.h Mon Apr 2 21:40:48 2001
-@@ -28,6 +28,8 @@
- int accumBlueBits;
- int accumAlphaBits;
-
-+ /* internal use only */
-+ int gl_supported;
- long nativeVisualID;
- } GLCapabilities;
-
---- src/unix/video-drivers/xgl.c.orig Mon Apr 2 13:33:10 2001
-+++ src/unix/video-drivers/xgl.c Mon Apr 2 21:42:05 2001
-@@ -63,14 +63,14 @@
- GLXContext glContext=NULL;
-
- const GLCapabilities glCapsDef = { BUFFER_DOUBLE, COLOR_RGBA, STEREO_OFF,
-- 1, 0, 1, 1, 1, 1, 0, 0, 0, 0,
-+ 1, 0, 1, 1, 1, 1, 0, 0, 0, 0, 1,
- -1
- };
-
- GLCapabilities glCaps;
-
- static const char * xgl_version_str =
-- "\nGLmame v0.83, by Sven Goethel, http://www.jausoft.com, sgoethel@jausoft.com,\nbased upon GLmame v0.6 driver for xmame, written by Mike Oliphant\n\n";
-+ "\nGLmame v0.85, by Sven Goethel, http://www.jausoft.com, sgoethel@jausoft.com,\nbased upon GLmame v0.6 driver for xmame, written by Mike Oliphant\n\n";
-
- struct rc_option display_opts[] = {
- /* name, shortname, type, dest, deflt, min, max, func, help */
-@@ -237,6 +237,7 @@
-
- glCaps.alphaBits=(alphablending>0)?1:0;
- glCaps.buffer =(doublebuffer>0)?BUFFER_DOUBLE:BUFFER_SINGLE;
-+ glCaps.gl_supported = 1;
-
- window = RootWindow(display,DefaultScreen( display ));
- vgc = findVisualGlX( display, window,
---- src/unix/video-drivers/glxtool.c.orig Fri Mar 23 17:33:38 2001
-+++ src/unix/video-drivers/glxtool.c Mon Apr 2 22:31:23 2001
-@@ -68,6 +68,7 @@
- GLCapabilities *glCaps )
- {
- int i=0;
-+ visualAttribList[i++] = GLX_USE_GL; /* paranoia .. */
- visualAttribList[i++] = GLX_RED_SIZE;
- visualAttribList[i++] = 1;
- visualAttribList[i++] = GLX_GREEN_SIZE;
-@@ -134,13 +135,18 @@
- int gc_ret = 0;
- int ownwin = 0;
-
-+ GLCapabilities _glCaps;
-+
- /**
- * The Visual seeked by Function: findVisualIdByFeature !
- */
- XVisualInfo * visualList=NULL; /* the visual list, to be XFree-ed */
-
-+ /* paranoia .. */
-+ glCaps->gl_supported = 1;
-+
- /* backup ... */
-- GLCapabilities _glCaps = *glCaps;
-+ _glCaps = *glCaps;
-
- if(pOwnWin) ownwin=*pOwnWin;
-
-@@ -214,14 +220,14 @@
-
- if( offscreen && vgc.visual!=NULL)
- {
-- if(*pix!=0)
-+ if(pix!=NULL && *pix!=NULL)
- {
- XFreePixmap(display, *pix);
- }
-- if(vgc.visual !=NULL)
-+ if(pix!=NULL && vgc.visual !=NULL)
- *pix = XCreatePixmap( display, rootWin, width, height,
- vgc.visual->depth);
-- if(*pix!=0)
-+ if(pix!=NULL && *pix!=NULL)
- {
- *pWin = __glXCreateGLXPixmap( display, vgc.visual, *pix );
- if(*pWin==0)
-@@ -271,7 +277,7 @@
- fflush(stderr);
- }
-
-- if(*pix!=0)
-+ if(pix!=NULL && *pix!=NULL)
- {
- XFreePixmap(display, *pix);
- *pix=0;
-@@ -463,6 +469,16 @@
- int iValue2=0;
- int iValue3=0;
-
-+ memset(glCaps, 0, sizeof(GLCapabilities));
-+
-+ if(__glXGetConfig( disp, visual, GLX_USE_GL, &iValue)==0)
-+ {
-+ glCaps->gl_supported=(iValue==True)?1:0;
-+ } else {
-+ fprintf(stderr,"GLINFO: fetching GLX_USE_GL state failed\n");
-+ fflush(stderr);
-+ }
-+
- if(__glXGetConfig( disp, visual, GLX_DOUBLEBUFFER, &iValue)==0)
- {
- glCaps->buffer=iValue?BUFFER_DOUBLE:BUFFER_SINGLE;
-@@ -530,7 +546,7 @@
- fprintf(stderr,"GLINFO: fetching rgba AccumSize states failed\n");
- fflush(stderr);
- }
-- glCaps->nativeVisualID=(long)visual->visualid;
-+ glCaps->nativeVisualID=(long) (visual->visualid);
-
- return 1;
- }
-@@ -541,6 +557,8 @@
- GLCapabilities _glCaps;
- setGLCapabilities ( display, vi, &_glCaps);
-
-+ if(_glCaps.gl_supported != glCaps->gl_supported) return 0;
-+
- if(_glCaps.buffer<glCaps->buffer) return 0;
-
- if(_glCaps.color<glCaps->color) return 0;
-@@ -635,6 +653,7 @@
-
- void printGLCapabilities ( GLCapabilities *glCaps )
- {
-+ fprintf(stdout, "\t gl_supported: %d !\n", glCaps->gl_supported);
- fprintf(stdout, "\t doubleBuff: %d, ", (int)glCaps->buffer);
- fprintf(stdout, " rgba: %d, ", (int)glCaps->color);
- fprintf(stdout, " stereo: %d, ", (int)glCaps->stereo);
diff --git a/emulators/xmame/pkg-plist b/emulators/xmame/pkg-plist
index 47f495451305..364dacfefb0a 100644
--- a/emulators/xmame/pkg-plist
+++ b/emulators/xmame/pkg-plist
@@ -3,6 +3,7 @@ etc/%%MAMEMESS%%rc.sample
share/%%MAMEMESS%%/%%MAMEMESS%%rc
%%PORTDOCS%%share/doc/%%MAMEMESS%%/changes.unix
%%PORTDOCS%%share/doc/%%MAMEMESS%%/liesmich.unix
+%%PORTDOCS%%share/doc/%%MAMEMESS%%/credits.txt
%%PORTDOCS%%share/doc/%%MAMEMESS%%/multiplayer-readme.txt
%%PORTDOCS%%share/doc/%%MAMEMESS%%/xmame-doc-1.html
%%PORTDOCS%%share/doc/%%MAMEMESS%%/xmame-doc-2.html
@@ -20,21 +21,58 @@ share/%%MAMEMESS%%/%%MAMEMESS%%rc
%%MAMEONLY%%%%DATFILES%%share/xmame/history.dat
%%MAMEONLY%%%%DATFILES%%share/xmame/cheat.dat
%%MAMEONLY%%%%PORTDOCS%%share/doc/xmame/changes.mame
-%%MAMEONLY%%%%PORTDOCS%%share/doc/xmame/changes.opengl
%%MAMEONLY%%%%PORTDOCS%%share/doc/xmame/gamelist.mame
%%MAMEONLY%%%%PORTDOCS%%share/doc/xmame/readme.mame
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/credits.txt
%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/changes.mess
%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/gamelist.mess
%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/readme.mess
%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/messold.txt
%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/messroms.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/aim65.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/bondwell.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/c128.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/c65.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/comquest.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/dream.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/elf.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/europc.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/galaxy.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/hp48s.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/i8530286.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/ibm8530.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/ibmat.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/ibmpc.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/ibmpcjr.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/lynx.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/mk1.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/mk2.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/msx.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/nc.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/nc200.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/neat.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/pc1251.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/pc1350.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/pc1401.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/pc1500.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/pc1512.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/pc1640.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/pc200.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/pcw16.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/pong.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/ssystem3.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/studio2.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/svision.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/sym1.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/t1000hx.txt
+%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/vip.txt
+%%MESSONLY%%%%PORTDOCS%%@dirrm share/doc/xmess/sysinfo
%%PINMAMEONLY%%%%PORTDOCS%%share/doc/xpinmame/simulation.txt
%%PINMAMEONLY%%%%PORTDOCS%%share/doc/xpinmame/whatsnew.txt
%%PINMAMEONLY%%%%PORTDOCS%%share/doc/xpinmame/pinmame.txt
%%PINMAMEONLY%%%%PORTDOCS%%share/doc/xpinmame/gamelist.txt
%%PINMAMEONLY%%%%PORTDOCS%%share/doc/xpinmame/keys.txt
%%PINMAMEONLY%%%%PORTDOCS%%share/doc/xpinmame/sounds.dat
+%%OPENGL%%%%PORTDOCS%%share/doc/%%MAMEMESS%%/changes.opengl
%%PORTDOCS%%@dirrm share/doc/%%MAMEMESS%%
%%OPENGL%%share/%%MAMEMESS%%/cab/glmame/cabfront.jpg
%%OPENGL%%share/%%MAMEMESS%%/cab/glmame/cabtitle.jpg