aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-09-02 03:18:06 +0800
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-09-02 03:18:06 +0800
commit5b28125f0157b04b2888781472244629a2476afc (patch)
treea09f0340850c180550e5a89e45bf337233ef38ce /emulators
parent29a74a25d0b1e59ddfbf3a756f977297e0b51764 (diff)
downloadfreebsd-ports-5b28125f0157b04b2888781472244629a2476afc.tar.gz
freebsd-ports-5b28125f0157b04b2888781472244629a2476afc.tar.zst
freebsd-ports-5b28125f0157b04b2888781472244629a2476afc.zip
- simultaneous update of xmame and xmess since xmess is a slave
port of xmame o Update xmame to 0.54.1 o Update xmess to 0.37b15.2 o Add WITH_ESOUND knob for both ports PR: 30161 Submitted by: MAINTAINER
Notes
Notes: svn path=/head/; revision=47292
Diffstat (limited to 'emulators')
-rw-r--r--emulators/xmame/Makefile27
-rw-r--r--emulators/xmame/distinfo4
-rw-r--r--emulators/xmame/pkg-plist41
-rw-r--r--emulators/xmess/Makefile2
4 files changed, 23 insertions, 51 deletions
diff --git a/emulators/xmame/Makefile b/emulators/xmame/Makefile
index ef20b0fa990e..0d148bf6cbb8 100644
--- a/emulators/xmame/Makefile
+++ b/emulators/xmame/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME?= xmame
-PORTVERSION?= 0.53.1
+PORTVERSION?= 0.54.1
CATEGORIES= emulators
MASTER_SITES= http://x.mame.net/download/ \
ftp://ftp.kaupp.cx/pub/xmame/ \
@@ -69,9 +69,7 @@ XMAMEDOCS= changes.mame \
XMESSDOCS= changes.mess \
gamelist.mess \
readme.mess \
- messold.txt \
- messroms.txt \
- credits.txt
+ messroms.txt
PINMAMEDOCS= pinmame/simulation.txt \
pinmame/whatsnew.txt \
pinmame/pinmame.txt \
@@ -201,6 +199,19 @@ JOYUSBCOMMENT=\#\
JOYUSBCOMMENT=
.endif
+# Esound audio - handy for a GNOME environment
+.if defined(WITH_ESOUND) && ${WITH_ESOUND} == "yes"
+ESOUNDCOMMENT=
+USE_ESOUND= yes
+.else
+ESOUNDCOMMENT=\#\
+.if !defined(WITH_ESOUND)
+pre-everything::
+ @echo "===> If you want to build ${MAMEMESS:U} with support for ESound,"
+ @echo " use \"make WITH_ESOUND=yes\""
+.endif
+.endif
+
# Some simple patches that don't warrant a separate patch
post-patch:
${PERL} -pi -e 's@SDL/@SDL11/@' ${WRKSRC}/src/unix/video-drivers/SDL.c
@@ -224,6 +235,7 @@ do-configure:
-e "s@= x11@= ${DISPLAY_METHOD}@g" \
-e "s@= mame@= ${MAMEMESS}@g" \
-e "s@# X86_ASM@${ASM_COMMENT}X86_ASM@g" \
+ -e "s@# SOUND_ESOUND@${ESOUNDCOMMENT}SOUND_ESOUND@g" \
-e "s@GLLIBS=.-ldl@GLLIBS= ${PTHREAD_LIBS}@g" \
${WRKSRC}/makefile.unix > ${WRKSRC}/Makefile
@@ -256,11 +268,10 @@ post-install:
.for file in ${ALLDOCS}
${INSTALL_DATA} ${WRKSRC}/doc/${file} ${PREFIX}/share/doc/x${MAMEMESS}
.endfor
-.if ${MAMEMESS} == "mess"
- ${MKDIR} ${PREFIX}/share/doc/x${MAMEMESS}/sysinfo
- ${INSTALL_DATA} ${WRKSRC}/doc/sysinfo/* \
- ${PREFIX}/share/doc/x${MAMEMESS}/sysinfo
.endif
+.if ${MAMEMESS} == "mess"
+ ${INSTALL_DATA} ${WRKSRC}/doc/sysinfo.dat \
+ ${PREFIX}/share/xmess/history.dat
.endif
.if ${MAMEMESS} == "mame" && defined(WITH_DATFILES) && ${WITH_DATFILES} == "yes"
${INSTALL_DATA} ${WRKDIR}/hiscore.dat ${PREFIX}/share/xmame
diff --git a/emulators/xmame/distinfo b/emulators/xmame/distinfo
index a2a0857b7bfb..16a402ecb808 100644
--- a/emulators/xmame/distinfo
+++ b/emulators/xmame/distinfo
@@ -1,6 +1,6 @@
-MD5 (xmame/xmame-0.37b13.2.tar.bz2) = 70ec7ae3fba3110a6d85a7f5bfdb84f1
+MD5 (xmame/xmame-0.54.1.tar.bz2) = 5768dc341b163c3733b4436870165f5a
+MD5 (xmame/xmame-0.37b15.2.tar.bz2) = 9c05a92aac0e29811e7b276c631153ed
MD5 (xmame/xmame-0.37b14.2.tar.bz2) = 34bfba3d1412a8f8e1abd4d738de3f27
-MD5 (xmame/xmame-0.53.1.tar.bz2) = dc34fe1646b8027147d4b29a993d4162
MD5 (xmame/cheat.zip) = dc380436c04780950cee07d3e31bfb0b
MD5 (xmame/history.zip) = 69da5c33e6a78092c6cd75cbeb737c6a
MD5 (xmame/hsdat7.zip) = 9e4a7e36448895f13128a675327e34e4
diff --git a/emulators/xmame/pkg-plist b/emulators/xmame/pkg-plist
index ad6a9d3bb506..c47747324e65 100644
--- a/emulators/xmame/pkg-plist
+++ b/emulators/xmame/pkg-plist
@@ -22,50 +22,11 @@ share/%%MAMEMESS%%/%%MAMEMESS%%rc
%%MAMEONLY%%%%PORTDOCS%%share/doc/xmame/changes.mame
%%MAMEONLY%%%%PORTDOCS%%share/doc/xmame/gamelist.mame
%%MAMEONLY%%%%PORTDOCS%%share/doc/xmame/readme.mame
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/credits.txt
%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/changes.mess
%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/gamelist.mess
%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/readme.mess
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/messold.txt
%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/messroms.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/aim65.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/bondwell.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/c128.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/c65.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/comquest.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/dream.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/elf.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/europc.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/galaxy.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/hp48s.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/i8530286.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/ibm8530.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/ibmat.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/ibmpc.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/ibmpcjr.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/lynx.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/mk1.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/mk2.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/msx.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/nc.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/nc200.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/neat.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/pc1251.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/pc1350.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/pc1401.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/pc1500.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/pc1512.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/pc1640.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/pc200.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/pcw16.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/pong.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/ssystem3.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/studio2.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/svision.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/sym1.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/t1000hx.txt
-%%MESSONLY%%%%PORTDOCS%%share/doc/xmess/sysinfo/vip.txt
-%%MESSONLY%%%%PORTDOCS%%@dirrm share/doc/xmess/sysinfo
+%%MESSONLY%%share/xmess/history.dat
%%PINMAMEONLY%%%%PORTDOCS%%share/doc/xpinmame/simulation.txt
%%PINMAMEONLY%%%%PORTDOCS%%share/doc/xpinmame/whatsnew.txt
%%PINMAMEONLY%%%%PORTDOCS%%share/doc/xpinmame/pinmame.txt
diff --git a/emulators/xmess/Makefile b/emulators/xmess/Makefile
index 3077eb1982a6..80f6a2a7d91f 100644
--- a/emulators/xmess/Makefile
+++ b/emulators/xmess/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xmess
-PORTVERSION= 0.37b13.2
+PORTVERSION= 0.37b15.2
MAINTAINER= stijn@win.tue.nl