aboutsummaryrefslogtreecommitdiffstats
path: root/french/xtel
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-01-01 22:10:16 +0800
committerijliao <ijliao@FreeBSD.org>2002-01-01 22:10:16 +0800
commit0750197375e42f5b085a399856f909dd534b225d (patch)
tree5b5a45e1d5e143b29ba71417f07ee7138b0c17fd /french/xtel
parent9c015ab4b9e1a0c2c63112a25ff805d6359d15d3 (diff)
downloadfreebsd-ports-0750197375e42f5b085a399856f909dd534b225d.tar.gz
freebsd-ports-0750197375e42f5b085a399856f909dd534b225d.tar.zst
freebsd-ports-0750197375e42f5b085a399856f909dd534b225d.zip
copy a default temporary host.def if you do not have one
PR: 33396 Submitted by: maintainer
Diffstat (limited to 'french/xtel')
-rw-r--r--french/xtel/Makefile11
-rw-r--r--french/xtel/files/host.def9
2 files changed, 20 insertions, 0 deletions
diff --git a/french/xtel/Makefile b/french/xtel/Makefile
index 017d5416da10..fb5682b2cd1c 100644
--- a/french/xtel/Makefile
+++ b/french/xtel/Makefile
@@ -41,6 +41,17 @@ post-patch:
find ${WRKSRC} -type f | xargs ${PERL} -pi -e \
"s@#include.*<malloc.h>@#include <stdlib.h>@g"
+pre-configure:
+.if !exists(${PREFIX}/lib/X11/config/host.def)
+ ${CP} ${FILESDIR}/host.def ${PREFIX}/lib/X11/config
+HOST_DEF_INSTALLED_BY_XTEL= yes
+.endif
+
+post-configure:
+.if defined(HOST_DEF_INSTALLED_BY_XTEL)
+ ${RM} ${PREFIX}/lib/X11/config/host.def
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
diff --git a/french/xtel/files/host.def b/french/xtel/files/host.def
new file mode 100644
index 000000000000..f8a38459fe01
--- /dev/null
+++ b/french/xtel/files/host.def
@@ -0,0 +1,9 @@
+/*
+ * Host.def for building FreeBSD bindists
+ *
+ * $XFree86: xc/programs/Xserver/hw/xfree86/etc/bindist/FreeBSD/host.def,v 1.3.4.1 2001/05/31 22:20:27 dawes Exp $
+ */
+
+#define InstallEmptyHostDef
+#define BuildBindist
+