aboutsummaryrefslogtreecommitdiffstats
path: root/games/alienarena/files/patch-Makefile
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2007-09-09 13:52:58 +0800
committeralepulver <alepulver@FreeBSD.org>2007-09-09 13:52:58 +0800
commit78429efdd647bda9ad20cd1dda86cdfccfe8df9c (patch)
tree8b6ad4a1d24e029c81eb5effad3c7bc6edc1291d /games/alienarena/files/patch-Makefile
parentd1531c2fe4561fd10c28b26c1f54754819597b71 (diff)
downloadfreebsd-ports-78429efdd647bda9ad20cd1dda86cdfccfe8df9c.tar.gz
freebsd-ports-78429efdd647bda9ad20cd1dda86cdfccfe8df9c.tar.zst
freebsd-ports-78429efdd647bda9ad20cd1dda86cdfccfe8df9c.zip
- Update patches (remove old and add new ones).
Diffstat (limited to 'games/alienarena/files/patch-Makefile')
-rw-r--r--games/alienarena/files/patch-Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/games/alienarena/files/patch-Makefile b/games/alienarena/files/patch-Makefile
new file mode 100644
index 000000000000..8eb73d19d1ac
--- /dev/null
+++ b/games/alienarena/files/patch-Makefile
@@ -0,0 +1,52 @@
+--- ../Makefile.orig Fri May 25 01:00:34 2007
++++ ../Makefile Sat Jul 21 13:39:48 2007
+@@ -22,6 +22,10 @@
+ # Build binary that uses SDL for sound when "1".
+ SDLSOUND?=1
+
++# Adds DATADIR/LIBDIR (see below) to the data and library search path.
++WITH_DATADIR?=no
++WITH_LIBDIR?=no
++
+ # Selects the component to build; ALL, GAME, or DEDICATED
+ BUILD?=ALL
+
+@@ -53,6 +57,20 @@
+
+ BASE_CFLAGS=$(CFLAGS) -Dstricmp=strcasecmp -D_stricmp=strcasecmp -I$(X11BASE)/include
+
++# DATADIR / LIBDIR support.
++
++PREFIX?=/usr/local
++
++ifeq ($(strip $(WITH_DATADIR)),yes)
++DATADIR?=$(PREFIX)/share/alienarena
++BASE_CFLAGS+=-DDATADIR='\"$(DATADIR)\"'
++endif
++
++ifeq ($(strip $(WITH_LIBDIR)),yes)
++LIBDIR?=$(PREFIX)/lib/alienarena
++BASE_CFLAGS+=-DLIBDIR='\"$(LIBDIR)\"'
++endif
++
+ RELEASE_CFLAGS=$(BASE_CFLAGS)
+
+ ifeq ($(strip $(OPTIMIZED_CFLAGS)),yes)
+@@ -128,13 +146,13 @@
+ $(BUILDDIR)/crx
+ endif
+
++ifeq ($(strip $(BUILD)),CLIENT)
++ TARGETS+=$(BUILDDIR)/crx
++endif
++
+ ifeq ($(strip $(BUILD)),DEDICATED)
+ SDLSOUND=0
+ TARGETS+=$(BUILDDIR)/crded
+-endif
+-
+-ifeq ($(strip $(BUILD)),GAME)
+- TARGETS+=$(BUILDDIR)/crx
+ endif
+
+ ifeq ($(strip $(SDLSOUND)),1)