aboutsummaryrefslogtreecommitdiffstats
path: root/games/biorythm
diff options
context:
space:
mode:
authorAlexander Langer <alex@FreeBSD.org>2000-07-16 22:31:54 +0800
committerAlexander Langer <alex@FreeBSD.org>2000-07-16 22:31:54 +0800
commit217ed45bf94757c34f79783b7402354783903558 (patch)
treeda504f9b49b4e741a0dee923eab380ffe34bef30 /games/biorythm
parent46d8696533b8961d0b96df54b52cef8db01b7890 (diff)
downloadfreebsd-ports-217ed45bf94757c34f79783b7402354783903558.tar.gz
freebsd-ports-217ed45bf94757c34f79783b7402354783903558.tar.zst
freebsd-ports-217ed45bf94757c34f79783b7402354783903558.zip
- Update MASTER_SITES and WWW: line of pkg/DESCR
- Support CC/CFLAGS/PREFIX/LOCALBASE/X11BASE/etc properly PR: 19757 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=30703
Diffstat (limited to 'games/biorythm')
-rw-r--r--games/biorythm/Makefile30
-rw-r--r--games/biorythm/files/patch-aa38
-rw-r--r--games/biorythm/pkg-descr2
3 files changed, 38 insertions, 32 deletions
diff --git a/games/biorythm/Makefile b/games/biorythm/Makefile
index b14adb6d1981..7012e111e147 100644
--- a/games/biorythm/Makefile
+++ b/games/biorythm/Makefile
@@ -5,31 +5,25 @@
# $FreeBSD$
#
-PORTNAME= biorythm
-PORTVERSION= 1.1.1
-CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SUNSITE} \
- http://home.sol.no/~sverrehu/pub-unix/files/
-MASTER_SITE_SUBDIR= games/amusements
+PORTNAME= biorythm
+PORTVERSION= 1.1.1
+CATEGORIES= games
+MASTER_SITES= http://shh.thathost.com/pub-unix/files/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= shhmsg.1:${PORTSDIR}/devel/libshhmsg \
- shhopt.1:${PORTSDIR}/devel/libshhopt
+LIB_DEPENDS= shhmsg.1:${PORTSDIR}/devel/libshhmsg \
+ shhopt.1:${PORTSDIR}/devel/libshhopt
-USE_GMAKE= yes
+USE_GMAKE= yes
-MAN6= biorythm.6
-
-do-install:
- @ ${INSTALL_PROGRAM} ${WRKSRC}/biorythm ${PREFIX}/bin
- @ ${INSTALL_MAN} ${WRKSRC}/biorythm.6 ${PREFIX}/man/man6
+MAN6= biorythm.6
post-install:
-.if !defined (NOPORTDOCS)
- @ ${MKDIR} ${PREFIX}/share/doc/biorythm
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/biorythm
.for file in CREDITS ChangeLog README
- @ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/biorythm
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/biorythm
.endfor
.endif
diff --git a/games/biorythm/files/patch-aa b/games/biorythm/files/patch-aa
index dc818b4b8fb2..ad77bb6649d3 100644
--- a/games/biorythm/files/patch-aa
+++ b/games/biorythm/files/patch-aa
@@ -1,28 +1,40 @@
---- Makefile Sun Jul 5 19:55:11 1998
-+++ /home/andy/tmp/wrk/Makefile Tue May 4 10:55:11 1999
-@@ -11,10 +11,10 @@
+--- Makefile.orig Mon Jul 6 00:55:11 1998
++++ Makefile Tue Jul 4 21:47:21 2000
+@@ -11,15 +11,15 @@
###########################################################################
# where are shhmsg and shhopt?
-INCDIR = -I/usr/local/include
-LIBDIR = -L/usr/local/lib
-+INCDIR = -I$(LOCALBASE)/include
-+LIBDIR = -L$(LOCALBASE)/lib
++INCDIR = -I${LOCALBASE}/include
++LIBDIR = -L${LOCALBASE}/lib
-INSTBASEDIR = /usr/local
-+INSTBASEDIR = $(PREFIX)
- INSTBINDIR = $(INSTBASEDIR)/games
+-INSTBINDIR = $(INSTBASEDIR)/games
++INSTBASEDIR = ${PREFIX}
++INSTBINDIR = $(INSTBASEDIR)/bin
INSTMANDIR = $(INSTBASEDIR)/man/man6
- INSTALL = install -m 644
-@@ -27,9 +27,9 @@
+-INSTALL = install -m 644
+-INSTALLPROG = install -s -m 755
+-MKDIRP = install -d -m 755
++INSTALL = ${BSD_INSTALL_DATA}
++INSTALLPROG = ${BSD_INSTALL_PROGRAM}
++MKDIRP = mkdir -p
+
+ DEFINES = -DVERSION=\"$(VERSION)\" \
+ "-DCOMPILED_DATE=\"$(COMPILED_DATE)\"" \
+@@ -27,11 +27,11 @@
###########################################################################
-CC = gcc
+#CC = gcc
--OPTIM = -O2
-+OPTIM = $(CFLAGS)
- CCOPT = -Wall $(OPTIM) $(INCDIR) $(DEFINES) $(CFLAGS)
- LDOPT = -s $(LIBDIR) $(LDFLAGS)
+ OPTIM = -O2
+-CCOPT = -Wall $(OPTIM) $(INCDIR) $(DEFINES) $(CFLAGS)
+-LDOPT = -s $(LIBDIR) $(LDFLAGS)
++CCOPT = $(INCDIR) $(DEFINES) $(CFLAGS)
++LDOPT = $(LIBDIR) $(LDFLAGS)
+ LIBS = -lshhmsg -lshhopt -lm
+ OBJS = $(PROG).o date.o
diff --git a/games/biorythm/pkg-descr b/games/biorythm/pkg-descr
index 5fb94d9ee9e3..6d9a112028cf 100644
--- a/games/biorythm/pkg-descr
+++ b/games/biorythm/pkg-descr
@@ -12,4 +12,4 @@ curves. This may be overridden by command line options.
The author has no idea how to interpret the plot, so please don't ask
him about it.
-WWW: http://home.sol.no/~sverrehu/pub-unix/
+WWW: http://shh.thathost.com/pub-unix/#biorythm