aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1998-08-12 14:29:36 +0800
committerSatoshi Asami <asami@FreeBSD.org>1998-08-12 14:29:36 +0800
commit65edaaa1f5cfb9af7b384788fefd39044f26fc07 (patch)
tree080a5bd8fdcd58d9ce8984e5662f2f2cdf79265d /games
parent1596221df99f5031117eaee27e868532becd0048 (diff)
downloadfreebsd-ports-65edaaa1f5cfb9af7b384788fefd39044f26fc07.tar.gz
freebsd-ports-65edaaa1f5cfb9af7b384788fefd39044f26fc07.tar.zst
freebsd-ports-65edaaa1f5cfb9af7b384788fefd39044f26fc07.zip
Replace qt dependencies with USE_QT.
(Also, net/licq/Makefile: No need to define both HAS_CONFIGURE and GNU_CONFIGURE)
Notes
Notes: svn path=/head/; revision=12469
Diffstat (limited to 'games')
-rw-r--r--games/blackjack/Makefile6
-rw-r--r--games/kdegames11/Makefile7
-rw-r--r--games/kdegames2/Makefile7
-rw-r--r--games/kdegames3/Makefile7
-rw-r--r--games/kdegames4/Makefile7
-rw-r--r--games/ktamaga/Makefile7
-rw-r--r--games/nethack-qt/Makefile6
-rw-r--r--games/nethack33-qt/Makefile6
-rw-r--r--games/nethack34-qt/Makefile6
-rw-r--r--games/pp/Makefile6
-rw-r--r--games/xlines/Makefile6
11 files changed, 30 insertions, 41 deletions
diff --git a/games/blackjack/Makefile b/games/blackjack/Makefile
index c6a5b700d013..00261fcec944 100644
--- a/games/blackjack/Makefile
+++ b/games/blackjack/Makefile
@@ -3,7 +3,7 @@
# Date created: 23 February 1998
# Whom: Peter Mutsaers
#
-# $Id: Makefile,v 1.3 1998/07/27 23:24:37 asami Exp $
+# $Id: Makefile,v 1.4 1998/08/07 23:56:19 asami Exp $
#
DISTNAME= blackjack-1.1
@@ -13,9 +13,7 @@ MASTER_SITE_SUBDIR= games/strategy
MAINTAINER= plm@xs4all.nl
-BUILD_DEPENDS= moc:${PORTSDIR}/x11-toolkits/qt
-LIB_DEPENDS= qt\\.1\\.3[0-9]:${PORTSDIR}/x11-toolkits/qt
-
+USE_QT= yes
WRKSRC= ${WRKDIR}/blackjack
MAN1= blackjack.1
diff --git a/games/kdegames11/Makefile b/games/kdegames11/Makefile
index 9da38c9d2ad0..32cf803e7e62 100644
--- a/games/kdegames11/Makefile
+++ b/games/kdegames11/Makefile
@@ -3,7 +3,7 @@
# Date created: 28 October 1997
# Whom: Stefan Eßer <se@freebsd.org>
#
-# $Id: Makefile,v 1.14 1998/07/23 20:51:58 se Exp $
+# $Id: Makefile,v 1.15 1998/08/07 23:56:20 asami Exp $
#
DISTNAME= kdegames-1.0
@@ -13,9 +13,7 @@ MASTER_SITE_SUBDIR= stable/1.0/distribution/tar/generic/source
MAINTAINER= se@freebsd.org
-BUILD_DEPENDS= moc:${PORTSDIR}/x11-toolkits/qt140
-LIB_DEPENDS= qt\\.1\\.\\\(33\\\|40\\\):${PORTSDIR}/x11-toolkits/qt140 \
- gif\\.[23]\\.:${PORTSDIR}/graphics/giflib \
+LIB_DEPENDS= gif\\.[23]\\.:${PORTSDIR}/graphics/giflib \
jpeg\\.9\\.:${PORTSDIR}/graphics/jpeg \
kdecore\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
kdeui\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
@@ -25,6 +23,7 @@ LIB_DEPENDS= qt\\.1\\.\\\(33\\\|40\\\):${PORTSDIR}/x11-toolkits/qt140 \
mediatool\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
QwSpriteField\\.5\\.[2-9]:${PORTSDIR}/converters/kdesupport
+USE_QT= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= "--prefix=$(PREFIX)" \
"--with-extra-includes=$(PREFIX)/include/giflib"
diff --git a/games/kdegames2/Makefile b/games/kdegames2/Makefile
index 9da38c9d2ad0..32cf803e7e62 100644
--- a/games/kdegames2/Makefile
+++ b/games/kdegames2/Makefile
@@ -3,7 +3,7 @@
# Date created: 28 October 1997
# Whom: Stefan Eßer <se@freebsd.org>
#
-# $Id: Makefile,v 1.14 1998/07/23 20:51:58 se Exp $
+# $Id: Makefile,v 1.15 1998/08/07 23:56:20 asami Exp $
#
DISTNAME= kdegames-1.0
@@ -13,9 +13,7 @@ MASTER_SITE_SUBDIR= stable/1.0/distribution/tar/generic/source
MAINTAINER= se@freebsd.org
-BUILD_DEPENDS= moc:${PORTSDIR}/x11-toolkits/qt140
-LIB_DEPENDS= qt\\.1\\.\\\(33\\\|40\\\):${PORTSDIR}/x11-toolkits/qt140 \
- gif\\.[23]\\.:${PORTSDIR}/graphics/giflib \
+LIB_DEPENDS= gif\\.[23]\\.:${PORTSDIR}/graphics/giflib \
jpeg\\.9\\.:${PORTSDIR}/graphics/jpeg \
kdecore\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
kdeui\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
@@ -25,6 +23,7 @@ LIB_DEPENDS= qt\\.1\\.\\\(33\\\|40\\\):${PORTSDIR}/x11-toolkits/qt140 \
mediatool\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
QwSpriteField\\.5\\.[2-9]:${PORTSDIR}/converters/kdesupport
+USE_QT= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= "--prefix=$(PREFIX)" \
"--with-extra-includes=$(PREFIX)/include/giflib"
diff --git a/games/kdegames3/Makefile b/games/kdegames3/Makefile
index 9da38c9d2ad0..32cf803e7e62 100644
--- a/games/kdegames3/Makefile
+++ b/games/kdegames3/Makefile
@@ -3,7 +3,7 @@
# Date created: 28 October 1997
# Whom: Stefan Eßer <se@freebsd.org>
#
-# $Id: Makefile,v 1.14 1998/07/23 20:51:58 se Exp $
+# $Id: Makefile,v 1.15 1998/08/07 23:56:20 asami Exp $
#
DISTNAME= kdegames-1.0
@@ -13,9 +13,7 @@ MASTER_SITE_SUBDIR= stable/1.0/distribution/tar/generic/source
MAINTAINER= se@freebsd.org
-BUILD_DEPENDS= moc:${PORTSDIR}/x11-toolkits/qt140
-LIB_DEPENDS= qt\\.1\\.\\\(33\\\|40\\\):${PORTSDIR}/x11-toolkits/qt140 \
- gif\\.[23]\\.:${PORTSDIR}/graphics/giflib \
+LIB_DEPENDS= gif\\.[23]\\.:${PORTSDIR}/graphics/giflib \
jpeg\\.9\\.:${PORTSDIR}/graphics/jpeg \
kdecore\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
kdeui\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
@@ -25,6 +23,7 @@ LIB_DEPENDS= qt\\.1\\.\\\(33\\\|40\\\):${PORTSDIR}/x11-toolkits/qt140 \
mediatool\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
QwSpriteField\\.5\\.[2-9]:${PORTSDIR}/converters/kdesupport
+USE_QT= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= "--prefix=$(PREFIX)" \
"--with-extra-includes=$(PREFIX)/include/giflib"
diff --git a/games/kdegames4/Makefile b/games/kdegames4/Makefile
index 9da38c9d2ad0..32cf803e7e62 100644
--- a/games/kdegames4/Makefile
+++ b/games/kdegames4/Makefile
@@ -3,7 +3,7 @@
# Date created: 28 October 1997
# Whom: Stefan Eßer <se@freebsd.org>
#
-# $Id: Makefile,v 1.14 1998/07/23 20:51:58 se Exp $
+# $Id: Makefile,v 1.15 1998/08/07 23:56:20 asami Exp $
#
DISTNAME= kdegames-1.0
@@ -13,9 +13,7 @@ MASTER_SITE_SUBDIR= stable/1.0/distribution/tar/generic/source
MAINTAINER= se@freebsd.org
-BUILD_DEPENDS= moc:${PORTSDIR}/x11-toolkits/qt140
-LIB_DEPENDS= qt\\.1\\.\\\(33\\\|40\\\):${PORTSDIR}/x11-toolkits/qt140 \
- gif\\.[23]\\.:${PORTSDIR}/graphics/giflib \
+LIB_DEPENDS= gif\\.[23]\\.:${PORTSDIR}/graphics/giflib \
jpeg\\.9\\.:${PORTSDIR}/graphics/jpeg \
kdecore\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
kdeui\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
@@ -25,6 +23,7 @@ LIB_DEPENDS= qt\\.1\\.\\\(33\\\|40\\\):${PORTSDIR}/x11-toolkits/qt140 \
mediatool\\.1\\.[0-9]:${PORTSDIR}/x11/kdelibs \
QwSpriteField\\.5\\.[2-9]:${PORTSDIR}/converters/kdesupport
+USE_QT= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= "--prefix=$(PREFIX)" \
"--with-extra-includes=$(PREFIX)/include/giflib"
diff --git a/games/ktamaga/Makefile b/games/ktamaga/Makefile
index 077cf285037f..d261ead84f87 100644
--- a/games/ktamaga/Makefile
+++ b/games/ktamaga/Makefile
@@ -3,7 +3,7 @@
# Date created: 13 November 1997
# Whom: Stefan Eßer <se@freebsd.org>
#
-# $Id: Makefile,v 1.4 1998/04/29 17:51:20 asami Exp $
+# $Id: Makefile,v 1.5 1998/08/07 23:56:20 asami Exp $
#
DISTNAME= ktamaga-0.2
@@ -13,12 +13,11 @@ MASTER_SITES= ftp://ftp.net.lut.ac.uk/kde/unstable/apps/games/ \
MAINTAINER= se@freebsd.org
-BUILD_DEPENDS= moc:${PORTSDIR}/x11-toolkits/qt
-LIB_DEPENDS= qt\\.1\\.3[0-9]:${PORTSDIR}/x11-toolkits/qt \
- kdecore\\.0\\.1[1-9]:${PORTSDIR}/x11/kdelibs
+LIB_DEPENDS= kdecore\\.0\\.1[1-9]:${PORTSDIR}/x11/kdelibs
BROKEN= upgrade
+USE_QT= yes
WRKSRC= ${WRKDIR}/tamaga-0.2
.include <bsd.port.mk>
diff --git a/games/nethack-qt/Makefile b/games/nethack-qt/Makefile
index aa7dbd535018..200a3895bd25 100644
--- a/games/nethack-qt/Makefile
+++ b/games/nethack-qt/Makefile
@@ -3,7 +3,7 @@
# Date created: So 6 Apr 1997 04:25:57 MET DST
# Whom: Andreas Klemm <andreas@klemm.gtn.com>
#
-# $Id: Makefile,v 1.14 1998/07/27 23:24:44 asami Exp $
+# $Id: Makefile,v 1.15 1998/08/07 23:56:21 asami Exp $
#
DISTNAME= nethack-3.2.2
@@ -21,10 +21,10 @@ MAINTAINER= andreas@FreeBSD.ORG
BUILD_DEPENDS= auplay:${PORTSDIR}/audio/nas \
xpmtoppm:${PORTSDIR}/graphics/netpbm
-LIB_DEPENDS= qt\\.1\\.40:${PORTSDIR}/x11-toolkits/qt140 \
- Xpm\\.4\\.:${PORTSDIR}/graphics/xpm
+LIB_DEPENDS= Xpm\\.4\\.:${PORTSDIR}/graphics/xpm
RUN_DEPENDS= auplay:${PORTSDIR}/audio/nas
+USE_QT= yes
EXTRACT_ONLY= nethack-3.2.2.tar.gz
USE_GMAKE= yes
MAN6= dgn_comp.6 dlb.6 lev_comp.6 nethack.6 recover.6
diff --git a/games/nethack33-qt/Makefile b/games/nethack33-qt/Makefile
index aa7dbd535018..200a3895bd25 100644
--- a/games/nethack33-qt/Makefile
+++ b/games/nethack33-qt/Makefile
@@ -3,7 +3,7 @@
# Date created: So 6 Apr 1997 04:25:57 MET DST
# Whom: Andreas Klemm <andreas@klemm.gtn.com>
#
-# $Id: Makefile,v 1.14 1998/07/27 23:24:44 asami Exp $
+# $Id: Makefile,v 1.15 1998/08/07 23:56:21 asami Exp $
#
DISTNAME= nethack-3.2.2
@@ -21,10 +21,10 @@ MAINTAINER= andreas@FreeBSD.ORG
BUILD_DEPENDS= auplay:${PORTSDIR}/audio/nas \
xpmtoppm:${PORTSDIR}/graphics/netpbm
-LIB_DEPENDS= qt\\.1\\.40:${PORTSDIR}/x11-toolkits/qt140 \
- Xpm\\.4\\.:${PORTSDIR}/graphics/xpm
+LIB_DEPENDS= Xpm\\.4\\.:${PORTSDIR}/graphics/xpm
RUN_DEPENDS= auplay:${PORTSDIR}/audio/nas
+USE_QT= yes
EXTRACT_ONLY= nethack-3.2.2.tar.gz
USE_GMAKE= yes
MAN6= dgn_comp.6 dlb.6 lev_comp.6 nethack.6 recover.6
diff --git a/games/nethack34-qt/Makefile b/games/nethack34-qt/Makefile
index aa7dbd535018..200a3895bd25 100644
--- a/games/nethack34-qt/Makefile
+++ b/games/nethack34-qt/Makefile
@@ -3,7 +3,7 @@
# Date created: So 6 Apr 1997 04:25:57 MET DST
# Whom: Andreas Klemm <andreas@klemm.gtn.com>
#
-# $Id: Makefile,v 1.14 1998/07/27 23:24:44 asami Exp $
+# $Id: Makefile,v 1.15 1998/08/07 23:56:21 asami Exp $
#
DISTNAME= nethack-3.2.2
@@ -21,10 +21,10 @@ MAINTAINER= andreas@FreeBSD.ORG
BUILD_DEPENDS= auplay:${PORTSDIR}/audio/nas \
xpmtoppm:${PORTSDIR}/graphics/netpbm
-LIB_DEPENDS= qt\\.1\\.40:${PORTSDIR}/x11-toolkits/qt140 \
- Xpm\\.4\\.:${PORTSDIR}/graphics/xpm
+LIB_DEPENDS= Xpm\\.4\\.:${PORTSDIR}/graphics/xpm
RUN_DEPENDS= auplay:${PORTSDIR}/audio/nas
+USE_QT= yes
EXTRACT_ONLY= nethack-3.2.2.tar.gz
USE_GMAKE= yes
MAN6= dgn_comp.6 dlb.6 lev_comp.6 nethack.6 recover.6
diff --git a/games/pp/Makefile b/games/pp/Makefile
index cc0f3c5666ce..4d3e1d445368 100644
--- a/games/pp/Makefile
+++ b/games/pp/Makefile
@@ -3,7 +3,7 @@
# Date created: 21 May 1998
# Whom: Andrey Zakhvatov
#
-# $Id: Makefile,v 1.2 1998/08/05 09:30:57 asami Exp $
+# $Id: Makefile,v 1.3 1998/08/07 23:56:21 asami Exp $
#
DISTNAME= pp-0.01
@@ -14,9 +14,7 @@ DISTFILES= ppinst-0.01.tar.gz ppsrc-0.01.tar.gz
MAINTAINER= andy@icc.surw.chel.su
-LIB_DEPENDS= qt\\.1\\.:${PORTSDIR}/x11-toolkits/qt
-BUILD_DEPENDS= moc:${PORTSDIR}/x11-toolkits/qt
-
+USE_QT= yes
USE_X_PREFIX= yes
WRKSRC= ${WRKDIR}/ppsrc
diff --git a/games/xlines/Makefile b/games/xlines/Makefile
index 8b696875936e..320dd3b7b4f2 100644
--- a/games/xlines/Makefile
+++ b/games/xlines/Makefile
@@ -3,7 +3,7 @@
# Date created: 11 February 1998
# Whom: Andrey Zakhvatov
#
-# $Id: Makefile,v 1.4 1998/08/05 09:30:59 asami Exp $
+# $Id: Makefile,v 1.5 1998/08/07 23:56:22 asami Exp $
#
DISTNAME= xlines
@@ -13,9 +13,7 @@ MASTER_SITES= ftp://risq.belcaf.minsk.by/pub/genie/
MAINTAINER= andy@icc.surw.chel.su
-LIB_DEPENDS= qt\\.1\\.:${PORTSDIR}/x11-toolkits/qt
-BUILD_DEPENDS= moc:${PORTSDIR}/x11-toolkits/qt
-
+USE_QT= yes
USE_X_PREFIX= yes
NO_WRKSUBDIR= yes