aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-04-11 04:36:17 +0800
committerWill Andrews <will@FreeBSD.org>2001-04-11 04:36:17 +0800
commit97652512b103a549afff95fdb23c7dadf63bf823 (patch)
tree379979a4addb41c1a17a8e46333b7a2b813c5d7b /games
parent15492376f6f42b726cb01bbaeb0776d93c89469c (diff)
downloadfreebsd-ports-97652512b103a549afff95fdb23c7dadf63bf823.tar.gz
freebsd-ports-97652512b103a549afff95fdb23c7dadf63bf823.tar.zst
freebsd-ports-97652512b103a549afff95fdb23c7dadf63bf823.zip
Add marathon-evil 3, the Marathon-Evil scenario for use with AlephOne.
PR: 26487 Submitted by: bmah
Notes
Notes: svn path=/head/; revision=41230
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/marathon-evil/Makefile47
-rw-r--r--games/marathon-evil/distinfo1
-rw-r--r--games/marathon-evil/pkg-comment1
-rw-r--r--games/marathon-evil/pkg-descr11
-rw-r--r--games/marathon-evil/pkg-message5
-rw-r--r--games/marathon-evil/pkg-plist10
7 files changed, 76 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 64abf64fd5a5..d4dee7794c93 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -139,6 +139,7 @@
SUBDIR += magiccube4d
SUBDIR += mahjong
SUBDIR += mangband
+ SUBDIR += marathon-evil
SUBDIR += merlin
SUBDIR += mindfocus
SUBDIR += mindguard
diff --git a/games/marathon-evil/Makefile b/games/marathon-evil/Makefile
new file mode 100644
index 000000000000..ad3af18844d6
--- /dev/null
+++ b/games/marathon-evil/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: marathon-evil
+# Date created: 01 April 2001
+# Whom: Bruce A. Mah <bmah@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= marathon-evil
+PORTVERSION= 3
+CATEGORIES= games
+MASTER_SITES= http://archives2.bungie.org/a1sdl/ \
+ ftp://ftp2.bungie.org/archives/a1sdl/
+DISTNAME= MarathonEvil-3
+
+MAINTAINER= bmah@freebsd.org
+
+#RUN_DEPENDS= alephone:${PORTSDIR}/games/alephone
+
+USE_X_PREFIX= yes
+NO_CDROM= Bungie/Microsoft do not allow charging for Marathon data files.
+
+WRKSRC= ${WRKDIR}/MarathonEvil
+
+# For some inexplicable reason, there's a tarball inside the tarball.
+# We'll deal with the inner tarball as the build.
+do-build:
+ cd ${WRKSRC}; \
+ ${GUNZIP_CMD} -c ${WRKSRC}/MarathonEvilData.tar.gz | ${TAR} -xf -
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/Cursed.Data ${PREFIX}/share/AlephOne/Cursed.Data
+ ${INSTALL_DATA} ${WRKSRC}/Cursed.Images ${PREFIX}/share/AlephOne/Cursed.Images
+ ${INSTALL_DATA} ${WRKSRC}/Cursed.Map ${PREFIX}/share/AlephOne/Cursed.Map
+ ${INSTALL_DATA} ${WRKSRC}/Cursed.Music ${PREFIX}/share/AlephOne/Cursed.Music
+ ${INSTALL_DATA} ${WRKSRC}/Cursed.Net.Map ${PREFIX}/share/AlephOne/Cursed.Net.Map
+ ${INSTALL_DATA} ${WRKSRC}/Cursed.Net.Physics ${PREFIX}/share/AlephOne/Cursed.Net.Physics
+ ${INSTALL_DATA} ${WRKSRC}/Cursed.Physics ${PREFIX}/share/AlephOne/Cursed.Physics
+ ${INSTALL_DATA} ${WRKSRC}/Cursed.Shapes ${PREFIX}/share/AlephOne/Cursed.Shapes
+ ${INSTALL_DATA} ${WRKSRC}/Cursed.Sounds ${PREFIX}/share/AlephOne/Cursed.Sounds
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/AlephOne/README.Evil
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${CAT} ${PKGMESSAGE}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/marathon-evil/distinfo b/games/marathon-evil/distinfo
new file mode 100644
index 000000000000..b87d325350e3
--- /dev/null
+++ b/games/marathon-evil/distinfo
@@ -0,0 +1 @@
+MD5 (MarathonEvil-3.tar.gz) = 42a5d07c956e4bb57c96cfb1299dd890
diff --git a/games/marathon-evil/pkg-comment b/games/marathon-evil/pkg-comment
new file mode 100644
index 000000000000..25f7bb57ab25
--- /dev/null
+++ b/games/marathon-evil/pkg-comment
@@ -0,0 +1 @@
+Marathon-Evil scenario for use with AlephOne
diff --git a/games/marathon-evil/pkg-descr b/games/marathon-evil/pkg-descr
new file mode 100644
index 000000000000..eb547309a6ff
--- /dev/null
+++ b/games/marathon-evil/pkg-descr
@@ -0,0 +1,11 @@
+This port contains the Marathon: Evil files, converted to run on
+Aleph One. The Aleph One application itself is in the `alephone' port.
+
+Marathon: Evil is a third-party scenario package with all-new monsters,
+maps, sounds, and so on. This particular port is a conversion of
+the original Marathon: Evil to run on Aleph One/SDL.
+
+Bruce A. Mah
+bmah@freebsd.org
+
+WWW: http://bighouse.bungie.org/evil/
diff --git a/games/marathon-evil/pkg-message b/games/marathon-evil/pkg-message
new file mode 100644
index 000000000000..919d0962cf9d
--- /dev/null
+++ b/games/marathon-evil/pkg-message
@@ -0,0 +1,5 @@
+To play the Marathon: Evil scenario, start alephone, and
+select the Preferences screen, the Environment section.
+For each of the items listed in the environment, choose the
+"Cursed" data file (there will be one for each environment item
+except for Theme).
diff --git a/games/marathon-evil/pkg-plist b/games/marathon-evil/pkg-plist
new file mode 100644
index 000000000000..ff4309dfb8ce
--- /dev/null
+++ b/games/marathon-evil/pkg-plist
@@ -0,0 +1,10 @@
+share/AlephOne/Cursed.Data
+share/AlephOne/Cursed.Images
+share/AlephOne/Cursed.Map
+share/AlephOne/Cursed.Music
+share/AlephOne/Cursed.Net.Map
+share/AlephOne/Cursed.Net.Physics
+share/AlephOne/Cursed.Physics
+share/AlephOne/Cursed.Shapes
+share/AlephOne/Cursed.Sounds
+share/AlephOne/README.Evil