aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2007-09-23 12:31:19 +0800
committeredwin <edwin@FreeBSD.org>2007-09-23 12:31:19 +0800
commitbf6ebdac033128d70da4e9ed3ecff2f229468d18 (patch)
tree994c189ee21ad025160c68eb5062f3885a07ef99 /games
parent002866beeaab83669369b9c5194a8edd25b52d68 (diff)
downloadfreebsd-ports-bf6ebdac033128d70da4e9ed3ecff2f229468d18.tar.gz
freebsd-ports-bf6ebdac033128d70da4e9ed3ecff2f229468d18.tar.zst
freebsd-ports-bf6ebdac033128d70da4e9ed3ecff2f229468d18.zip
New port: games/crafty-open-enormous
This is the port of the medium opening book for crafty. It consumes about 85-90M. It was created with "book create enormous.pgn 60 2 50" (see the crafty documentation and online help for a more thorough explanation of what this does) PR: ports/116240 Submitted by: shoemaker@bluebottle.com (Jonathan Shoemaker)
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/crafty-open-enormous/Makefile45
-rw-r--r--games/crafty-open-enormous/distinfo3
-rw-r--r--games/crafty-open-enormous/files/book-building2
-rw-r--r--games/crafty-open-enormous/pkg-descr8
-rw-r--r--games/crafty-open-enormous/pkg-plist2
6 files changed, 61 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 36bf5e41f3ff..48dee0b42639 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -128,6 +128,7 @@
SUBDIR += cowsay
SUBDIR += crack-attack
SUBDIR += crafty
+ SUBDIR += crafty-open-enormous
SUBDIR += crafty-open-large
SUBDIR += crafty-open-medium
SUBDIR += crafty-tablebase-no-pawn
diff --git a/games/crafty-open-enormous/Makefile b/games/crafty-open-enormous/Makefile
new file mode 100644
index 000000000000..6a080a96ddef
--- /dev/null
+++ b/games/crafty-open-enormous/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: crafty-open-enormous
+# Date created: 9 Sep 2007
+# Whom: Jonathan Shoemaker <shoemaker@bluebottle.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= crafty-open-enormous
+PORTVERSION= 1
+CATEGORIES= games
+MASTER_SITES= ftp://ftp.cis.uab.edu/pub/hyatt/pgn/ \
+ ${MASTER_SITE_LOCAL}
+DISTFILES= enormous.zip
+EXTRACT_ONLY= ${DISTFILES}
+
+MAINTAINER= shoemaker@bluebottle.com
+COMMENT= The enormous opening book (about 85-90 MByte) for crafty
+
+BUILD_DEPENDS= crafty:${PORTSDIR}/games/crafty
+RUN_DEPENDS= crafty:${PORTSDIR}/games/crafty
+
+DIST_SUBDIR= crafty
+USE_ZIP= yes
+NO_WRKSUBDIR= yes
+NO_PACKAGE= Package is way too big
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+BROKEN= dumps core during build
+.endif
+
+do-build:
+ @${ECHO_MSG} '================================================================'
+ @${ECHO_MSG} 'Ignore warnings about illegal moves. These warnings are normal.'
+ @${ECHO_MSG} '================================================================'
+ (cd ${WRKDIR}; ${CHOWN} nobody ${WRKDIR}; crafty bookpath=. <${FILESDIR}/book-building)
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/crafty
+ ${INSTALL_DATA} ${WRKDIR}/book.bin ${PREFIX}/lib/crafty/book.bin
+ ${CHOWN} nobody:nogroup ${PREFIX}/lib/crafty/book.bin
+ ${CHMOD} 664 ${PREFIX}/lib/crafty/book.bin
+
+.include <bsd.port.post.mk>
diff --git a/games/crafty-open-enormous/distinfo b/games/crafty-open-enormous/distinfo
new file mode 100644
index 000000000000..352178914d17
--- /dev/null
+++ b/games/crafty-open-enormous/distinfo
@@ -0,0 +1,3 @@
+MD5 (crafty/enormous.zip) = 063c388c5b58fef83fa6f8be35644975
+SHA256 (crafty/enormous.zip) = c29bef354014e0cdb91644578101d48419f3aef15c300ab7eb01a1f11f392500
+SIZE (crafty/enormous.zip) = 282114811
diff --git a/games/crafty-open-enormous/files/book-building b/games/crafty-open-enormous/files/book-building
new file mode 100644
index 000000000000..5991cb18c62f
--- /dev/null
+++ b/games/crafty-open-enormous/files/book-building
@@ -0,0 +1,2 @@
+book create enormous.pgn 60 2 50
+quit
diff --git a/games/crafty-open-enormous/pkg-descr b/games/crafty-open-enormous/pkg-descr
new file mode 100644
index 000000000000..eecd44ac0a0f
--- /dev/null
+++ b/games/crafty-open-enormous/pkg-descr
@@ -0,0 +1,8 @@
+This is the port of the enormous opening book for crafty. It consumes
+about 85-90M.
+
+It was created with "book create enormous.pgn 60 2 50" (see the crafty
+documentation and online help for a more thorough explanation of what
+this does)
+
+// Jonathan Shoemaker <shoemaker@bluebottle.com>
diff --git a/games/crafty-open-enormous/pkg-plist b/games/crafty-open-enormous/pkg-plist
new file mode 100644
index 000000000000..f0e71da92a6a
--- /dev/null
+++ b/games/crafty-open-enormous/pkg-plist
@@ -0,0 +1,2 @@
+lib/crafty/book.bin
+@dirrm lib/crafty