aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2006-01-15 04:38:18 +0800
committerSergey Matveychuk <sem@FreeBSD.org>2006-01-15 04:38:18 +0800
commit43e448da34bd27802a32f6fde00ac824bca0d353 (patch)
tree41cf1361037e1eb6aa3a3279c0f58ccf3cfa49a9 /graphics
parenteb340132974990634a152877801a3e636fea7973 (diff)
downloadfreebsd-ports-43e448da34bd27802a32f6fde00ac824bca0d353.tar.gz
freebsd-ports-43e448da34bd27802a32f6fde00ac824bca0d353.tar.zst
freebsd-ports-43e448da34bd27802a32f6fde00ac824bca0d353.zip
Gnash is a GNU Flash movie player. Till now it has been possible
to play flash movies with proprietary software. While there are a few free flash players, none supports anything higher than SWF v4 at best. Gnash is based on GameSWF, and supports many SWF v7 features. WWW: http://www.gnu.org/software/gnash/ PR: ports/91775 Submitted by: Dmitry Marakasov <amdmi3@mail.ru>
Notes
Notes: svn path=/head/; revision=153499
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/gnash-devel/Makefile105
-rw-r--r--graphics/gnash-devel/distinfo3
-rw-r--r--graphics/gnash-devel/pkg-descr22
-rw-r--r--graphics/gnash-devel/pkg-plist26
-rw-r--r--graphics/gnash/Makefile105
-rw-r--r--graphics/gnash/distinfo3
-rw-r--r--graphics/gnash/pkg-descr22
-rw-r--r--graphics/gnash/pkg-plist26
9 files changed, 313 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index e5712ee0cb68..ddaffe2fb1cc 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -171,6 +171,7 @@
SUBDIR += gltk
SUBDIR += gltt
SUBDIR += gmt
+ SUBDIR += gnash
SUBDIR += gnofract4d
SUBDIR += gnome-colorscheme
SUBDIR += gnomecanvas
diff --git a/graphics/gnash-devel/Makefile b/graphics/gnash-devel/Makefile
new file mode 100644
index 000000000000..9606503ae0e6
--- /dev/null
+++ b/graphics/gnash-devel/Makefile
@@ -0,0 +1,105 @@
+# New ports collection makefile for: gnash
+# Date created: 12 Jan 2006
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnash
+PORTVERSION= 0.7
+CATEGORIES= graphics
+MASTER_SITES= http://www.gnu.org/software/gnash/releases/
+DISTNAME= ${PORTNAME}-20051226
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= GNU Flash movie player
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
+ jpeg.9:${PORTSDIR}/graphics/jpeg
+
+USE_X_PREFIX= yes
+USE_GNOME= gnomehier
+USE_SDL= sdl mixer
+USE_BZIP2= yes
+USE_GL= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+#INSTALLS_OMF= yes
+USE_GCC= 3.4+
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-0.7
+
+CPPFLAGS= `${SDL_CONFIG} --cflags` -I${X11BASE}/include
+LDFLAGS= `${SDL_CONFIG} --libs` -L${X11BASE}/lib -Wl,--rpath,${PREFIX}/lib/gnash
+
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= --program-prefix=''
+
+INSTALLS_SHLIB= yes
+LDCONFIG_DIRS= %%PREFIX%%/lib %%PREFIX%%/lib/gnash
+
+MAN1= gnash.1
+
+# As the project was just recently announced, firefox plugin doesn't work
+# correctly yet. You can still try it with specifying WITH_FIREFOX=yes as
+# make parameter - feel free to mail reports (preferrably of success) and
+# your ideas to port maintainer.
+# See also http://lists.gnu.org/archive/html/gnash/
+
+OPTIONS= XML "Enable support for xml and xmlsocket" off
+# FIREFOX "Build firefox plugin" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_FIREFOX)
+BUILD_DEPENDS+= ${X11BASE}/bin/firefox-config:${PORTSDIR}/www/firefox
+CONFIGURE_ARGS+= --enable-plugin
+CPPFLAGS+= `firefox-config --cflags`
+LDFLAGS+= `firefox-config --libs`
+PLIST_SUB= PLUGIN:=""
+.else
+PLIST_SUB= PLUGIN:="@comment "
+.endif
+
+.if defined(WITH_XML)
+BUILD_DEPENDS+= ${LOCALBASE}/bin/xml2-config:${PORTSDIR}/textproc/libxml2
+CPPFLAGS+= `xml2-config --cflags`
+LDFLAGS+= `xml2-config --libs`
+.else
+CONFIGURE_ARGS+= --disable-xml
+.endif
+
+post-extract:
+ @${FIND} ${WRKSRC} -name "*.cpp" -o -name "*.h" | \
+ ${XARGS} ${REINPLACE_CMD} -e "s|$$(${PRINTF} '\r')||g"
+
+post-patch:
+ @${REINPLACE_CMD} -e '/INCLUDES/ s|$$(srcdir)||' ${WRKSRC}/libgeometry/Makefile.in ${WRKSRC}/libbase/Makefile.in
+ @${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/libbase/dlmalloc.c ${WRKSRC}/libbase/dlmalloc.h
+ @${REINPLACE_CMD} -e '/APPLE_CC/ s|^.*$$|#if 0|' ${WRKSRC}/libbase/utility.cpp
+ @${REINPLACE_CMD} -e '/cd doc/ s|^.*$$| @true|; /DIRS/ s/ doc//' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '/^include_HEADERS/ s|^|#|' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '/FIREFOX_PLUGINS=.*FIREFOX_LIBS/ s|^.*$$|FIREFOX_PLUGINS=${X11BASE}/lib/browser_plugins|' ${WRKSRC}/configure
+.if !defined(WITH_FIREFOX)
+ @${REINPLACE_CMD} -e 's|firefox-config|firefox-config1|g' ${WRKSRC}/configure
+.endif
+
+.if defined(WITH_FIREFOX)
+pre-install:
+ ${MKDIR} ${PREFIX}/lib/browser_plugins
+.endif
+
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/doc/C/gnash.1 ${PREFIX}/man/man1
+ ${MKDIR} ${PREFIX}/share/gnome/omf/gnash
+ ${INSTALL_DATA} ${WRKSRC}/doc/C/gnash.omf ${PREFIX}/share/gnome/omf/gnash
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}/images
+.for i in gnash.html gnash.pdf gnash.xml legal.xml
+ ${INSTALL_DATA} ${WRKSRC}/doc/C/${i} ${DOCSDIR}
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/doc/C/images/* ${DOCSDIR}/images
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/gnash-devel/distinfo b/graphics/gnash-devel/distinfo
new file mode 100644
index 000000000000..92645f83de1f
--- /dev/null
+++ b/graphics/gnash-devel/distinfo
@@ -0,0 +1,3 @@
+MD5 (gnash-20051226.tar.bz2) = 16d3261d0ec22be7cc738e30b42dc9ac
+SHA256 (gnash-20051226.tar.bz2) = 49a1e958d1cf62e8cda1605abeb61b7924f3f0bb5978f78ff08d657243263350
+SIZE (gnash-20051226.tar.bz2) = 742001
diff --git a/graphics/gnash-devel/pkg-descr b/graphics/gnash-devel/pkg-descr
new file mode 100644
index 000000000000..a381f09fd134
--- /dev/null
+++ b/graphics/gnash-devel/pkg-descr
@@ -0,0 +1,22 @@
+Gnash is a GNU Flash movie player. Till now it has been possible
+to play flash movies with proprietary software. While there are a
+few free flash players, none supports anything higher than SWF v4
+at best. Gnash is based on GameSWF, and supports many SWF v7 features.
+
+Features:
+- Runs standalone
+ Gnash can run standalone to play flash movies.
+- Firefox plugin
+ Gnash can also run as a plugin from within Firefox.
+- SWF v7 compliant
+ Gnash can play many current flash movies.
+- XML Message server
+ Gnash also supports an XML based message system as is documented
+ in the Flash Format specification.
+- High Quality Output
+ Gnash uses OpenGL for rendering the graphics.
+- Free Software
+ Gnash is 100% free software. For more information on the GPL, go
+ to the Free Software Foundation web site.
+
+WWW: http://www.gnu.org/software/gnash/
diff --git a/graphics/gnash-devel/pkg-plist b/graphics/gnash-devel/pkg-plist
new file mode 100644
index 000000000000..bc462a826d0c
--- /dev/null
+++ b/graphics/gnash-devel/pkg-plist
@@ -0,0 +1,26 @@
+bin/gnash
+bin/gparser
+bin/gprocessor
+lib/gnash/libbase.a
+lib/gnash/libbase.la
+lib/gnash/libbase.so
+lib/gnash/libbase.so.0
+lib/gnash/libgeometry.a
+lib/gnash/libgeometry.la
+lib/gnash/libgeometry.so
+lib/gnash/libgeometry.so.0
+lib/gnash/libserver.a
+lib/gnash/libserver.la
+lib/gnash/libserver.so
+lib/gnash/libserver.so.0
+%%PLUGIN:%%lib/browser_plugins/libgnash.so
+share/gnome/omf/gnash/gnash.omf
+%%PORTDOCS%%%%DOCSDIR%%/gnash.html
+%%PORTDOCS%%%%DOCSDIR%%/gnash.pdf
+%%PORTDOCS%%%%DOCSDIR%%/gnash.xml
+%%PORTDOCS%%%%DOCSDIR%%/legal.xml
+%%PORTDOCS%%%%DOCSDIR%%/images/car_crash.png
+@dirrm lib/gnash
+@dirrm share/gnome/omf/gnash
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/images
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
diff --git a/graphics/gnash/Makefile b/graphics/gnash/Makefile
new file mode 100644
index 000000000000..9606503ae0e6
--- /dev/null
+++ b/graphics/gnash/Makefile
@@ -0,0 +1,105 @@
+# New ports collection makefile for: gnash
+# Date created: 12 Jan 2006
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnash
+PORTVERSION= 0.7
+CATEGORIES= graphics
+MASTER_SITES= http://www.gnu.org/software/gnash/releases/
+DISTNAME= ${PORTNAME}-20051226
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= GNU Flash movie player
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
+ jpeg.9:${PORTSDIR}/graphics/jpeg
+
+USE_X_PREFIX= yes
+USE_GNOME= gnomehier
+USE_SDL= sdl mixer
+USE_BZIP2= yes
+USE_GL= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+#INSTALLS_OMF= yes
+USE_GCC= 3.4+
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-0.7
+
+CPPFLAGS= `${SDL_CONFIG} --cflags` -I${X11BASE}/include
+LDFLAGS= `${SDL_CONFIG} --libs` -L${X11BASE}/lib -Wl,--rpath,${PREFIX}/lib/gnash
+
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= --program-prefix=''
+
+INSTALLS_SHLIB= yes
+LDCONFIG_DIRS= %%PREFIX%%/lib %%PREFIX%%/lib/gnash
+
+MAN1= gnash.1
+
+# As the project was just recently announced, firefox plugin doesn't work
+# correctly yet. You can still try it with specifying WITH_FIREFOX=yes as
+# make parameter - feel free to mail reports (preferrably of success) and
+# your ideas to port maintainer.
+# See also http://lists.gnu.org/archive/html/gnash/
+
+OPTIONS= XML "Enable support for xml and xmlsocket" off
+# FIREFOX "Build firefox plugin" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_FIREFOX)
+BUILD_DEPENDS+= ${X11BASE}/bin/firefox-config:${PORTSDIR}/www/firefox
+CONFIGURE_ARGS+= --enable-plugin
+CPPFLAGS+= `firefox-config --cflags`
+LDFLAGS+= `firefox-config --libs`
+PLIST_SUB= PLUGIN:=""
+.else
+PLIST_SUB= PLUGIN:="@comment "
+.endif
+
+.if defined(WITH_XML)
+BUILD_DEPENDS+= ${LOCALBASE}/bin/xml2-config:${PORTSDIR}/textproc/libxml2
+CPPFLAGS+= `xml2-config --cflags`
+LDFLAGS+= `xml2-config --libs`
+.else
+CONFIGURE_ARGS+= --disable-xml
+.endif
+
+post-extract:
+ @${FIND} ${WRKSRC} -name "*.cpp" -o -name "*.h" | \
+ ${XARGS} ${REINPLACE_CMD} -e "s|$$(${PRINTF} '\r')||g"
+
+post-patch:
+ @${REINPLACE_CMD} -e '/INCLUDES/ s|$$(srcdir)||' ${WRKSRC}/libgeometry/Makefile.in ${WRKSRC}/libbase/Makefile.in
+ @${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/libbase/dlmalloc.c ${WRKSRC}/libbase/dlmalloc.h
+ @${REINPLACE_CMD} -e '/APPLE_CC/ s|^.*$$|#if 0|' ${WRKSRC}/libbase/utility.cpp
+ @${REINPLACE_CMD} -e '/cd doc/ s|^.*$$| @true|; /DIRS/ s/ doc//' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '/^include_HEADERS/ s|^|#|' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '/FIREFOX_PLUGINS=.*FIREFOX_LIBS/ s|^.*$$|FIREFOX_PLUGINS=${X11BASE}/lib/browser_plugins|' ${WRKSRC}/configure
+.if !defined(WITH_FIREFOX)
+ @${REINPLACE_CMD} -e 's|firefox-config|firefox-config1|g' ${WRKSRC}/configure
+.endif
+
+.if defined(WITH_FIREFOX)
+pre-install:
+ ${MKDIR} ${PREFIX}/lib/browser_plugins
+.endif
+
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/doc/C/gnash.1 ${PREFIX}/man/man1
+ ${MKDIR} ${PREFIX}/share/gnome/omf/gnash
+ ${INSTALL_DATA} ${WRKSRC}/doc/C/gnash.omf ${PREFIX}/share/gnome/omf/gnash
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}/images
+.for i in gnash.html gnash.pdf gnash.xml legal.xml
+ ${INSTALL_DATA} ${WRKSRC}/doc/C/${i} ${DOCSDIR}
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/doc/C/images/* ${DOCSDIR}/images
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/gnash/distinfo b/graphics/gnash/distinfo
new file mode 100644
index 000000000000..92645f83de1f
--- /dev/null
+++ b/graphics/gnash/distinfo
@@ -0,0 +1,3 @@
+MD5 (gnash-20051226.tar.bz2) = 16d3261d0ec22be7cc738e30b42dc9ac
+SHA256 (gnash-20051226.tar.bz2) = 49a1e958d1cf62e8cda1605abeb61b7924f3f0bb5978f78ff08d657243263350
+SIZE (gnash-20051226.tar.bz2) = 742001
diff --git a/graphics/gnash/pkg-descr b/graphics/gnash/pkg-descr
new file mode 100644
index 000000000000..a381f09fd134
--- /dev/null
+++ b/graphics/gnash/pkg-descr
@@ -0,0 +1,22 @@
+Gnash is a GNU Flash movie player. Till now it has been possible
+to play flash movies with proprietary software. While there are a
+few free flash players, none supports anything higher than SWF v4
+at best. Gnash is based on GameSWF, and supports many SWF v7 features.
+
+Features:
+- Runs standalone
+ Gnash can run standalone to play flash movies.
+- Firefox plugin
+ Gnash can also run as a plugin from within Firefox.
+- SWF v7 compliant
+ Gnash can play many current flash movies.
+- XML Message server
+ Gnash also supports an XML based message system as is documented
+ in the Flash Format specification.
+- High Quality Output
+ Gnash uses OpenGL for rendering the graphics.
+- Free Software
+ Gnash is 100% free software. For more information on the GPL, go
+ to the Free Software Foundation web site.
+
+WWW: http://www.gnu.org/software/gnash/
diff --git a/graphics/gnash/pkg-plist b/graphics/gnash/pkg-plist
new file mode 100644
index 000000000000..bc462a826d0c
--- /dev/null
+++ b/graphics/gnash/pkg-plist
@@ -0,0 +1,26 @@
+bin/gnash
+bin/gparser
+bin/gprocessor
+lib/gnash/libbase.a
+lib/gnash/libbase.la
+lib/gnash/libbase.so
+lib/gnash/libbase.so.0
+lib/gnash/libgeometry.a
+lib/gnash/libgeometry.la
+lib/gnash/libgeometry.so
+lib/gnash/libgeometry.so.0
+lib/gnash/libserver.a
+lib/gnash/libserver.la
+lib/gnash/libserver.so
+lib/gnash/libserver.so.0
+%%PLUGIN:%%lib/browser_plugins/libgnash.so
+share/gnome/omf/gnash/gnash.omf
+%%PORTDOCS%%%%DOCSDIR%%/gnash.html
+%%PORTDOCS%%%%DOCSDIR%%/gnash.pdf
+%%PORTDOCS%%%%DOCSDIR%%/gnash.xml
+%%PORTDOCS%%%%DOCSDIR%%/legal.xml
+%%PORTDOCS%%%%DOCSDIR%%/images/car_crash.png
+@dirrm lib/gnash
+@dirrm share/gnome/omf/gnash
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/images
+%%PORTDOCS%%@dirrm %%DOCSDIR%%