aboutsummaryrefslogtreecommitdiffstats
path: root/lang/clips
diff options
context:
space:
mode:
authorvd <vd@FreeBSD.org>2006-12-19 16:50:06 +0800
committervd <vd@FreeBSD.org>2006-12-19 16:50:06 +0800
commit2a15b03708801885d2b73240deeac42543f06256 (patch)
tree6fd74a4b72a2f78fd24cd9520fae451526069784 /lang/clips
parent1f9ff3a38f788eb4c4eed84ee5d779c56f8757b4 (diff)
downloadfreebsd-ports-2a15b03708801885d2b73240deeac42543f06256.tar.gz
freebsd-ports-2a15b03708801885d2b73240deeac42543f06256.tar.zst
freebsd-ports-2a15b03708801885d2b73240deeac42543f06256.zip
Resurrect lang/clips and update it to 6.24
Diffstat (limited to 'lang/clips')
-rw-r--r--lang/clips/Makefile37
-rw-r--r--lang/clips/distinfo6
-rw-r--r--lang/clips/pkg-descr9
3 files changed, 52 insertions, 0 deletions
diff --git a/lang/clips/Makefile b/lang/clips/Makefile
new file mode 100644
index 000000000000..9773fd1c0d62
--- /dev/null
+++ b/lang/clips/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: clips
+# Date created: 8 July 2001
+# Whom: Douglas Anestad <yotta@dougdidit.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= clips
+PORTVERSION= 6.24
+CATEGORIES= lang
+MASTER_SITES= http://www.ghg.net/clips/download/source/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= vd/${PORTNAME}
+DISTFILES= clipssrc.tar.Z ${MAKEFILE}
+DIST_SUBDIR= clips-${PORTVERSION}
+EXTRACT_ONLY= ${DISTFILES:M*.tar.*}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A productive development and delivery expert system tool
+
+WRKSRC= ${WRKDIR}/${PORTNAME}src/${PORTNAME}src
+
+MAKEFILE= makefile.gcc
+ALL_TARGET= clips
+
+PLIST_FILES= bin/clips
+
+post-extract:
+ ${CP} ${DISTDIR}/${DIST_SUBDIR}/${MAKEFILE} ${WRKSRC}/
+
+do-patch:
+ ${REINPLACE_CMD} -e 's/gcc /${CC} ${CFLAGS} /g' ${WRKSRC}/${MAKEFILE}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/clips ${PREFIX}/bin/
+
+.include <bsd.port.mk>
diff --git a/lang/clips/distinfo b/lang/clips/distinfo
new file mode 100644
index 000000000000..efe2ff61961a
--- /dev/null
+++ b/lang/clips/distinfo
@@ -0,0 +1,6 @@
+MD5 (clips-6.24/clipssrc.tar.Z) = ccba9d912375e57a1b7d9eba12da4198
+SHA256 (clips-6.24/clipssrc.tar.Z) = 80852a0df97597f710e90ca8bf5ecdc250c2034bf9dd3044bbedee111ad2e4ab
+SIZE (clips-6.24/clipssrc.tar.Z) = 1524143
+MD5 (clips-6.24/makefile.gcc) = 3b74fa0bdda8786574b198ae8cf9748a
+SHA256 (clips-6.24/makefile.gcc) = 062990ec16df6c983929711acba0f7ce284c4c8f2b6e527bcfc1794110284e03
+SIZE (clips-6.24/makefile.gcc) = 71566
diff --git a/lang/clips/pkg-descr b/lang/clips/pkg-descr
new file mode 100644
index 000000000000..e766e43cf4ed
--- /dev/null
+++ b/lang/clips/pkg-descr
@@ -0,0 +1,9 @@
+CLIPS is a productive development and delivery expert system tool which
+provides a complete environment for the construction of rule and/or object
+based expert systems.
+
+CLIPS is being used by numerous users throughout the public and private
+community including: all NASA sites and branches of the military, numerous
+federal bureaus, government contractors, universities, and many companies.
+
+WWW: http://www.ghg.net/clips/CLIPS.html