aboutsummaryrefslogtreecommitdiffstats
path: root/lang/xotcl
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2006-11-27 10:30:32 +0800
committerrafan <rafan@FreeBSD.org>2006-11-27 10:30:32 +0800
commit4aa53ec611bc0469aacddfb48b1a4fefc25ffabe (patch)
tree4ff43127947bfb9b4f6c7a83dd52c7190943a8fe /lang/xotcl
parentcf2221c824fedf597f3065e0b7395abf236c41c1 (diff)
downloadfreebsd-ports-4aa53ec611bc0469aacddfb48b1a4fefc25ffabe.tar.gz
freebsd-ports-4aa53ec611bc0469aacddfb48b1a4fefc25ffabe.tar.zst
freebsd-ports-4aa53ec611bc0469aacddfb48b1a4fefc25ffabe.zip
- Update to 1.5.3
- Add THREADS option for threading support PR: ports/105867 Submitted by: Martin Matuska <martin at matuska.org> (maintainer)
Diffstat (limited to 'lang/xotcl')
-rw-r--r--lang/xotcl/Makefile11
-rw-r--r--lang/xotcl/distinfo6
-rw-r--r--lang/xotcl/pkg-plist1
3 files changed, 14 insertions, 4 deletions
diff --git a/lang/xotcl/Makefile b/lang/xotcl/Makefile
index 7d954feec393..1a7cedda75d1 100644
--- a/lang/xotcl/Makefile
+++ b/lang/xotcl/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xotcl
-PORTVERSION= 1.5.2
+PORTVERSION= 1.5.3
CATEGORIES= lang tcl83 tcl84
MASTER_SITES= http://media.wu-wien.ac.at/download/
@@ -23,6 +23,7 @@ USE_GMAKE= yes
PLIST_SUB+= PORTVERSION=${PORTVERSION}
OPTIONS= AOLSERVER "AOL server module" off \
+ THREADS "Force threaded build" off \
TUTORIAL "Install XOTcl tutorial" off
CONFIGURE_ARGS+= --exec-prefix=${PREFIX} \
@@ -48,6 +49,14 @@ PLIST_SUB+= TUTORIAL=""
PLIST_SUB+= TUTORIAL="@comment "
.endif
+.if defined(WITH_THREADS)
+TCL_THREADED!= ${ECHO_EMD} 'puts [array names tcl_platform -exact threaded]' | ${TCLSH}
+.if empty(TCL_THREADED)
+IGNORE= WITH_THREADS option is selected. You need Tcl with threads to use this port. Please install Tcl with WITH_THREADS defined or from lang/tcl84-thread port and try again.
+.endif
+CONFIGURE_ARGS+= --enable-threads
+.endif
+
INSTALL_TARGET+= install-shells
.if !defined(NO_INSTALL_MANPAGES)
MAN1= xotclsh.1
diff --git a/lang/xotcl/distinfo b/lang/xotcl/distinfo
index 12320dbef467..d06dbdf3857b 100644
--- a/lang/xotcl/distinfo
+++ b/lang/xotcl/distinfo
@@ -1,3 +1,3 @@
-MD5 (xotcl-1.5.2.tar.gz) = c08ec454d140a305d5b8951e3328769e
-SHA256 (xotcl-1.5.2.tar.gz) = 0d5df219e2ee927ef60722d6a2488ee75b7453eee6a2100615a237266b813b0e
-SIZE (xotcl-1.5.2.tar.gz) = 1845603
+MD5 (xotcl-1.5.3.tar.gz) = ed246596550812375ff4461c07b89bcb
+SHA256 (xotcl-1.5.3.tar.gz) = f2393a1a3dc81509215a5ab1548b063a1dd60423a331eae3c106b0a38b85f4ae
+SIZE (xotcl-1.5.3.tar.gz) = 1961146
diff --git a/lang/xotcl/pkg-plist b/lang/xotcl/pkg-plist
index 44e5d5e89982..a418f8beb63d 100644
--- a/lang/xotcl/pkg-plist
+++ b/lang/xotcl/pkg-plist
@@ -96,6 +96,7 @@ lib/xotcl%%PORTVERSION%%/xotclConfig.sh
%%PORTDOCS%%%%DOCSDIR%%/announces/Announce-1.5.0
%%PORTDOCS%%%%DOCSDIR%%/announces/Announce-1.5.1
%%PORTDOCS%%%%DOCSDIR%%/announces/Announce-1.5.2
+%%PORTDOCS%%%%DOCSDIR%%/announces/Announce-1.5.3
%%TUTORIAL%%%%EXAMPLESDIR%%/tutorial/html/JufGdbmStorage-xotcl.html
%%TUTORIAL%%%%EXAMPLESDIR%%/tutorial/html/MemStorage-xotcl.html
%%TUTORIAL%%%%EXAMPLESDIR%%/tutorial/html/MultiStorage-xotcl.html