aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2002-07-15 16:56:26 +0800
committerJimmy Olgeni <olgeni@FreeBSD.org>2002-07-15 16:56:26 +0800
commit79d87c64affaed284bb34b5fce11f59219b66ca8 (patch)
tree3508d17195fda01540e8b0a41f5e2695b89cab1e /lang
parent41626c642a56ef5c65ab5b6bd8101afc4f5d7def (diff)
downloadfreebsd-ports-79d87c64affaed284bb34b5fce11f59219b66ca8.tar.gz
freebsd-ports-79d87c64affaed284bb34b5fce11f59219b66ca8.tar.zst
freebsd-ports-79d87c64affaed284bb34b5fce11f59219b66ca8.zip
chown lib/erlang to root:wheel with proper permissions, do not use bogus
uids from the documentation tarball.
Notes
Notes: svn path=/head/; revision=62966
Diffstat (limited to 'lang')
-rw-r--r--lang/erlang/Makefile2
-rw-r--r--lang/erlang14/Makefile2
2 files changed, 4 insertions, 0 deletions
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index ad9f8877fbb4..58e085c867f0 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -102,6 +102,8 @@ post-install:
@${TAR} --unlink -xzpf ${DISTDIR}/${DIST_SUBDIR}/${ERLANG_DOCS} \
-C ${PREFIX}/lib/erlang
.endif
+ @${CHOWN} -R root:wheel ${PREFIX}/lib/erlang
+ @${CHMOD} -R o+rX-w,g+rX-w ${PREFIX}/lib/erlang
@sslapp=`ls -d ${PREFIX}/lib/erlang/lib/ssl-* | tail -1`; \
cd $$sslapp/priv/obj && ${MAKE} && strip ../bin/ssl_esock
@cd ${PREFIX} ; find lib/erlang/* -type f -o -type l \
diff --git a/lang/erlang14/Makefile b/lang/erlang14/Makefile
index ad9f8877fbb4..58e085c867f0 100644
--- a/lang/erlang14/Makefile
+++ b/lang/erlang14/Makefile
@@ -102,6 +102,8 @@ post-install:
@${TAR} --unlink -xzpf ${DISTDIR}/${DIST_SUBDIR}/${ERLANG_DOCS} \
-C ${PREFIX}/lib/erlang
.endif
+ @${CHOWN} -R root:wheel ${PREFIX}/lib/erlang
+ @${CHMOD} -R o+rX-w,g+rX-w ${PREFIX}/lib/erlang
@sslapp=`ls -d ${PREFIX}/lib/erlang/lib/ssl-* | tail -1`; \
cd $$sslapp/priv/obj && ${MAKE} && strip ../bin/ssl_esock
@cd ${PREFIX} ; find lib/erlang/* -type f -o -type l \