aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2009-07-31 01:14:53 +0800
committerjohans <johans@FreeBSD.org>2009-07-31 01:14:53 +0800
commit817e3f4c902a3bcc17fc8d1468d257cb818bd8b1 (patch)
treefa97c3c28421e733bc70c2c6da49f4402dc1c2ff /lang
parent54987c867f152f053144455d5b1fc04fe865f46f (diff)
downloadfreebsd-ports-817e3f4c902a3bcc17fc8d1468d257cb818bd8b1.tar.gz
freebsd-ports-817e3f4c902a3bcc17fc8d1468d257cb818bd8b1.tar.zst
freebsd-ports-817e3f4c902a3bcc17fc8d1468d257cb818bd8b1.zip
Update to 1.9.0
Diffstat (limited to 'lang')
-rw-r--r--lang/afnix/Makefile6
-rw-r--r--lang/afnix/distinfo6
-rw-r--r--lang/afnix/files/patch-cnf_mak_afnix-freebsd.mak10
-rw-r--r--lang/afnix/pkg-plist21
4 files changed, 27 insertions, 16 deletions
diff --git a/lang/afnix/Makefile b/lang/afnix/Makefile
index 334732cc5fb1..1055885da168 100644
--- a/lang/afnix/Makefile
+++ b/lang/afnix/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= afnix
-PORTVERSION= 1.8.0
+PORTVERSION= 1.9.0
CATEGORIES= lang
MASTER_SITES= http://www.afnix.org/ftp/ \
ftp://ftp.stack.nl/pub/users/johans/afnix/
@@ -31,7 +31,7 @@ PORTDOCS= *
AFNIX_VERSION= ${PORTVERSION:S,.,-,g}
PLIST_SUB= PORTVER=${PORTVERSION:R}
-MAN1= adp::afnix.1 amd::afnix.1 axc::afnix.1 axd::afnix.1 \
+MAN1= adp::afnix.1 axc::afnix.1 axd::afnix.1 \
axi::afnix.1 axl::afnix.1 axs::afnix.1
MAN3= gfx::afnix.3 mth::afnix.3 net::afnix.3 nwg::afnix.3 \
pim::afnix.3 sec::afnix.3 sio::afnix.3 sps::afnix.3 \
@@ -64,7 +64,7 @@ post-install:
${MANPREFIX}/man/man${i:E}/
. endfor
.else
- @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} instdoc
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} publish
.endif
.include <bsd.port.post.mk>
diff --git a/lang/afnix/distinfo b/lang/afnix/distinfo
index 2f58672f6b70..e7407f992e4d 100644
--- a/lang/afnix/distinfo
+++ b/lang/afnix/distinfo
@@ -1,3 +1,3 @@
-MD5 (afnix-src-1-8-0.tgz) = 87a74175c1f535bf20e715049ff31a13
-SHA256 (afnix-src-1-8-0.tgz) = 6abe464e0eba132a6924e0bcc2a781a06afda67a10cff9332fe719ad5dbd5a34
-SIZE (afnix-src-1-8-0.tgz) = 1692178
+MD5 (afnix-src-1-9-0.tgz) = f20c6399fa66715889248302624edc59
+SHA256 (afnix-src-1-9-0.tgz) = c65eb6ef773b23bedc28be84f473eeba713f0935df3f9ec814cae9660c010acb
+SIZE (afnix-src-1-9-0.tgz) = 1741827
diff --git a/lang/afnix/files/patch-cnf_mak_afnix-freebsd.mak b/lang/afnix/files/patch-cnf_mak_afnix-freebsd.mak
index 5fb849a9f42f..d8d7864e7667 100644
--- a/lang/afnix/files/patch-cnf_mak_afnix-freebsd.mak
+++ b/lang/afnix/files/patch-cnf_mak_afnix-freebsd.mak
@@ -1,5 +1,5 @@
---- cnf/mak/afnix-freebsd.mak.orig Sat May 26 23:59:55 2007
-+++ cnf/mak/afnix-freebsd.mak Sun May 27 00:00:45 2007
+--- cnf/mak/afnix-freebsd.mak.orig 2009-07-30 15:29:26.000000000 +0200
++++ cnf/mak/afnix-freebsd.mak 2009-07-30 15:30:41.000000000 +0200
@@ -18,21 +18,21 @@
# - compiler and linker section -
# ----------------------------------------------------------------------------
@@ -28,7 +28,7 @@
DBGDEFINES = -DDEBUG
OPTDEFINES =
STDINCLUDE =
-@@ -75,14 +75,11 @@
+@@ -75,14 +75,11 @@ endif
# adjust for freebsd platform
ifeq ($(PLATNAME),freebsd)
@@ -40,12 +40,12 @@
LDFLAGS = -shared
AFXCPPLIBS =
-ifeq ($(LKMODE),soname)
--LDFLAGS += -Wl,-soname,$(SONAME)
+-LDFLAGS += -Wl,-soname,$(SOMIN)
-endif
endif
# adjust for gnu/freebsd platform
-@@ -102,7 +99,7 @@
+@@ -102,7 +99,7 @@ LKFLAGS =
# adjust linker flags for freebsd
ifeq ($(PLATNAME),freebsd)
diff --git a/lang/afnix/pkg-plist b/lang/afnix/pkg-plist
index f1716666824c..25670ba737c2 100644
--- a/lang/afnix/pkg-plist
+++ b/lang/afnix/pkg-plist
@@ -10,6 +10,7 @@ include/afnix/eng/Builtin.hpp
include/afnix/eng/Class.hpp
include/afnix/eng/Closure.hpp
include/afnix/eng/Constant.hpp
+include/afnix/eng/Counter.hpp
include/afnix/eng/Enum.hpp
include/afnix/eng/Extracter.hpp
include/afnix/eng/Form.hpp
@@ -63,6 +64,7 @@ include/afnix/nwg/Cookie.hpp
include/afnix/nwg/HttpProto.hpp
include/afnix/nwg/HttpRequest.hpp
include/afnix/nwg/HttpResponse.hpp
+include/afnix/nwg/HttpStream.hpp
include/afnix/nwg/Libnwg.hpp
include/afnix/nwg/Mime.hpp
include/afnix/nwg/NwgCalls.hpp
@@ -93,10 +95,12 @@ include/afnix/plt/cthr.hpp
include/afnix/plt/ctrm.hpp
include/afnix/plt/cucd.hpp
include/afnix/sec/Aes.hpp
+include/afnix/sec/Blkmsg.hpp
include/afnix/sec/BlockCipher.hpp
include/afnix/sec/Cipher.hpp
include/afnix/sec/Crypto.hpp
include/afnix/sec/Des.hpp
+include/afnix/sec/Dsa.hpp
include/afnix/sec/Hasher.hpp
include/afnix/sec/Hkdf.hpp
include/afnix/sec/Hmac.hpp
@@ -112,15 +116,22 @@ include/afnix/sec/Md4.hpp
include/afnix/sec/Md5.hpp
include/afnix/sec/Predsec.hpp
include/afnix/sec/PublicCipher.hpp
+include/afnix/sec/Rc2.hpp
+include/afnix/sec/Rc4.hpp
+include/afnix/sec/Rc5.hpp
include/afnix/sec/Rsa.hpp
+include/afnix/sec/SerialCipher.hpp
include/afnix/sec/Sha1.hpp
include/afnix/sec/Sha224.hpp
include/afnix/sec/Sha256.hpp
include/afnix/sec/Sha384.hpp
include/afnix/sec/Sha512.hpp
+include/afnix/sec/Signature.hpp
+include/afnix/sec/Signer.hpp
include/afnix/sio/Directory.hpp
include/afnix/sio/Libsio.hpp
include/afnix/sio/Logtee.hpp
+include/afnix/sio/NamedFifo.hpp
include/afnix/sio/Predsio.hpp
include/afnix/sio/Selector.hpp
include/afnix/sio/SioCalls.hpp
@@ -142,12 +153,14 @@ include/afnix/std/Buffer.hpp
include/afnix/std/Byte.hpp
include/afnix/std/Character.hpp
include/afnix/std/Cilo.hpp
+include/afnix/std/Combo.hpp
include/afnix/std/Condvar.hpp
include/afnix/std/Cons.hpp
include/afnix/std/Cursor.hpp
include/afnix/std/Date.hpp
include/afnix/std/Encoding.hpp
include/afnix/std/Exception.hpp
+include/afnix/std/FileInfo.hpp
include/afnix/std/Freeable.hpp
include/afnix/std/HashTable.hpp
include/afnix/std/Heap.hpp
@@ -156,10 +169,10 @@ include/afnix/std/InputBuffer.hpp
include/afnix/std/InputFile.hpp
include/afnix/std/InputMapped.hpp
include/afnix/std/InputOutput.hpp
+include/afnix/std/InputStream.hpp
include/afnix/std/InputString.hpp
include/afnix/std/InputTerm.hpp
include/afnix/std/InputTimeout.hpp
-include/afnix/std/InputStream.hpp
include/afnix/std/Integer.hpp
include/afnix/std/Item.hpp
include/afnix/std/Iterable.hpp
@@ -170,7 +183,6 @@ include/afnix/std/Literal.hpp
include/afnix/std/Loader.hpp
include/afnix/std/Lockrw.hpp
include/afnix/std/Logger.hpp
-include/afnix/std/Method.hpp
include/afnix/std/Monitor.hpp
include/afnix/std/Mutex.hpp
include/afnix/std/NameTable.hpp
@@ -203,6 +215,7 @@ include/afnix/std/Sorter.hpp
include/afnix/std/Stack.hpp
include/afnix/std/Strbuf.hpp
include/afnix/std/Stream.hpp
+include/afnix/std/Strfifo.hpp
include/afnix/std/String.hpp
include/afnix/std/Strvec.hpp
include/afnix/std/System.hpp
@@ -315,9 +328,7 @@ include/afnix/xpe/XmlInclude.hpp
include/afnix/xpe/XmlPlist.hpp
include/afnix/xpe/XmlPrintTable.hpp
include/afnix/xpe/XmlProcessor.hpp
-lib/afnix/afnix-adp.axl
-lib/afnix/afnix-amd.axl
-lib/afnix/afnix-apx.axl
+lib/afnix/afnix-std-adp.axl
lib/libafnix-eng.a
lib/libafnix-eng.so
lib/libafnix-eng.so.1