aboutsummaryrefslogtreecommitdiffstats
path: root/mail/stuphead
diff options
context:
space:
mode:
authorAlexander Langer <alex@FreeBSD.org>2001-05-09 22:30:05 +0800
committerAlexander Langer <alex@FreeBSD.org>2001-05-09 22:30:05 +0800
commit36039c0cc24c37acc932121ab78cad8daa177743 (patch)
treeac4c8347e47313526fa2df6b3c59572e0bd58342 /mail/stuphead
parent44a794052f9ceded76ce2dfda1b52fe5001cd8c9 (diff)
downloadfreebsd-ports-36039c0cc24c37acc932121ab78cad8daa177743.tar.gz
freebsd-ports-36039c0cc24c37acc932121ab78cad8daa177743.tar.zst
freebsd-ports-36039c0cc24c37acc932121ab78cad8daa177743.zip
Update to 0.5.2.
PR: 28085 Submitted by: Sergey A. Osokin <osa@freebsd.org.ru>
Notes
Notes: svn path=/head/; revision=42456
Diffstat (limited to 'mail/stuphead')
-rw-r--r--mail/stuphead/Makefile39
-rw-r--r--mail/stuphead/distinfo3
-rw-r--r--mail/stuphead/files/patch-Makefile.in17
-rw-r--r--mail/stuphead/files/patch-src::main.h14
-rw-r--r--mail/stuphead/files/patch-src::stuphead11
-rw-r--r--mail/stuphead/pkg-descr4
-rw-r--r--mail/stuphead/pkg-plist3
7 files changed, 85 insertions, 6 deletions
diff --git a/mail/stuphead/Makefile b/mail/stuphead/Makefile
index 12a1ff1406aa..0674452ec7dc 100644
--- a/mail/stuphead/Makefile
+++ b/mail/stuphead/Makefile
@@ -6,21 +6,54 @@
#
PORTNAME= stuphead
-PORTVERSION= 0.4.9
-PORTREVISION= 1
+PORTVERSION= 0.5.2
CATEGORIES= mail gnome
MASTER_SITES= http://stuphead.antex.ru/
+PATCH_SITES= ${MASTER_SITES}
+PATCHFILES= ${PORTNAME}-${PORTVERSION}.patch
+
MAINTAINER= ozz@FreeBSD.org.ru
+LIB_DEPENDS= iconv.2:${PORTSDIR}/converters/iconv
+
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= yes
+USE_GTK= yes
USE_LIBTOOL= yes
+CONFIGURE_ARGS= --enable-threads \
+ --prefix=${PREFIX}
+
+.if defined (WITH_PIXBUF)
+LIB_DEPENDS+= gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
+.else
+CONFIGURE_ARGS+= --disable-gdk-pixbuf \
+ --disable-gdk_pixbuftest
+.endif
+
+.if defined (WITH_GNOME)
+USE_GNOME= yes
+CONFIGURE_ARGS+= --enable-gnome
+.else
+CONFIGURE_ARGS+= --disable-imlib \
+ --disable-imlibtest
+.endif
+
+.if defined (WITH_MOZILLA)
+CONFIGURE_ARGS+= --enable-mozilla
+BUILD_DEPENDS+= ${PREFIX}/include/mozilla/gtkmozembed.h:${PORTSDIR}/www/mozilla-headers
+RUN_DEPENDS+= ${PREFIX}/bin/mozilla:${PORTSDIR}/www/mozilla
+.endif
+
+.if defined (WITH_ISPELL)
+RUN_DEPENDS+= ${LOCALBASE}/bin/ispell-ru:${PORTSDIR}/russian/rus-ispell
+.endif
pre-patch:
@${PERL} -pi -e 's#DATADIRNAME=lib#DATADIRNAME=share#g' \
${WRKSRC}/configure
+ @${PERL} -pi -e 's#/usr/bin/gnome-config#$(PREFIX)/bin/gnome-config#g' \
+ ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/mail/stuphead/distinfo b/mail/stuphead/distinfo
index c134c5bbcdb9..8fe75b64c304 100644
--- a/mail/stuphead/distinfo
+++ b/mail/stuphead/distinfo
@@ -1 +1,2 @@
-MD5 (stuphead-0.4.9.tar.bz2) = e219e37acf90c462e3f1a0c63a1546f3
+MD5 (stuphead-0.5.2.tar.bz2) = 1e4024b142f10a73a08da0035867c03a
+MD5 (stuphead-0.5.2.patch) = aeb8d2ea39e7c00910ecdcb8fbc622b2
diff --git a/mail/stuphead/files/patch-Makefile.in b/mail/stuphead/files/patch-Makefile.in
new file mode 100644
index 000000000000..0b0152d55226
--- /dev/null
+++ b/mail/stuphead/files/patch-Makefile.in
@@ -0,0 +1,17 @@
+--- Makefile.in.orig Fri May 4 19:56:35 2001
++++ Makefile.in Fri May 4 19:57:01 2001
+@@ -424,11 +424,11 @@
+ -rm -rf $(distdir)
+
+ install-data-local:
+- @INSTALL@ -d -m755 $(GNOME_DATADIR)/gnome/apps/Internet
+- @INSTALL@ -m644 stuphead.desktop $(GNOME_DATADIR)/gnome/apps/Internet
++ @INSTALL@ -d -m755 $(GNOME_DATADIR)/apps/Internet
++ @INSTALL@ -m644 stuphead.desktop $(GNOME_DATADIR)/apps/Internet
+
+ uninstall-local:
+- rm -f $(GNOME_DATADIR)/gnome/apps/Internet/stuphead.desktop
++ rm -f $(GNOME_DATADIR)/apps/Internet/stuphead.desktop
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/mail/stuphead/files/patch-src::main.h b/mail/stuphead/files/patch-src::main.h
new file mode 100644
index 000000000000..96c3faea8870
--- /dev/null
+++ b/mail/stuphead/files/patch-src::main.h
@@ -0,0 +1,14 @@
+--- src/main.h.orig Fri May 4 20:46:11 2001
++++ src/main.h Fri May 4 20:46:57 2001
+@@ -71,9 +71,9 @@
+ #define DEFAULT_INC_PROGRAM "inc"
+ /* #define DEFAULT_INC_PATH "/usr/bin/imget" */
+ /* #define DEFAULT_INC_PROGRAM "imget" */
+-#define DEFAULT_SPOOL_PATH "/var/spool/mail"
++#define DEFAULT_SPOOL_PATH "/var/mail"
+
+-#define DEFAULT_ISPELL_COMMAND "ispell -d russian -a"
++#define DEFAULT_ISPELL_COMMAND "ispell-ru -a"
+
+ #define BUFFSIZE 8192
+ #define MAXPATHLEN 4095
diff --git a/mail/stuphead/files/patch-src::stuphead b/mail/stuphead/files/patch-src::stuphead
new file mode 100644
index 000000000000..10edf96179c6
--- /dev/null
+++ b/mail/stuphead/files/patch-src::stuphead
@@ -0,0 +1,11 @@
+--- src/stuphead.orig Fri May 4 19:12:38 2001
++++ src/stuphead Fri May 4 19:13:57 2001
+@@ -15,6 +15,8 @@
+ MOZILLA_HOME=/usr/local/lib/mozilla
+ elif [ -f ~/mozilla/libgtkembedmoz.so ]; then
+ MOZILLA_HOME=~/mozilla
++elif [ -f /usr/X11R6/lib/mozilla/libgtkembedmoz.so ]; then
++ MOZILLA_HOME=/usr/X11R6/lib/mozilla
+ fi
+
+ LD_LIBRARY_PATH=$MOZILLA_HOME:$LD_LIBRARY_PATH
diff --git a/mail/stuphead/pkg-descr b/mail/stuphead/pkg-descr
index 43604aea3ae0..1f8b7d9da49c 100644
--- a/mail/stuphead/pkg-descr
+++ b/mail/stuphead/pkg-descr
@@ -1,4 +1,4 @@
-Russian mailer stuphead 0.4.9.
-Based on Sylpheed 0.4.1 Copyright(C) 1999,2000 Hiroyuki Yamamoto <hiro-y@kcn.ne.jp>
+Russian mailer stuphead based on Sylpheed 0.4.1
+Copyright(C) 1999,2000 Hiroyuki Yamamoto <hiro-y@kcn.ne.jp>
WWW: http://stuphead.antex.ru/
diff --git a/mail/stuphead/pkg-plist b/mail/stuphead/pkg-plist
index 94e8d4d1657b..ffb1269992b5 100644
--- a/mail/stuphead/pkg-plist
+++ b/mail/stuphead/pkg-plist
@@ -1,3 +1,6 @@
bin/stuphead
+bin/stupheadbin
share/locale/fr/LC_MESSAGES/stuphead.mo
share/locale/ru/LC_MESSAGES/stuphead.mo
+share/pixmaps/stuphead.xpm
+share/gnome/apps/Internet/stuphead.desktop