aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-10-26 21:14:24 +0800
committerKirill Ponomarev <krion@FreeBSD.org>2003-10-26 21:14:24 +0800
commitb44976b8da76aee6a10d2a4dd6513ffaf247da5d (patch)
tree8837a33438a4b8e30861d8d0a6e6922f60868687 /mail
parentda496f49110f2fbc029d74f016593d34b08b5e76 (diff)
downloadfreebsd-ports-b44976b8da76aee6a10d2a4dd6513ffaf247da5d.tar.gz
freebsd-ports-b44976b8da76aee6a10d2a4dd6513ffaf247da5d.tar.zst
freebsd-ports-b44976b8da76aee6a10d2a4dd6513ffaf247da5d.zip
- Fix the DOCSDIR and EXAMPLESDIR code. Now both can be set to
non-standard values. - Be less verbose. PR: 58559 Submitted by: Udo Schweigert <udo.schweigert@siemens.com> (maintainer)
Notes
Notes: svn path=/head/; revision=92199
Diffstat (limited to 'mail')
-rw-r--r--mail/mutt-devel/Makefile22
-rw-r--r--mail/mutt-devel/files/patch-doc-mutt.man20
2 files changed, 33 insertions, 9 deletions
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index 13f5d4225c8d..0cca9eaa1c83 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -133,7 +133,7 @@ DW_PATCH_VERSION= ${PORTVERSION}
# this should be done automagically by aclocal but ....
# for now, this will have to do
pre-build:
- ${REINPLACE_CMD} -E -e "s|^(ACLOCAL = ).+|\1${ACLOCAL}|" \
+ @${REINPLACE_CMD} -E -e "s|^(ACLOCAL = ).+|\1${ACLOCAL}|" \
-e "s|^(AUTOCONF = ).+|\1${AUTOCONF}|" \
-e "s|^(AUTOMAKE = ).+|\1${AUTOMAKE}|" \
-e "s|^(AUTOHEADER = ).+|\1${AUTOHEADER}|" \
@@ -181,13 +181,13 @@ LIB_DEPENDS+= sasl.8:${PORTSDIR}/security/cyrus-sasl
.endif
.if ! defined(WITHOUT_MUTT_SMIME_OUTLOOK_COMPAT)
pre-configure::
- ${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-smime-outlook
+ @${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-smime-outlook
.endif
.if ! defined(WITHOUT_MUTT_PGP_PATCH)
SGML_NEEDED= yes
pre-configure::
- ${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-pgp-dw
+ @${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-pgp-dw
.endif
.if defined(WITH_MUTT_LOCALES_FIX)
@@ -243,7 +243,7 @@ MAN5= muttrc.5 mbox.5
post-patch::
@${REINPLACE_CMD} -e 's,/usr/bin/gpg,${LOCALBASE}/bin/gpg,g' \
${WRKSRC}/contrib/gpg.rc
- ${REINPLACE_CMD} -E -e 's|@samplesdir@|${EXAMPLESDIR}|g' \
+ @${REINPLACE_CMD} -E -e 's|@samplesdir@|${EXAMPLESDIR}|g' \
${WRKSRC}/contrib/Makefile.in
pre-configure::
@@ -275,17 +275,21 @@ SCRIPTS_ENV+= MUTT_HTML="yes"
.endif
.if ! defined(WITHOUT_MUTT_QUOTE_PATCH)
post-patch::
- ${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-quote
+ @${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-quote
.endif
.if !defined(NOPORTDOCS)
SCRIPTS_ENV+= MUTT_PORTDOCS="yes"
post-build:
- ${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-doc-ref
- ${REINPLACE_CMD} -E -e 's|\$$\{PREFIX\}|${PREFIX}|g' \
+ @${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-doc-ref
+ @${REINPLACE_CMD} -E -e 's|\$$\{PREFIX\}|${PREFIX}|g' \
-e 's|\$$\{DOCSDIR\}|${DOCSDIR}|g' \
-e 's|\$$\{EXAMPLESDIR\}|${EXAMPLESDIR}|g' \
${WRKSRC}/doc/mutt.man
+ @${REINPLACE_CMD} -E -e 's|\$$\{PREFIX\}|${PREFIX}|g' \
+ -e 's|\$$\{DOCSDIR\}|${DOCSDIR}|g' \
+ -e 's|\$$\{EXAMPLESDIR\}|${EXAMPLESDIR}|g' \
+ ${WRKSRC}/doc/muttrc.man
.if ! defined(WITHOUT_MUTT_HTML)
SGML_USED= yes
.endif
@@ -294,14 +298,14 @@ SGML_USED= yes
.endif
.else # ! NOPORTDOCS
post-patch::
- ${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-nodoc-contrib
+ @${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-nodoc-contrib
.endif # ! NOPORTDOCS
.if ${SGML_USED} == yes
SCRIPTS_ENV+= MUTT_SGML="yes"
BUILD_DEPENDS+= sgmlfmt:${PORTSDIR}/textproc/sgmlformat
post-patch::
- ${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-sgmlformat
+ @${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-sgmlformat
.endif
pre-install:
diff --git a/mail/mutt-devel/files/patch-doc-mutt.man b/mail/mutt-devel/files/patch-doc-mutt.man
index 82f4a93ffd04..3d6381963abe 100644
--- a/mail/mutt-devel/files/patch-doc-mutt.man
+++ b/mail/mutt-devel/files/patch-doc-mutt.man
@@ -12,3 +12,23 @@
The Mutt manual.
.SH BUGS
.PP
+--- doc/muttrc.man.orig Wed Mar 19 22:55:03 2003
++++ doc/muttrc.man Sun Oct 26 11:16:05 2003
+@@ -1031,7 +1031,7 @@
+ .B dotlock_program
+ .nf
+ Type: path
+-Default: \(lq/usr/local/bin/mutt_dotlock\(rq
++Default: \(lq${PREFIX}/bin/mutt_dotlock\(rq
+ .fi
+ .IP
+ Contains the path of the mutt_dotlock (8) binary to be used by
+@@ -4410,7 +4410,7 @@
+ instead of a raw socket. You may be able to use this to set up
+ preauthenticated connections to your IMAP/POP3 server. Example:
+ .IP
+-tunnel=\(rqssh -q mailhost.net /usr/local/libexec/imapd\(rq
++tunnel=\(rqssh -q mailhost.net ${PREFIX}/libexec/imapd\(rq
+ .IP
+ NOTE: For this example to work you must be able to log in to the remote
+ machine without having to enter a password.