aboutsummaryrefslogtreecommitdiffstats
path: root/math/grace/Makefile
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>1999-03-18 16:41:40 +0800
committerSatoshi Taoka <taoka@FreeBSD.org>1999-03-18 16:41:40 +0800
commit121181f4e6951c5828ae4a73ebe6e82f9b9a210f (patch)
treebbffd1d52f98c29888eb898bf5599647fcaae1d6 /math/grace/Makefile
parent8d087a6cf09331f49618430b0d609cc79134b723 (diff)
downloadfreebsd-ports-121181f4e6951c5828ae4a73ebe6e82f9b9a210f.tar.gz
freebsd-ports-121181f4e6951c5828ae4a73ebe6e82f9b9a210f.tar.zst
freebsd-ports-121181f4e6951c5828ae4a73ebe6e82f9b9a210f.zip
A powerful plotting tool (successor of xmgr)
PR: ports/9222 Submitted by: Lars Koeller lkoeller@cc.fh-lippe.de
Notes
Notes: svn path=/head/; revision=17277
Diffstat (limited to 'math/grace/Makefile')
-rw-r--r--math/grace/Makefile51
1 files changed, 51 insertions, 0 deletions
diff --git a/math/grace/Makefile b/math/grace/Makefile
new file mode 100644
index 000000000000..7736365892f2
--- /dev/null
+++ b/math/grace/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: grace
+# Version required: 5.0.1
+# Date created: Dec 28 1998
+# Whom: Lars Koeller <lkoeller@cc.fh-lippe.de>
+#
+# $Id$
+#
+
+DISTNAME= grace-5.0.1
+PKGNAME= grace-5.0.1a
+CATEGORIES= math print
+#
+# You never know when and why this caotic team moves it to ../src/old/ :-)
+#
+MASTER_SITES= ftp://ftp.uni-bielefeld.de/pub/systems/FreeBSD/lkoeller/ \
+ ftp://plasma-gate.weizmann.ac.il/pub/grace/src/ \
+ ftp://plasma-gate.weizmann.ac.il/pub/grace/src/old/ \
+ ftp://abragam.med.utoronto.ca/pub/mirrors/grace/src/ \
+ ftp://abragam.med.utoronto.ca/pub/mirrors/grace/src/old/ \
+ ftp://linux.mathematik.tu-darmstadt.de/pub/linux/mirrors/misc/grace/src/old/ \
+ ftp://linux.mathematik.tu-darmstadt.de/pub/linux/mirrors/misc/grace/src/
+EXTRACT_SUFX= alpha.tar.gz
+
+MAINTAINER= Lars.Koeller@Uni-Bielefeld.DE
+
+BUILD_DEPENDS= ${X11BASE}/lib/libhlpclient.a:${PORTSDIR}/x11/libhelp \
+ ${LOCALBASE}/lib/libmfhdf.a:${PORTSDIR}/graphics/hdf \
+ ${LOCALBASE}/lib/libgd.a:${PORTSDIR}/graphics/gd \
+ ${LOCALBASE}/lib/libpdf.a:${PORTSDIR}/print/pdflib
+LIB_DEPENDS= Xbae.6:${PORTSDIR}/x11-toolkits/xbae \
+ fftw.2:${PORTSDIR}/math/fftw \
+ tiff.4:${PORTSDIR}/graphics/tiff34
+
+USE_X_PREFIX= YES
+REQUIRE_MOTIF= YES
+HAS_CONFIGURE= YES
+CONFIGURE_ARGS= -prefix=${X11BASE} \
+ --enable-extra-incpath=${X11BASE}/include/X11:${LOCALBASE}/include:${LOCALBASE}/include/tiff34:${LOCALBASE}/include/gd \
+ --enable-extra-ldpath=${LOCALBASE}/lib --enable-libhelp \
+ --enable-mfhdf --enable-grace-home=${X11BASE}/lib/X11/grace
+
+ALL_TARGET=
+INSTALL_TARGET= install links
+
+post-patch:
+ ${MV} ${WRKSRC}/configure ${WRKSRC}/configure.input
+ ${SED} "s%-lXm %${MOTIFLIB} %" ${WRKSRC}/configure.input > ${WRKSRC}/configure
+ chmod 755 ${WRKSRC}/configure
+ ${RM} -f ${WRKSRC}/configure.input
+
+.include <bsd.port.mk>