aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2004-08-16 16:55:50 +0800
committermaho <maho@FreeBSD.org>2004-08-16 16:55:50 +0800
commit3a7bf0fd4951deaf3842ea1e181d53b9e3295db2 (patch)
treef4072bfafc87bb3d01dddbc51e533ae8eff2e15f /math
parent9a0163f5fccc746d7f75c1b144bd962dfd94b9b9 (diff)
downloadfreebsd-ports-3a7bf0fd4951deaf3842ea1e181d53b9e3295db2.tar.gz
freebsd-ports-3a7bf0fd4951deaf3842ea1e181d53b9e3295db2.tar.zst
freebsd-ports-3a7bf0fd4951deaf3842ea1e181d53b9e3295db2.zip
Add flag USE_ICC, uses intel c/c++ compilier
Diffstat (limited to 'math')
-rw-r--r--math/sdpa/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/math/sdpa/Makefile b/math/sdpa/Makefile
index d4cdabe6ab2a..4ddceae7fb8f 100644
--- a/math/sdpa/Makefile
+++ b/math/sdpa/Makefile
@@ -22,6 +22,9 @@ EXTRACT_ONLY= ${PORTNAME}.${PORTVERSION}.src.tar.gz
MAINTAINER= maho@FreeBSD.org
COMMENT= SDPA(SemiDefinite Programming Algorithm) Very efficent SDP Solver
+.if defined(USE_ICC)
+BUILD_DEPENDS= ${LOCALBASE}/intel_cc_80/bin/icc:${PORTSDIR}/lang/icc
+.endif
LIB_DEPENDS= atlas:${PORTSDIR}/math/atlas
RESTRICTED= "unsure distribution condition"
@@ -32,16 +35,24 @@ USE_REINPLACE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
LAPACK= -lalapack
CBLAS= -lcblas -lf77blas -latlas -lg2c
+#USE_ICC= yes
.if defined(WITH_OPTIMIZED_FLAGS)
CFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -malign-double
CXXFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -malign-double -Wno-multichar
.if (${MACHINE_ARCH} == "i386")
-CFLAGS+=-mcpu=i686 -march=i686 -mfancy-math-387 -mpreferred-stack-boundary=3
-CXXFLAGS+=-mcpu=i686 -march=i686 -mfancy-math-387 -mpreferred-stack-boundary=3
+CFLAGS+= -mcpu=i686 -march=i686 -mfancy-math-387 -mpreferred-stack-boundary=3
+CXXFLAGS+= -mcpu=i686 -march=i686 -mfancy-math-387 -mpreferred-stack-boundary=3
.endif # i386
.endif
+.if defined(USE_ICC)
+CC= ${LOCALBASE}/intel_cc_80/bin/icc
+CXX= ${LOCALBASE}/intel_cc_80/bin/icpc
+CFLAGS= -O3 -tpp7 -xiMKW -Vaxlib
+CXXFLAGS= -O3 -tpp7 -xiMKW -Vaxlib
+.endif
+
pre-build:
${CP} ${FILESDIR}/Makefile ${WRKDIR}
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g ; \