aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2002-05-27 22:50:49 +0800
committerSergey Skvortsov <skv@FreeBSD.org>2002-05-27 22:50:49 +0800
commit4818abba4f346b0652db511162a351af3332a2f9 (patch)
tree4b397c3533e9642372d3dc35447a10cb832030c6 /math
parentc0127ac2fce3cb68a131e5aedcc6a09d4e986af3 (diff)
downloadfreebsd-ports-4818abba4f346b0652db511162a351af3332a2f9.tar.gz
freebsd-ports-4818abba4f346b0652db511162a351af3332a2f9.tar.zst
freebsd-ports-4818abba4f346b0652db511162a351af3332a2f9.zip
Add p5-Math-SimpleVariable 0.03,
simple representation of mathematical variables. PR: 32974 Submitted by: Sergey Skvortsov <skv@FreeBSD.org>
Notes
Notes: svn path=/head/; revision=60136
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Math-SimpleVariable/Makefile29
-rw-r--r--math/p5-Math-SimpleVariable/distinfo1
-rw-r--r--math/p5-Math-SimpleVariable/pkg-comment1
-rw-r--r--math/p5-Math-SimpleVariable/pkg-descr7
-rw-r--r--math/p5-Math-SimpleVariable/pkg-plist5
6 files changed, 44 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index b957d873f1e4..c0e23774d916 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -90,6 +90,7 @@
SUBDIR += p5-Math-Pari
SUBDIR += p5-Math-Random
SUBDIR += p5-Math-Random-MT
+ SUBDIR += p5-Math-SimpleVariable
SUBDIR += p5-Math-TrulyRandom
SUBDIR += p5-MatrixReal
SUBDIR += p5-Set-IntSpan
diff --git a/math/p5-Math-SimpleVariable/Makefile b/math/p5-Math-SimpleVariable/Makefile
new file mode 100644
index 000000000000..8a5be9b956f7
--- /dev/null
+++ b/math/p5-Math-SimpleVariable/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: Math::SimpleVariable
+# Date created: 5 Nov 2001
+# Whom: Sergey Skvortsov <skv@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-SimpleVariable
+PORTVERSION= 0.03
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/fields.pm:${PORTSDIR}/devel/p5-Class-Fields
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Math::SimpleVariable.3
+
+pre-patch:
+ @${FIND} ${WRKSRC} -name "*.pm" | xargs ${PERL} -pi -e \
+ '$$package=$$1 if /^package\s+([^\s;]*);/; s!^require 5.005_62;!!; s!^use warnings;!!; s!^our\s+(\$$)(VERSION)\s+=!$$1$${package}::$$2=!;'
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-SimpleVariable/distinfo b/math/p5-Math-SimpleVariable/distinfo
new file mode 100644
index 000000000000..14a86213c922
--- /dev/null
+++ b/math/p5-Math-SimpleVariable/distinfo
@@ -0,0 +1 @@
+MD5 (Math-SimpleVariable-0.03.tar.gz) = 0b7b45d71edab401e7aa64a0ad292eed
diff --git a/math/p5-Math-SimpleVariable/pkg-comment b/math/p5-Math-SimpleVariable/pkg-comment
new file mode 100644
index 000000000000..860f2b6e4f3a
--- /dev/null
+++ b/math/p5-Math-SimpleVariable/pkg-comment
@@ -0,0 +1 @@
+Simple representation of mathematical variables
diff --git a/math/p5-Math-SimpleVariable/pkg-descr b/math/p5-Math-SimpleVariable/pkg-descr
new file mode 100644
index 000000000000..4d308d7f35f9
--- /dev/null
+++ b/math/p5-Math-SimpleVariable/pkg-descr
@@ -0,0 +1,7 @@
+Math::SimpleVariable is a simple representation of mathematical
+variables, with an obligatory name and an optional value.
+
+WWW: http://search.cpan.org/search?dist=Math-SimpleVariable
+
+-- Sergey Skvortsov
+skv@FreeBSD.org
diff --git a/math/p5-Math-SimpleVariable/pkg-plist b/math/p5-Math-SimpleVariable/pkg-plist
new file mode 100644
index 000000000000..2df96163f514
--- /dev/null
+++ b/math/p5-Math-SimpleVariable/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math/SimpleVariable/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Math/SimpleVariable.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math/SimpleVariable
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Math 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math 2>/dev/null || true