aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-03-18 17:46:46 +0800
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-03-18 17:46:46 +0800
commit8493a5819b74095ca9e0b9f0cf8e77fedad823e1 (patch)
tree19832c4fa0699d64a8eaf478f63987c7ab06da65 /math
parent0b31d075bc0e27d93cf260d6dda0f3fbe47654e6 (diff)
downloadfreebsd-ports-8493a5819b74095ca9e0b9f0cf8e77fedad823e1.tar.gz
freebsd-ports-8493a5819b74095ca9e0b9f0cf8e77fedad823e1.tar.zst
freebsd-ports-8493a5819b74095ca9e0b9f0cf8e77fedad823e1.zip
Iconv cleanup, stage 1b: correct {BUILD,LIB,RUN}_DEPENDS of all ports that need
libiconv.
Notes
Notes: svn path=/head/; revision=56287
Diffstat (limited to 'math')
-rw-r--r--math/gnumeric/Makefile3
-rw-r--r--math/gnumeric2/Makefile3
2 files changed, 4 insertions, 2 deletions
diff --git a/math/gnumeric/Makefile b/math/gnumeric/Makefile
index d161bd9395bc..fef12b65d62f 100644
--- a/math/gnumeric/Makefile
+++ b/math/gnumeric/Makefile
@@ -16,7 +16,7 @@ MAINTAINER?= gnome@FreeBSD.org
LIB_DEPENDS= gnomeole2.0:${PORTSDIR}/devel/libole2 \
gbrun.0:${PORTSDIR}/lang/gnomebasic \
- giconv.2:${PORTSDIR}/converters/libiconv \
+ iconv.3:${PORTSDIR}/converters/libiconv \
psiconv.8:${PORTSDIR}/converters/psiconv
RUN_DEPENDS= guppi-gnumeric:${PORTSDIR}/math/guppi
@@ -28,6 +28,7 @@ USE_GNOME= yes
USE_PYTHON= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
+CONFIGURE_ARGS= --with-evolution
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib -lintl -lgiconv ${PTHREAD_LIBS}"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
diff --git a/math/gnumeric2/Makefile b/math/gnumeric2/Makefile
index d161bd9395bc..fef12b65d62f 100644
--- a/math/gnumeric2/Makefile
+++ b/math/gnumeric2/Makefile
@@ -16,7 +16,7 @@ MAINTAINER?= gnome@FreeBSD.org
LIB_DEPENDS= gnomeole2.0:${PORTSDIR}/devel/libole2 \
gbrun.0:${PORTSDIR}/lang/gnomebasic \
- giconv.2:${PORTSDIR}/converters/libiconv \
+ iconv.3:${PORTSDIR}/converters/libiconv \
psiconv.8:${PORTSDIR}/converters/psiconv
RUN_DEPENDS= guppi-gnumeric:${PORTSDIR}/math/guppi
@@ -28,6 +28,7 @@ USE_GNOME= yes
USE_PYTHON= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
+CONFIGURE_ARGS= --with-evolution
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib -lintl -lgiconv ${PTHREAD_LIBS}"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}