aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-04-07 09:47:51 +0800
committerWill Andrews <will@FreeBSD.org>2000-04-07 09:47:51 +0800
commita6d989b045799e9f256fc58431202a3f28173f85 (patch)
treeca6ae90dd627c9d292c4a2b594df67a77e136b7a /math
parent095e4b4d73852b09fef0ac68d64297ca91275dad (diff)
downloadfreebsd-ports-a6d989b045799e9f256fc58431202a3f28173f85.tar.gz
freebsd-ports-a6d989b045799e9f256fc58431202a3f28173f85.tar.zst
freebsd-ports-a6d989b045799e9f256fc58431202a3f28173f85.zip
Add LinAlg, an extended C++ math library. Unfortunately, it can't be made
to respect C(C,XX) or C(XX)FLAGS, according to the author. Author also requested that the distfile be hosted on *.FreeBSD.org. PR: 13124 Submitted by: Oleg <oleg@pobox.com>
Notes
Notes: svn path=/head/; revision=27392
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/linalg/Makefile36
-rw-r--r--math/linalg/distinfo1
-rw-r--r--math/linalg/pkg-comment1
-rw-r--r--math/linalg/pkg-descr19
-rw-r--r--math/linalg/pkg-message11
-rw-r--r--math/linalg/pkg-plist12
7 files changed, 81 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 552eaf72d745..404e45d2a236 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -28,6 +28,7 @@
SUBDIR += hexcalc
SUBDIR += lapack
SUBDIR += libranlib
+ SUBDIR += linalg
SUBDIR += linpack
SUBDIR += metis
SUBDIR += netcdf
diff --git a/math/linalg/Makefile b/math/linalg/Makefile
new file mode 100644
index 000000000000..cee7161e056b
--- /dev/null
+++ b/math/linalg/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: LinAlg
+# Version required: 4.3
+# Date created: August 25, 1999
+# Whom: Oleg Kiselyov <oleg@pobox.com>
+#
+# $FreeBSD$
+#
+
+DISTNAME= linalg-4.3
+CATEGORIES= math
+MASTER_SITES= http://people.FreeBSD.org/~will/distfiles/
+
+MAINTAINER= oleg@pobox.com
+
+WRKSRC= ${WRKDIR}/LinAlg
+ALL_TARGET= lib
+INSTALL_TARGET= lib
+USE_GMAKE= yes
+
+post-install:
+ $(INSTALL_DATA) ${WRKSRC}/libla.a ${PREFIX}/lib
+ ${MKDIR} ${PREFIX}/include/LinAlg
+ $(INSTALL_DATA) ${WRKSRC}/LinAlg.h ${PREFIX}/include/LinAlg
+ $(INSTALL_DATA) ${WRKSRC}/LAStreams.h ${PREFIX}/include/LinAlg
+ $(INSTALL_DATA) ${WRKSRC}/builtin.h ${PREFIX}/include/LinAlg
+ $(INSTALL_DATA) ${WRKSRC}/math_num.h ${PREFIX}/include/LinAlg
+ $(INSTALL_DATA) ${WRKSRC}/minmax.h ${PREFIX}/include/LinAlg
+ $(INSTALL_DATA) ${WRKSRC}/myenv.h ${PREFIX}/include/LinAlg
+ $(INSTALL_DATA) ${WRKSRC}/std.h ${PREFIX}/include/LinAlg
+ $(INSTALL_DATA) ${WRKSRC}/svd.h ${PREFIX}/include/LinAlg
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/LinAlg
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/LinAlg
+.endif
+
+.include <bsd.port.mk>
diff --git a/math/linalg/distinfo b/math/linalg/distinfo
new file mode 100644
index 000000000000..d5beaf0b85df
--- /dev/null
+++ b/math/linalg/distinfo
@@ -0,0 +1 @@
+MD5 (linalg-4.3.tar.gz) = b5b4d5907f60f8517532af6bc23efd01
diff --git a/math/linalg/pkg-comment b/math/linalg/pkg-comment
new file mode 100644
index 000000000000..8b420c2b647a
--- /dev/null
+++ b/math/linalg/pkg-comment
@@ -0,0 +1 @@
+C++ Linear Algebra and Optimization classlib
diff --git a/math/linalg/pkg-descr b/math/linalg/pkg-descr
new file mode 100644
index 000000000000..3c017af32ac4
--- /dev/null
+++ b/math/linalg/pkg-descr
@@ -0,0 +1,19 @@
+ LinAlg -- C++ Linear Algebra and Optimization classlib
+
+- Matrix, Vector, subMatrices, and LAStreams over real domain;
+- Matrix inverse, norms, determinant, lazy matrices, Singular Value
+ Decomposition (SVD) and applications, nested functions;
+- Brent's univariate optimization and root finding, Hooke-Jeeves
+ multidimensional optimization of functors, Aitken-Lagrange interpolation;
+- LinAlg stresses Matrix streams, which provide a sequential
+ view/access to a matrix or its parts. LABlockStreams may
+ span over an arbitrary rectangular block of a matrix, including the
+ whole matrix, a single matrix element, and all other block sizes in
+ between. Matrix streams are seekable and subrange-able. A stream or
+ a substream are always created in-line; they do not allocate any
+ heap storage, and are safe.
+- Every feature is extensively tested in the validation code (included).
+
+WWW: http://pobox.com/~oleg/ftp/packages.html
+
+Oleg Kiselyov <oleg@pobox.com>
diff --git a/math/linalg/pkg-message b/math/linalg/pkg-message
new file mode 100644
index 000000000000..3fd4fd9df0d5
--- /dev/null
+++ b/math/linalg/pkg-message
@@ -0,0 +1,11 @@
+Don't forget to compile and run verification/validation code: gmake check-all
+or specifically, sub-targets
+ vmatrix vvector vmatrix1 vmatrix2 vlastreams
+ vali vhjmin vfminbr vzeroin
+ vsvd vslesing sample_ult sample_adv
+
+See comments in a LinAlg/Makefile for details, as well as NumMath.dr.
+The verification code checks to see that all the functions in this
+package have compiled and run well. The validation code can also serve
+as an illustration of how package's classes and functions may be
+employed.
diff --git a/math/linalg/pkg-plist b/math/linalg/pkg-plist
new file mode 100644
index 000000000000..3f2d828f314a
--- /dev/null
+++ b/math/linalg/pkg-plist
@@ -0,0 +1,12 @@
+lib/libla.a
+share/doc/LinAlg/README
+include/LinAlg/LinAlg.h
+include/LinAlg/LAStreams.h
+include/LinAlg/builtin.h
+include/LinAlg/math_num.h
+include/LinAlg/minmax.h
+include/LinAlg/myenv.h
+include/LinAlg/std.h
+include/LinAlg/svd.h
+@dirrm share/doc/LinAlg
+@dirrm include/LinAlg