aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2002-03-26 10:02:10 +0800
committerTrevor Johnson <trevor@FreeBSD.org>2002-03-26 10:02:10 +0800
commitaa277916ac0d41efd1092e56082154a3b7803eaf (patch)
treecc11aafa66c3500f8e0d4ec742564463e1ecbe45 /math
parent746e4b7b5d5c61573462a956a198ac17bacc2f50 (diff)
downloadfreebsd-ports-aa277916ac0d41efd1092e56082154a3b7803eaf.tar.gz
freebsd-ports-aa277916ac0d41efd1092e56082154a3b7803eaf.tar.zst
freebsd-ports-aa277916ac0d41efd1092e56082154a3b7803eaf.zip
Ignore CFLAGS. As noted by the authors, optimization "takes too
much RAM."
Notes
Notes: svn path=/head/; revision=56666
Diffstat (limited to 'math')
-rw-r--r--math/cxsc/Makefile2
-rw-r--r--math/cxsc/files/patch-Makefile15
2 files changed, 4 insertions, 13 deletions
diff --git a/math/cxsc/Makefile b/math/cxsc/Makefile
index 4a5320b53167..144c4328d76f 100644
--- a/math/cxsc/Makefile
+++ b/math/cxsc/Makefile
@@ -14,8 +14,6 @@ DISTNAME= ${PORTNAME}-2-0-beta
MAINTAINER= ports@FreeBSD.org
-BROKEN= "Does not build (exhausts memory)"
-
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_GMAKE= yes
MAKE_ENV= INSTALL_DATA="${INSTALL_DATA}"
diff --git a/math/cxsc/files/patch-Makefile b/math/cxsc/files/patch-Makefile
index f6f61b5faf30..2eee7a257a99 100644
--- a/math/cxsc/files/patch-Makefile
+++ b/math/cxsc/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig Fri Aug 10 01:50:35 2001
-+++ Makefile Sat Aug 11 23:35:31 2001
-@@ -2,24 +2,23 @@
+--- Makefile.orig Thu Aug 9 10:50:35 2001
++++ Makefile Mon Mar 25 17:26:19 2002
+@@ -2,19 +2,18 @@
# (un-)installation prefix
# e.g. /usr/local/cxsc or local home directory
@@ -14,8 +14,7 @@
+#export CCOPTS=-Wall# optional flags to give to the C compiler
export CCINC=-I. -I../.. -I../rts#
# additional include path
--export CCFLAGS=$(CCINC) $(CCOPTS)#
-+export CCFLAGS=${CFLAGS} $(CCINC) $(CCOPTS)#
+ export CCFLAGS=$(CCINC) $(CCOPTS)#
# extra flags to give to the C compiler
-export CXX=g++# name of the C++ compiler
@@ -25,12 +24,6 @@
# -O3# at the moment without optimization
# (takes too much RAM)
export CXXINC=-I. -I.. -Irts/ -Ifi_lib#
- # additional include path
--export CXXFLAGS=$(CXXINC) $(CXXOPTS)#
-+export CXXFLAGS+=$(CXXINC) $(CXXOPTS)#
- # extra flags to give to the C++ compiler
-
- export AR=ar# put object file into archive
@@ -29,7 +28,7 @@
export RM=rm -f# remove files (forced)
export RMDIR=rm -rf# remove directory