aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-03-15 00:40:24 +0800
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-03-15 00:40:24 +0800
commitc5a9970f43e813f57275b6c2ce6d3052998821c2 (patch)
treeeeddf85398be208618369afc1610283cb675e78b /math
parentbeafdedff556413bd156435068f1c2f665f9bb01 (diff)
downloadfreebsd-ports-c5a9970f43e813f57275b6c2ce6d3052998821c2.tar.gz
freebsd-ports-c5a9970f43e813f57275b6c2ce6d3052998821c2.tar.zst
freebsd-ports-c5a9970f43e813f57275b6c2ce6d3052998821c2.zip
Manually invoke `${MAKE} patch' for Gnumeric, because puting it into
BUILD_DEPEDS creates short circuit when make clean is invoked either for Gnumeric port or for Guppi port. Perhaps our bsd.port.mk should be fixed to avoid such problems. Submitted by: John Merryweather Cooper <john_m_cooper@yahoo.com>
Notes
Notes: svn path=/head/; revision=56091
Diffstat (limited to 'math')
-rw-r--r--math/guppi/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/math/guppi/Makefile b/math/guppi/Makefile
index 5f77170e9c6a..fe7ed25159c2 100644
--- a/math/guppi/Makefile
+++ b/math/guppi/Makefile
@@ -15,7 +15,6 @@ DISTNAME= Guppi-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
-BUILD_DEPENDS= /nonexistent:${PORTSDIR}/math/gnumeric:patch
LIB_DEPENDS= guile.9:${PORTSDIR}/lang/guile
USE_X_PREFIX= yes
@@ -31,6 +30,12 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include/libglade-1.
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
PLIST_SUB= VERSION="${PORTVERSION}"
+# Can't use BUILD_DEPENDS, because then we have `short circuit' for
+# make clean - Gnumeric tries to clean-up Guppi, while Guppi in turn
+# tries to clean Gnumeric.
+post-extract:
+ @cd ${PORTSDIR}/math/gnumeric && ${MAKE} patch
+
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure