aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-05-15 23:34:15 +0800
committerkrion <krion@FreeBSD.org>2004-05-15 23:34:15 +0800
commitd90e6e3c64ffee1b38e5e80601fef6acacccbbc4 (patch)
treec43c956c5ded91ae15aab3fea98606ed311249f6 /math
parentd1d158ec9d0b0e69eb699bbd34f61a2e16d5b448 (diff)
downloadfreebsd-ports-d90e6e3c64ffee1b38e5e80601fef6acacccbbc4.tar.gz
freebsd-ports-d90e6e3c64ffee1b38e5e80601fef6acacccbbc4.tar.zst
freebsd-ports-d90e6e3c64ffee1b38e5e80601fef6acacccbbc4.zip
Add libRmath 1.9.0, the standalone math library from R.
PR: ports/66644 Submitted by: Eric van Gyzen <vangyzen@stat.duke.edu>
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/libRmath/Makefile54
-rw-r--r--math/libRmath/distinfo2
-rw-r--r--math/libRmath/pkg-descr10
4 files changed, 67 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 02843d2460f0..4ddf12ff5485 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -80,6 +80,7 @@
SUBDIR += lambda
SUBDIR += lapack
SUBDIR += lapack++
+ SUBDIR += libRmath
SUBDIR += libgmp-freebsd
SUBDIR += libgmp4
SUBDIR += libmath++
diff --git a/math/libRmath/Makefile b/math/libRmath/Makefile
new file mode 100644
index 000000000000..7a35bfd369ed
--- /dev/null
+++ b/math/libRmath/Makefile
@@ -0,0 +1,54 @@
+# ex: tabstop=8 softtabstop=0 noexpandtab
+# Ports collection Makefile for: libRmath
+# Date created: 14 May 2004
+# Whom: Eric van Gyzen <vangyzen@stat.duke.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libRmath
+PORTVERSION= 1.9.0
+CATEGORIES= math
+MASTER_SITES= http://cran.r-project.org/src/base/ \
+ ftp://cran.r-project.org/pub/R/src/base/ \
+ http://cran.at.r-project.org/src/base/ \
+ http://cran.au.r-project.org/src/base/ \
+ http://cran.br.r-project.org/src/base/ \
+ http://cran.ch.r-project.org/src/base/ \
+ http://cran.es.r-project.org/src/base/ \
+ http://cran.dk.r-project.org/src/base/ \
+ http://cran.hu.r-project.org/src/base/ \
+ http://cran.uk.r-project.org/src/base/ \
+ http://cran.us.r-project.org/src/base/ \
+ http://cran.za.r-project.org/src/base/ \
+ ftp://ftp.u-aizu.ac.jp/pub/lang/R/CRAN/src/base/ \
+ http://lib.stat.cmu.edu/R/CRAN/src/base/ \
+ http://cran.stat.ucla.edu/src/base/ \
+ http://probability.ca/cran/src/base/ \
+ http://www.ibiblio.org/pub/languages/R/CRAN/src/base/ \
+ http://www.bioconductor.org/CRAN/src/base/
+DISTNAME= R-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= vangyzen@stat.duke.edu
+COMMENT= The standalone math library from R
+
+INSTALLS_SHLIB= yes
+USE_PERL5= yes
+GNU_CONFIGURE= yes
+
+PLIST_FILES= include/Rmath.h lib/libRmath.a lib/libRmath.so lib/libRmath.so.0
+
+do-build:
+ (cd ${WRKSRC}/src/include; ${MAKE} Rmath.h)
+ (cd ${WRKSRC}/src/nmath/standalone; ${MAKE})
+
+do-install:
+ ${MKDIR} ${PREFIX}/include ${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/src/include/Rmath.h ${PREFIX}/include/
+ ${INSTALL_DATA} ${WRKSRC}/src/nmath/standalone/libRmath.a ${PREFIX}/lib/
+ ${INSTALL_DATA} ${WRKSRC}/src/nmath/standalone/libRmath.so \
+ ${PREFIX}/lib/libRmath.so.0
+ (cd ${PREFIX}/lib; ${LN} -sf libRmath.so.0 libRmath.so)
+
+.include <bsd.port.mk>
diff --git a/math/libRmath/distinfo b/math/libRmath/distinfo
new file mode 100644
index 000000000000..fda50e0b4072
--- /dev/null
+++ b/math/libRmath/distinfo
@@ -0,0 +1,2 @@
+MD5 (R-1.9.0.tgz) = 79ae9d20a7bed94d7c92504c8c130310
+SIZE (R-1.9.0.tgz) = 9505598
diff --git a/math/libRmath/pkg-descr b/math/libRmath/pkg-descr
new file mode 100644
index 000000000000..e927f636f620
--- /dev/null
+++ b/math/libRmath/pkg-descr
@@ -0,0 +1,10 @@
+This is the standalone math library from R. R is a language
+and environment for statistical computing and graphics.
+To use the routines in your own C or C++ programs, include
+
+#define MATHLIB_STANDALONE
+#include <Rmath.h>
+
+and link against -lRmath.
+
+WWW: http://www.R-project.org/