aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-05-14 20:23:22 +0800
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-05-14 20:23:22 +0800
commite227284f5cc7144b5f87340a80bc345b2635dbd5 (patch)
tree88a7dd6b386f26295583f684ba82f2baa9e0d04f /math
parent84f845abb3eadcc7235704213f4fde9a58277eb0 (diff)
downloadfreebsd-ports-e227284f5cc7144b5f87340a80bc345b2635dbd5.tar.gz
freebsd-ports-e227284f5cc7144b5f87340a80bc345b2635dbd5.tar.zst
freebsd-ports-e227284f5cc7144b5f87340a80bc345b2635dbd5.zip
- Fix plist.
- Depend on gcc 3.3+ since there's no need to use older ggc's on 6, 7. PR: ports/96986 Submitted by: Jason Bacon <bacon@smithers.neuro.mcw.edu> (maintianer) [1] itetcu (me) [2] Approved by: maintainer [2], lawrance (mentor)
Notes
Notes: svn path=/head/; revision=162316
Diffstat (limited to 'math')
-rw-r--r--math/vtk43/Makefile7
-rw-r--r--math/vtk43/pkg-plist4
2 files changed, 8 insertions, 3 deletions
diff --git a/math/vtk43/Makefile b/math/vtk43/Makefile
index fd8836c5f9b5..75c11974e7b9 100644
--- a/math/vtk43/Makefile
+++ b/math/vtk43/Makefile
@@ -23,8 +23,6 @@ DISTFILES?= VTK-${PORTVERSION}-cvs${CVSDATE}.tar.gz
MAINTAINER= bacon@smithers.neuro.mcw.edu
COMMENT?= The Visualization Toolkit shared libs
-BROKEN= Incorrect pkg-plist
-
LATEST_LINK= vtk43
PREFIX= ${LOCALBASE}/vtk43
@@ -38,6 +36,7 @@ DOCSDIR= ${PREFIX}/share/doc/${PKGNAME}
PLIST= ${.CURDIR}/pkg-plist
FILESDIR= ${.CURDIR}/files
RESTRICTED= yes
+NO_MTREE= yes
VTK_KITS= Common Filtering Graphics Hybrid IO Imaging Rendering Parallel Patented
@@ -74,7 +73,7 @@ INSTALLS_SHLIB= yes
TTT= "${CXXFLAGS}" # this quotes are VERY important!
OPTFLAGPRESENT= ${TTT:C/^.*-O[23].*$/yes/}
.if ${OPTFLAGPRESENT} == "yes"
-USE_GCC= 3.3
+USE_GCC= 3.3+
.endif
.endif
@@ -200,6 +199,7 @@ patch-common:
install-binaries:
.if defined(BINARIES)
+ @${MKDIR} ${PREFIX}/bin
@${ECHO_MSG} "Installing binaries to ${PREFIX}/bin :"
.for i in ${BINARIES}
@${ECHO_MSG} "Installing ${i} ..."
@@ -208,6 +208,7 @@ install-binaries:
.endif
install-libs:
+ @${MKDIR} ${PREFIX}/lib
@${ECHO_MSG} "Installing shared libraries to ${PREFIX}/lib ..."
.for i in ${VTK_KITS:S/$/${WRAP}/} ${EXTRA_LIBS}
@${ECHO_MSG} "Installing libvtk${i}.so ..."
diff --git a/math/vtk43/pkg-plist b/math/vtk43/pkg-plist
index f2d76b7fe19d..58ab1ca86e75 100644
--- a/math/vtk43/pkg-plist
+++ b/math/vtk43/pkg-plist
@@ -43,3 +43,7 @@ lib/libvtkftgl.so.%%LIBVER%%
%%DOCSDIR%%/README.patented-classes
%%DOCSDIR%%/vtkLogo.jpg
@unexec rmdir %D/%%DOCSDIR%% 2>/dev/null || true
+@unexec rmdir %D/lib 2>/dev/null || true
+@unexec rmdir %D/share/doc 2>/dev/null || true
+@unexec rmdir %D/share 2>/dev/null || true
+@unexec rmdir %D/bin 2>/dev/null || true