aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2004-08-17 00:36:20 +0800
committerarved <arved@FreeBSD.org>2004-08-17 00:36:20 +0800
commitebc7bd9cdac98cf2f646332d4a21f133a0bb4bd4 (patch)
tree21ce3e210db8eb9ddc6ba135f6ef595bdd3c2665 /math
parent160dc712df7b917b097a2a315cc2bc52522ecfe4 (diff)
downloadfreebsd-ports-ebc7bd9cdac98cf2f646332d4a21f133a0bb4bd4.tar.gz
freebsd-ports-ebc7bd9cdac98cf2f646332d4a21f133a0bb4bd4.tar.zst
freebsd-ports-ebc7bd9cdac98cf2f646332d4a21f133a0bb4bd4.zip
Unbreak with gcc 3.4.2
Diffstat (limited to 'math')
-rw-r--r--math/gracetmpl/Makefile4
-rw-r--r--math/gracetmpl/files/patch-pygracetmpl.cc11
2 files changed, 11 insertions, 4 deletions
diff --git a/math/gracetmpl/Makefile b/math/gracetmpl/Makefile
index b1fb781d2325..b895beb85a89 100644
--- a/math/gracetmpl/Makefile
+++ b/math/gracetmpl/Makefile
@@ -28,10 +28,6 @@ INSTALL_TARGET= install python_install
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile with gcc 3.4.2"
-.endif
-
.if ${OSVERSION} < 500041
CFLAGS+= "${CPPFLAGS}"
MAKE_ENV= LDFLAGS="${LDFLAGS}"
diff --git a/math/gracetmpl/files/patch-pygracetmpl.cc b/math/gracetmpl/files/patch-pygracetmpl.cc
new file mode 100644
index 000000000000..9ba3f2d0cad8
--- /dev/null
+++ b/math/gracetmpl/files/patch-pygracetmpl.cc
@@ -0,0 +1,11 @@
+--- python/src/pygracetmpl.cc.orig Mon Aug 16 18:25:45 2004
++++ python/src/pygracetmpl.cc Mon Aug 16 18:31:35 2004
+@@ -179,7 +179,7 @@
+ int rows = dataArray->dimensions[1];
+ if(cols > 4)
+ cols = 4;
+- double **data = new (double *)[cols];
++ double **data = new double *[cols];
+ for(int c = 0; c < cols; ++c){
+ data[c] = new double[rows];
+ for(int r = 0; r < rows; ++r)