aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2004-08-16 20:09:45 +0800
committermaho <maho@FreeBSD.org>2004-08-16 20:09:45 +0800
commitefa1fd8e89b68a4c35c7bc91a2d952231d907fbd (patch)
tree3a7350dd88dbce3c7eb0569dbfa8724cd2fc01bb /math
parent6501afe82fe0d35b8319f473e2d6fcb699e8d8fe (diff)
downloadfreebsd-ports-efa1fd8e89b68a4c35c7bc91a2d952231d907fbd.tar.gz
freebsd-ports-efa1fd8e89b68a4c35c7bc91a2d952231d907fbd.tar.zst
freebsd-ports-efa1fd8e89b68a4c35c7bc91a2d952231d907fbd.zip
USE_ICC -> WITH_ICC
Checked by: portlint
Diffstat (limited to 'math')
-rw-r--r--math/sdpa/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/math/sdpa/Makefile b/math/sdpa/Makefile
index 4ddceae7fb8f..9fedf556c723 100644
--- a/math/sdpa/Makefile
+++ b/math/sdpa/Makefile
@@ -22,7 +22,7 @@ EXTRACT_ONLY= ${PORTNAME}.${PORTVERSION}.src.tar.gz
MAINTAINER= maho@FreeBSD.org
COMMENT= SDPA(SemiDefinite Programming Algorithm) Very efficent SDP Solver
-.if defined(USE_ICC)
+.if defined(WITH_ICC)
BUILD_DEPENDS= ${LOCALBASE}/intel_cc_80/bin/icc:${PORTSDIR}/lang/icc
.endif
LIB_DEPENDS= atlas:${PORTSDIR}/math/atlas
@@ -35,7 +35,7 @@ USE_REINPLACE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
LAPACK= -lalapack
CBLAS= -lcblas -lf77blas -latlas -lg2c
-#USE_ICC= yes
+#WITH_ICC= yes
.if defined(WITH_OPTIMIZED_FLAGS)
CFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -malign-double
@@ -46,7 +46,7 @@ CXXFLAGS+= -mcpu=i686 -march=i686 -mfancy-math-387 -mpreferred-stack-boundary=3
.endif # i386
.endif
-.if defined(USE_ICC)
+.if defined(WITH_ICC)
CC= ${LOCALBASE}/intel_cc_80/bin/icc
CXX= ${LOCALBASE}/intel_cc_80/bin/icpc
CFLAGS= -O3 -tpp7 -xiMKW -Vaxlib