aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-26 04:27:48 +0800
committerAaron Dalton <aaron@FreeBSD.org>2006-05-26 04:27:48 +0800
commiteffadb7fdc24694d014838cb9159da0a93d2364c (patch)
tree7a1b531f683a3b928d091c546b944a4487383298 /math
parent4fa76fde503d69abd73f7a73dbfd5da2f99dd288 (diff)
downloadfreebsd-ports-effadb7fdc24694d014838cb9159da0a93d2364c.tar.gz
freebsd-ports-effadb7fdc24694d014838cb9159da0a93d2364c.tar.zst
freebsd-ports-effadb7fdc24694d014838cb9159da0a93d2364c.zip
Adding port math/p5-Math-Units, a Perl library to perform unit conversion.
Approved by: tobez (implicit)
Notes
Notes: svn path=/head/; revision=163406
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Math-Units/Makefile22
-rw-r--r--math/p5-Math-Units/distinfo3
-rw-r--r--math/p5-Math-Units/pkg-descr17
-rw-r--r--math/p5-Math-Units/pkg-plist5
5 files changed, 48 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index e92ba20a5dbf..7acb2ed2da6e 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -212,6 +212,7 @@
SUBDIR += p5-Math-SymbolicX-ParserExtensionFactory
SUBDIR += p5-Math-SymbolicX-Statistics-Distributions
SUBDIR += p5-Math-TrulyRandom
+ SUBDIR += p5-Math-Units
SUBDIR += p5-Math-Vec
SUBDIR += p5-Math-VecStat
SUBDIR += p5-MatrixReal
diff --git a/math/p5-Math-Units/Makefile b/math/p5-Math-Units/Makefile
new file mode 100644
index 000000000000..37817c0cdb55
--- /dev/null
+++ b/math/p5-Math-Units/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Math-Units
+# Date created: 25 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Units
+PORTVERSION= 1.2
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Unit conversion
+
+MAN3= Math::Units.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Units/distinfo b/math/p5-Math-Units/distinfo
new file mode 100644
index 000000000000..513d4f04756d
--- /dev/null
+++ b/math/p5-Math-Units/distinfo
@@ -0,0 +1,3 @@
+MD5 (Math-Units-1.2.tar.gz) = 5089d07f2042c567759d1c761c40dd98
+SHA256 (Math-Units-1.2.tar.gz) = a5fbd19bff53cc4c3878434f8f5b4478a3e4f7aad3e4f858ecadf91aad8e4498
+SIZE (Math-Units-1.2.tar.gz) = 12148
diff --git a/math/p5-Math-Units/pkg-descr b/math/p5-Math-Units/pkg-descr
new file mode 100644
index 000000000000..d7a771aa3c59
--- /dev/null
+++ b/math/p5-Math-Units/pkg-descr
@@ -0,0 +1,17 @@
+The Math::Units module converts a numeric value in one unit of measurement
+to some other unit. The units must be compatible, i.e. length can not be
+converted to volume. If a conversion can not be made an exception is
+thrown.
+
+A combination chaining and reduction algorithm is used to perform the most
+direct unit conversion possible. Units may be written in several different
+styles. An abbreviation table is used to convert from common long-form
+unit names to the (more or less) standard abbreviations that the units
+module uses internally. All multiplicative unit conversions are cached so
+that future conversions can be performed very quickly.
+
+Too many units, prefixes and abbreviations are supported to list here. See
+the source code for a complete listing.
+
+WWW: http://search.cpan.org/dist/Math-Units
+Author: Ken Fox
diff --git a/math/p5-Math-Units/pkg-plist b/math/p5-Math-Units/pkg-plist
new file mode 100644
index 000000000000..c8a82fd22c65
--- /dev/null
+++ b/math/p5-Math-Units/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Math/Units.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Units/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Units
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
+@dirrmtry %%SITE_PERL%%/Math