aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-06-12 06:24:10 +0800
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-06-12 06:24:10 +0800
commit35781cb6a33e10bc8a87bddcbf9ec5966cf3d88d (patch)
treee9ae5a73d99de807731d3e4c6b0c159720355af4 /misc
parentc78adb8a819881e5706d30e9a58d80398fe90cc9 (diff)
downloadfreebsd-ports-35781cb6a33e10bc8a87bddcbf9ec5966cf3d88d.tar.gz
freebsd-ports-35781cb6a33e10bc8a87bddcbf9ec5966cf3d88d.tar.zst
freebsd-ports-35781cb6a33e10bc8a87bddcbf9ec5966cf3d88d.zip
- Fix OPTION checking [1]
- allow to depend on csup (default) or cvsup [2] - default database is now mysql [2] This port still needs a lot of work and it would be great if one of the wizards that know tindy's insides would take maintainership (current maintainer seem to be gone, no feedback rom him for > 1 month). PR: ports/97433 [1] Submitted by: Shaun Amott <shaun@inerd.com> [1] itetrcu (me) Approved by: lawrance (mentor)
Notes
Notes: svn path=/head/; revision=165149
Diffstat (limited to 'misc')
-rw-r--r--misc/tinderbox/Makefile31
-rw-r--r--misc/tinderbox/distinfo6
-rw-r--r--misc/tinderbox/pkg-plist2
3 files changed, 27 insertions, 12 deletions
diff --git a/misc/tinderbox/Makefile b/misc/tinderbox/Makefile
index 57f2fbc24afe..fc5b776993b6 100644
--- a/misc/tinderbox/Makefile
+++ b/misc/tinderbox/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= tinderbox
-PORTVERSION= 2.3.0
-PORTREVISION= 2
+PORTVERSION= 2.3.1
CATEGORIES= misc
MASTER_SITES= http://tinderbox.marcuscom.com/
@@ -16,20 +15,24 @@ COMMENT= Port build tinderbox system
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net \
${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB \
- cvsup:${PORTSDIR}/net/cvsup-without-gui
-OPTIONS= PGSQL "With pgsql" On \
- MYSQL "With mysql" Off
+OPTIONS= PGSQL "With pgsql" Off \
+ MYSQL "With mysql" On \
+ CSUP "Use csup for updates" On \
+ CVSUP "Use cvsup for updates" Off
NO_BUILD= yes
USE_APACHE= 1.3+
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
+MAN1= tc-configCcache.1 tc-configDistfile.1 tc-configGet.1 \
+ tc-configJail.1 tc-configTinderd.1 tc-init.1
+
.include <bsd.port.pre.mk>
.if defined(WITHOUT_PGSQL) && defined(WITHOUT_MYSQL)
-BROKEN= Tinderbox is useless without a database. Please (re)run 'make config' and choose one of PGSQL and MYSQL
+IGNORE= is useless without a database. Please (re)run 'make config' and choose one of PGSQL and MYSQL
.endif
USE_PHP= session
@@ -40,12 +43,20 @@ USE_PHP+= pgsql
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
.endif
-.if defined(WITH_MYSQL)
+.if !defined(WITHOUT_MYSQL)
USE_PHP+= mysql
USE_MYSQL= yes
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql${MYSQL_VER}
.endif
+.if defined(WITH_CSUP)
+RUN_DEPENDS+= csup:${PORTSDIR}/net/csup
+.endif
+
+.if defined(WITH_CVSUP)
+RUN_DEPENDS+= cvsup:${PORTSDIR}/net/cvsup-without-gui
+.endif
+
.include "${PORTSDIR}/Mk/bsd.php.mk"
post-extract:
@@ -55,9 +66,10 @@ post-extract:
post-patch:
.if defined(WITH_MYSQL)
- ${REINPLACE_CMD} \
+ @${REINPLACE_CMD} \
-e 's,DB_MAN_PREREQS=.*,DB_MAN_PREREQS="databases/p5-DBD-mysql${MYSQL_VER} databases/mysql${MYSQL_VER}-client",' \
${WRKSRC}/lib/setup-mysql.sh
+ @${RM} ${WRKSRC}/lib/setup-mysql.sh.bak
.endif
do-install:
@@ -65,6 +77,7 @@ do-install:
${CP} -R ${WRKSRC}/* ${PREFIX}/tinderbox/scripts
post-install:
- ${CAT} ${PKGMESSAGE}
+ cd ${WRKSRC}/man/man1 && ${INSTALL_MAN} ${MAN1} ${MAN1PREFIX}/man/man1
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/misc/tinderbox/distinfo b/misc/tinderbox/distinfo
index fefebbeedd7c..6c1a8e80946a 100644
--- a/misc/tinderbox/distinfo
+++ b/misc/tinderbox/distinfo
@@ -1,3 +1,3 @@
-MD5 (tinderbox-2.3.0.tar.gz) = 4bd33a1ac8a31ec3e62b42f5307a587d
-SHA256 (tinderbox-2.3.0.tar.gz) = a3062b98688ac50ac3c50c94f1f3a27334bfb2479f8d83cabb0f8b263dc7fba7
-SIZE (tinderbox-2.3.0.tar.gz) = 118046
+MD5 (tinderbox-2.3.1.tar.gz) = f92ff04fa6fef815b6238e164e019752
+SHA256 (tinderbox-2.3.1.tar.gz) = fbeb316c039196c4509231dce374759476a7aa836be333dc8c1656fed71e87b0
+SIZE (tinderbox-2.3.1.tar.gz) = 120573
diff --git a/misc/tinderbox/pkg-plist b/misc/tinderbox/pkg-plist
index 7b5386940c5d..5b7e87d504c7 100644
--- a/misc/tinderbox/pkg-plist
+++ b/misc/tinderbox/pkg-plist
@@ -48,8 +48,10 @@ tinderbox/scripts/upgrade/mig_mysql_tinderbox-2.0.0_to_2.1.0.sql
tinderbox/scripts/upgrade/mig_mysql_tinderbox-2.1.0_to_2.1.1.sql
tinderbox/scripts/upgrade/mig_mysql_tinderbox-2.1.1_to_2.2.0.sql
tinderbox/scripts/upgrade/mig_mysql_tinderbox-2.2.0_to_2.3.0.sql
+tinderbox/scripts/upgrade/mig_mysql_tinderbox-2.3.0_to_2.3.1.sql
tinderbox/scripts/upgrade/mig_pgsql_tinderbox-2.1.1_to_2.2.0.sql
tinderbox/scripts/upgrade/mig_pgsql_tinderbox-2.2.0_to_2.3.0.sql
+tinderbox/scripts/upgrade/mig_pgsql_tinderbox-2.3.0_to_2.3.1.sql
tinderbox/scripts/upgrade/mig_shlib.sh
tinderbox/scripts/www-exp/core/Build.php
tinderbox/scripts/www-exp/core/BuildPortsQueue.php