aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-04-10 19:48:26 +0800
committerAkinori MUSHA <knu@FreeBSD.org>2001-04-10 19:48:26 +0800
commitf7c634fd5e7c337bf4314da19c630d3bbce3842b (patch)
tree9a21a0a64a56e4e639c6ebabde52e7023a66ecc2 /misc
parentceeb78bd6684d92427f594339c8530df292afaf8 (diff)
downloadfreebsd-ports-f7c634fd5e7c337bf4314da19c630d3bbce3842b.tar.gz
freebsd-ports-f7c634fd5e7c337bf4314da19c630d3bbce3842b.tar.zst
freebsd-ports-f7c634fd5e7c337bf4314da19c630d3bbce3842b.zip
Re-update to 1.03r with a hotfix from the author. PORTREVISION is set
to 1 now due to this whole matter. Submitted by: MAINTAINER
Notes
Notes: svn path=/head/; revision=41198
Diffstat (limited to 'misc')
-rw-r--r--misc/fd/Makefile3
-rw-r--r--misc/fd/distinfo2
-rw-r--r--misc/fd/files/patch-browse.c11
-rw-r--r--misc/fd/files/patch-shell.c12
4 files changed, 26 insertions, 2 deletions
diff --git a/misc/fd/Makefile b/misc/fd/Makefile
index a8f9405650e9..5e9e5bcc8ef2 100644
--- a/misc/fd/Makefile
+++ b/misc/fd/Makefile
@@ -6,7 +6,8 @@
#
PORTNAME= fd
-PORTVERSION= 1.03q
+PORTVERSION= 1.03r
+PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= http://hp.vector.co.jp/authors/VA012337/soft/fd/ \
${MASTER_SITE_LOCAL}
diff --git a/misc/fd/distinfo b/misc/fd/distinfo
index fa7d5c8db707..7bfd0e945495 100644
--- a/misc/fd/distinfo
+++ b/misc/fd/distinfo
@@ -1 +1 @@
-MD5 (FD-1.03q.tar.gz) = 9b4ee116be9916817cc4d1dfd3d22442
+MD5 (FD-1.03r.tar.gz) = 943d17ccc6257340c29db8362bac67fa
diff --git a/misc/fd/files/patch-browse.c b/misc/fd/files/patch-browse.c
new file mode 100644
index 000000000000..e3c8c7e1cbe6
--- /dev/null
+++ b/misc/fd/files/patch-browse.c
@@ -0,0 +1,11 @@
+diff -urNP ../FD-1.03r/browse.c ./browse.c
+--- ../FD-1.03r/browse.c Tue Apr 3 00:00:00 2001
++++ ./browse.c Tue Apr 10 00:00:00 2001
+@@ -1305,6 +1305,7 @@
+ }
+ else if (_chdir2(cp) >= 0) strcpy(tmp, cp);
+ else {
++ *fullpath = '\0';
+ warning(-1, cp);
+ def = NULL;
+ strcpy(fullpath, origpath);
diff --git a/misc/fd/files/patch-shell.c b/misc/fd/files/patch-shell.c
new file mode 100644
index 000000000000..942eff6f7d06
--- /dev/null
+++ b/misc/fd/files/patch-shell.c
@@ -0,0 +1,12 @@
+diff -urNP ../FD-1.03r/shell.c ./shell.c
+--- ../FD-1.03r/shell.c Tue Apr 3 00:00:00 2001
++++ ./shell.c Tue Apr 10 00:00:00 2001
+@@ -240,7 +240,7 @@
+ if (flags & (F_NOEXT | F_TOSFN));
+ else if (c == '%') c = command[++i];
+ else {
+- line[j++] = c;
++ line[j++] = command[i];
+ #if !MSDOS
+ if (command[i] == META && command[i + 1]
+ && uneval != '\'')