aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2009-03-20 01:28:51 +0800
committerbsam <bsam@FreeBSD.org>2009-03-20 01:28:51 +0800
commitb5b6ef339af6e9567c4016e6901e2bfe99d8929d (patch)
treeae0eafd06267e327a81b96ea5185410d99119e0b /net-im
parent0204725af4e2f2a52e65017bb4dc7820bee39bab (diff)
downloadfreebsd-ports-b5b6ef339af6e9567c4016e6901e2bfe99d8929d.tar.gz
freebsd-ports-b5b6ef339af6e9567c4016e6901e2bfe99d8929d.tar.zst
freebsd-ports-b5b6ef339af6e9567c4016e6901e2bfe99d8929d.zip
Welcome to the new linux ports infrastructure which allows using
both current (fc4) and future linux (f8) distributions at one ports tree. The patch contains full changes to ports/Mk files and all ports involved. But only infrastructure is changed. The resulting packages are the same as before. Hence no need to bump PORTREVISIONs. The idea was taken from bsd.gnome.mk and others. More than 130 ports are switched to follow a new linux infrastructure introduced by changes to bsd.port.mk, bsd.linux-rpm.mk and a new bsd.linux-apps.mk. Thanks for all who was involved and helped me with this work. And help from Alexander Leidinger was incredible. Other changes are coming. Stay tuned! PR: ports/132510 Submitted by: bsam (me) Exp-run by: portmgr (pav)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/aim/Makefile4
-rw-r--r--net-im/skype/Makefile8
-rw-r--r--net-im/skype12/Makefile4
-rw-r--r--net-im/skype20/Makefile8
4 files changed, 6 insertions, 18 deletions
diff --git a/net-im/aim/Makefile b/net-im/aim/Makefile
index f8241aee817b..42cc44f8029b 100644
--- a/net-im/aim/Makefile
+++ b/net-im/aim/Makefile
@@ -16,11 +16,9 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= AOL's Instant Messenger (AIM) client
-RUN_DEPENDS= ${LINUXBASE}/usr/lib/libgtk-1.2.so.0:${PORTSDIR}/x11-toolkits/linux-gtk
-
ONLY_FOR_ARCHS= i386 amd64
USE_LINUX= yes
-USE_XLIB= yes
+USE_LINUX_APPS= gtk xorglibs
NO_WRKSUBDIR= yes
NO_BUILD= yes
USE_LDCONFIG= yes
diff --git a/net-im/skype/Makefile b/net-im/skype/Makefile
index d24c4ab5c756..916099b2eaa0 100644
--- a/net-im/skype/Makefile
+++ b/net-im/skype/Makefile
@@ -18,20 +18,16 @@ DISTNAME= skype_static-${DISTVERSION}-oss
MAINTAINER= beech@FreeBSD.org
COMMENT= P2P VoIP software
-RUN_DEPENDS= ${LINUXBASE}/usr/lib/libfontconfig.so.1:${PORTSDIR}/x11-fonts/linux-fontconfig \
- ${LINUXBASE}/usr/lib/libexpat.so.0:${PORTSDIR}/textproc/linux-expat \
- ${LINUXBASE}/usr/lib/libsigc-2.0.so.0:${PORTSDIR}/devel/linux-libsigc++20 \
- ${LINUXBASE}/lib/libasound.so.2:${PORTSDIR}/audio/linux-alsa-lib
-
.ifdef WITH_NVIDIA_GL
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
-USE_XLIB= yes
+USE_LINUX_APPS+=xorglibs
.else
USE_GL= linux
.endif
USE_BZIP2= yes
USE_LINUX= yes
+USE_LINUX_APPS+=alsalib expat fontconfig libsigcpp20
RESTRICTED= Redistribution prohibited.
WRKSRC= ${WRKDIR}/${PORTNAME}_static-${DISTVERSION}-oss
diff --git a/net-im/skype12/Makefile b/net-im/skype12/Makefile
index 8418e16e905d..70ff3caea62b 100644
--- a/net-im/skype12/Makefile
+++ b/net-im/skype12/Makefile
@@ -14,11 +14,9 @@ DISTNAME= skype_staticQT-${PORTVERSION}
MAINTAINER= beech@FreeBSD.org
COMMENT= Legacy version P2P VoIP software
-RUN_DEPENDS= ${LINUXBASE}/usr/lib/libfontconfig.so.1:${PORTSDIR}/x11-fonts/linux-fontconfig \
- ${LINUXBASE}/usr/lib/libexpat.so.0:${PORTSDIR}/textproc/linux-expat
-
USE_BZIP2= yes
USE_LINUX= yes
+USE_LINUX_APPS= expat fontconfig
PORTDOCS= LICENSE README
SUB_FILES= pkg-message
diff --git a/net-im/skype20/Makefile b/net-im/skype20/Makefile
index d24c4ab5c756..916099b2eaa0 100644
--- a/net-im/skype20/Makefile
+++ b/net-im/skype20/Makefile
@@ -18,20 +18,16 @@ DISTNAME= skype_static-${DISTVERSION}-oss
MAINTAINER= beech@FreeBSD.org
COMMENT= P2P VoIP software
-RUN_DEPENDS= ${LINUXBASE}/usr/lib/libfontconfig.so.1:${PORTSDIR}/x11-fonts/linux-fontconfig \
- ${LINUXBASE}/usr/lib/libexpat.so.0:${PORTSDIR}/textproc/linux-expat \
- ${LINUXBASE}/usr/lib/libsigc-2.0.so.0:${PORTSDIR}/devel/linux-libsigc++20 \
- ${LINUXBASE}/lib/libasound.so.2:${PORTSDIR}/audio/linux-alsa-lib
-
.ifdef WITH_NVIDIA_GL
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
-USE_XLIB= yes
+USE_LINUX_APPS+=xorglibs
.else
USE_GL= linux
.endif
USE_BZIP2= yes
USE_LINUX= yes
+USE_LINUX_APPS+=alsalib expat fontconfig libsigcpp20
RESTRICTED= Redistribution prohibited.
WRKSRC= ${WRKDIR}/${PORTNAME}_static-${DISTVERSION}-oss