aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/arpscan
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2006-10-07 15:06:57 +0800
committerrafan <rafan@FreeBSD.org>2006-10-07 15:06:57 +0800
commit739739a8d613ff6c7156e20a8fe93deb9b89348f (patch)
tree6b0db6ba4ff603b85c7c59f772a5053a8385f9f4 /net-mgmt/arpscan
parent4f79375ba0bcc8c60b9c0d4d1a6eed0b014a544d (diff)
downloadfreebsd-ports-739739a8d613ff6c7156e20a8fe93deb9b89348f.tar.gz
freebsd-ports-739739a8d613ff6c7156e20a8fe93deb9b89348f.tar.zst
freebsd-ports-739739a8d613ff6c7156e20a8fe93deb9b89348f.zip
- Update to 0.3
PR: ports/103538 Submitted by: Nils Vogels <nivo+kw+ports.bfa274 at is-root.com> (maintainer) Approved by: maintainer timeout (14 days)
Diffstat (limited to 'net-mgmt/arpscan')
-rw-r--r--net-mgmt/arpscan/Makefile11
-rw-r--r--net-mgmt/arpscan/distinfo6
-rw-r--r--net-mgmt/arpscan/files/patch-arpscan.c22
3 files changed, 20 insertions, 19 deletions
diff --git a/net-mgmt/arpscan/Makefile b/net-mgmt/arpscan/Makefile
index 282335ae04d6..0fb3391afb8b 100644
--- a/net-mgmt/arpscan/Makefile
+++ b/net-mgmt/arpscan/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= arpscan
-PORTVERSION= 0.2
-PORTREVISION= 1
+PORTVERSION= 0.3
CATEGORIES= net-mgmt
-MASTER_SITES= http://ish.cx/~jason/arpscan/
+MASTER_SITES= http://ish.cx/~jason/arpscan/ \
+ http://unx.ca/~jason/arpscan/
MAINTAINER= dyeske@yahoo.com
COMMENT= Simple arp scanner
@@ -17,14 +17,15 @@ COMMENT= Simple arp scanner
LIB_DEPENDS= dnet.1:${PORTSDIR}/net/libdnet
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL} \
+ --with-libdnet=${LOCALBASE}
PLIST_FILES= bin/arpscan
.include <bsd.port.pre.mk>
.if ${OSVERSION} <= 500000
-IGNORE= "unknown BIOCSETIF error"
+IGNORE= unknown BIOCSETIF error
.endif
.include <bsd.port.post.mk>
diff --git a/net-mgmt/arpscan/distinfo b/net-mgmt/arpscan/distinfo
index ba114e1d7367..bf6973c5d44d 100644
--- a/net-mgmt/arpscan/distinfo
+++ b/net-mgmt/arpscan/distinfo
@@ -1,3 +1,3 @@
-MD5 (arpscan-0.2.tar.gz) = a832c8946dc9e2d66c8fa02a7a8b8059
-SHA256 (arpscan-0.2.tar.gz) = 7f6480a8558e0d0bc6f97f3f55a3cf25c3ff5e39a29e2954957f453da42dfab2
-SIZE (arpscan-0.2.tar.gz) = 35462
+MD5 (arpscan-0.3.tar.gz) = ebf3aab6c1abf67961592788230b9382
+SHA256 (arpscan-0.3.tar.gz) = 27a2bf1e3b4bf28b976b7e7da26d01ce99d9dc227fd174989dbfa6f164a573f4
+SIZE (arpscan-0.3.tar.gz) = 58052
diff --git a/net-mgmt/arpscan/files/patch-arpscan.c b/net-mgmt/arpscan/files/patch-arpscan.c
index c06e55310731..ee400d55ef44 100644
--- a/net-mgmt/arpscan/files/patch-arpscan.c
+++ b/net-mgmt/arpscan/files/patch-arpscan.c
@@ -1,6 +1,6 @@
---- arpscan.c.orig Mon Aug 18 22:54:25 2003
-+++ arpscan.c Fri Sep 22 16:55:48 2006
-@@ -8,7 +8,9 @@
+--- arpscan.c.orig Wed Aug 2 08:31:32 2006
++++ arpscan.c Sun Sep 24 04:31:06 2006
+@@ -9,7 +9,9 @@
#include <sys/socket.h>
#include <netinet/in.h>
#include <arpa/inet.h>
@@ -9,10 +9,10 @@
+#include <stdlib.h>
#include <string.h>
#include <unistd.h>
-
-@@ -17,6 +19,13 @@
-
- #define PCAP_TIMEO 20
+ #include <fcntl.h>
+@@ -22,6 +24,13 @@
+ #include <dnet.h>
+ #endif /* DUMBNET */
+#ifdef __FreeBSD__
+# include <sys/param.h>
@@ -21,10 +21,10 @@
+# endif
+#endif
+
- struct ether_arp {
- struct arp_hdr ea_hdr;
- u_int8_t arp_sha[ETH_ADDR_LEN];
-@@ -36,7 +45,7 @@
+ /* A concatenation of dnet's arp_hdr and arp_ethip. */
+ struct ether_arp {
+ struct arp_hdr arp_hdr;
+@@ -45,7 +54,7 @@
fprintf(stderr, "\teg)\n");
fprintf(stderr, "\t %s 172.16.1.11\n", __progname);
fprintf(stderr, "\t %s 192.168.1.100-192.168.1.200\n", __progname);