aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorkoitsu <koitsu@FreeBSD.org>2008-02-19 18:52:00 +0800
committerkoitsu <koitsu@FreeBSD.org>2008-02-19 18:52:00 +0800
commitd01caf8423425e7c2890780054b574257706c070 (patch)
tree1d40fdab7cc4805440ee53fc2a355d91929854de /net-mgmt
parent98100475a1aded6e7aa0a324380b436e3c3c87c4 (diff)
downloadfreebsd-ports-d01caf8423425e7c2890780054b574257706c070.tar.gz
freebsd-ports-d01caf8423425e7c2890780054b574257706c070.tar.zst
freebsd-ports-d01caf8423425e7c2890780054b574257706c070.zip
Remove IGNORE; add UID 141 to ports/UIDs, and remove unnecessary Time::HiRes
dependency (unless using a perl older than 5.8.7). Confirmed as working on RELENG_6.
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/cricket/Makefile23
1 files changed, 13 insertions, 10 deletions
diff --git a/net-mgmt/cricket/Makefile b/net-mgmt/cricket/Makefile
index 1e251f1de635..80c01f992953 100644
--- a/net-mgmt/cricket/Makefile
+++ b/net-mgmt/cricket/Makefile
@@ -16,16 +16,18 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A high performance, extremely flexible monitoring system
-RUN_DEPENDS= ${SITE_PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
- ${SITE_PERL_ARCH}/RRDs.pm:${PORTSDIR}/databases/rrdtool \
- ${SITE_PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes \
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/${PERL_ARCH}/RRDs.pm:${PORTSDIR}/databases/rrdtool \
${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
${SITE_PERL}/SNMP_Session.pm:${PORTSDIR}/net-mgmt/p5-SNMP_Session \
${SITE_PERL}/Time/Zone.pm:${PORTSDIR}/devel/p5-TimeDate
-IGNORE= uses a UID registered to another port
+.include <bsd.port.pre.mk>
-SITE_PERL_ARCH= ${SITE_PERL}/${PERL_ARCH}
+# A reliable version of Time::HiRes is included with perl 5.8.7 and later.
+.if ${PERL_LEVEL} < 500807
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+.endif
HAS_CONFIGURE= yes
USE_PERL5= yes
@@ -33,10 +35,11 @@ NO_BUILD= yes
PLIST_SUB+= VERSION=${PORTVERSION}
SUB_FILES= pkg-message pkg-install
SUB_LIST= USER="${CRICKET_USER}" GROUP="${CRICKET_GROUP}" UID="${CRICKET_UID}" GID="${CRICKET_GID}"
-CRICKET_USER?= wwwadm
-CRICKET_UID?= 81
-CRICKET_GROUP?= www
-CRICKET_GID?= 80
+# UID and username comes from ports/UIDs.
+CRICKET_USER= cricket
+CRICKET_UID= 141
+CRICKET_GROUP= www
+CRICKET_GID= 80
post-patch:
@${REINPLACE_CMD} -e 's,/home/cricket,${PREFIX},g' \
@@ -66,4 +69,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>